Solved

how to fix useraccount

Posted on 2013-02-07
40
219 Views
Last Modified: 2013-02-10
Hi Experts,

I have a very strange problem with my useraccount.
Exchange server is 2007 on Win2008 Server x64.
Outlook is 2007.

1. I can login to windows with my credentials and I can reset my password with AD.

2. When I try to open outlook, it always ask NEED PASSWORD. It is not working to enter my windows password, but this worked the last 4 years.

3. I tried webmail, and with my user it is not working, with other users it works.

4. I think here is a glitch of permissions between my useraccount and the mailbox.

5. Another user I gave full access permission to my mailbox. In outlook, I entered the credentials of the other user and I was online with outlook and my mailbox.

Please can you help me to reset all the permissions between mailbox and user account and or the inheritance ?
Is there a way to reset all without loosing my mailbox?
0
Comment
Question by:Eprs_Admin
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 22
  • 11
  • 3
  • +2
40 Comments
 
LVL 21

Accepted Solution

by:
jvuz earned 84 total points
ID: 38863166
Try to delete your mail profile (start/control panel/mail) and create it again.
0
 
LVL 1

Assisted Solution

by:theithelp
theithelp earned 28 total points
ID: 38863171
Hi  there,

Do I understand this correct if:

When you log in with your user account and try to open Outlook, a loginprompt pops up and wants you to enter your password?

If that is the case:

I have come across this issue a few times, and it is usually resolved by clearing the Windows Vault.
0
 
LVL 42

Assisted Solution

by:sedgwick
sedgwick earned 84 total points
ID: 38863179
did u try both:
SERVERNAME\UserName

and
DOMAINNAME\UserName
0
Are your AD admin tools letting you down?

Managing Active Directory can get complicated.  Often, the native tools for managing AD are just not up to the task.  The largest Active Directory installations in the world have relied on one tool to manage their day-to-day administration tasks: Hyena. Start your trial today.

 

Author Comment

by:Eprs_Admin
ID: 38863201
Hi jvuz,

to create a new profile is not possible, see the pic.
But the connection to exchange is ok.new profile error
0
 

Author Comment

by:Eprs_Admin
ID: 38863203
Hi theithelp,

yes it is exactly this behavior.
How to fix this Windows Vault ?
0
 

Author Comment

by:Eprs_Admin
ID: 38863208
Hi sedgwick,

yes I tried both.
Nothing works.
I cannot login to my mailbox with my AD credentials.
Hope you have an idea to fix this glitch.
0
 
LVL 42

Assisted Solution

by:sedgwick
sedgwick earned 84 total points
ID: 38863215
can u check on iis if ssl is required?
0
 
LVL 52

Assisted Solution

by:Manpreet SIngh Khatra
Manpreet SIngh Khatra earned 304 total points
ID: 38863217
Any cached credentials on the machine ?
Check "Alloww Inheritable" is selected :)
Was this working earlier ? Check Self permissions on the Mailbox and AD account

- Rancy
0
 
LVL 42

Assisted Solution

by:sedgwick
sedgwick earned 84 total points
ID: 38863220
did u install Exchange 2007 SP2?
0
 
LVL 21

Assisted Solution

by:jvuz
jvuz earned 84 total points
ID: 38863242
http://answers.microsoft.com/en-us/office/forum/office_2007-office_install/the-name-cannot-be-resolved-the-connection-to/806264c9-2052-499f-a68c-ad4a24539af3

I was able to solve this issue by including the following in the exchange connection settings:

enable "Connect to Microsoft Exchange using HTTP"

in Exchange Proxy Settings:

enter the webmail domain (ex: email.domain.com)

Connect using SSL - checked
connect to proxy servers that have this principal name in their certificate

msstd:"email.domain.com"

Basic authentication  for "use this authentication when connecting to my proxy server for Exchange"
0
 

Author Comment

by:Eprs_Admin
ID: 38863249
Hi sedgwick
where to check ssl in detail ?
0
 

Author Comment

by:Eprs_Admin
ID: 38863303
Hi Rancy,
where to check this in detail ?

Hi sedgwick,
the latest SP's are installed.
0
 

Author Comment

by:Eprs_Admin
ID: 38863401
Hi jvuz,

where to set this changes, but in detail please.
On the server or the client , AD or Exchange ?
0
 
LVL 21

Assisted Solution

by:jvuz
jvuz earned 84 total points
ID: 38863419
0
 

Author Comment

by:Eprs_Admin
ID: 38863455
sorry JVUZ,
this is not working, same problem need password in a loop.

What about permissions or inhertance for my user?
0
 
LVL 52

Assisted Solution

by:Manpreet SIngh Khatra
Manpreet SIngh Khatra earned 304 total points
ID: 38863466
Any cached credentials on the machine ? - What is the version of Windows OS
Check "Alloww Inheritable" is selected :) - This is on the Propertie so of teh Account (Security Tab)
Was this working earlier ? Check Self permissions on the Mailbox and AD account - EMC Mailbox right click "Manage Full Mailbox Access"

- Rancy
0
 

Author Comment

by:Eprs_Admin
ID: 38863499
Hi Rancy,

1. no credentials are cached here
2. The os is Win7 Pro x64
3. When I go to AD and check the account and the security, under Advanced many permission entries in. But INCLUDE INHERITABLE PERMISSION FROM THIS OBJECT is not selected.

4. It was working until yesterday 5pm
5. SELF permission are set on AD and Mailbox for my account
6. And I have full access to my mailbox under MANAGE FULL MAILBOX ACCESS.
0
 
LVL 52

Assisted Solution

by:Manpreet SIngh Khatra
Manpreet SIngh Khatra earned 304 total points
ID: 38863548
3.) Should be :)

- Rancy
0
 

Author Comment

by:Eprs_Admin
ID: 38863570
Are you sure, because it is also not set for the other users in the AD ?
0
 
LVL 52

Assisted Solution

by:Manpreet SIngh Khatra
Manpreet SIngh Khatra earned 304 total points
ID: 38863685
Yes i am Damn sure as only reason to uncheck is if you make some changes on the OU or Upper level and you dont want that to Propogate to clhild objects

- Rancy
0
 

Author Comment

by:Eprs_Admin
ID: 38864016
ok I did it, but no changes, still asking NEED PASSWORD
0
 

Author Comment

by:Eprs_Admin
ID: 38864155
I made now a lot of tests.

I connected another mailbox to my test user and could start outlook and was connected.
Then I took another mailbox and connected this also to my test user. worked.

Now I connected my mailbox to the test user and here is the same, I cannot login with outlook. I tested credential from test user and my. no way to be connected.

Does a restore of the mailbox maybe help ?
Is the mailbox corrupted ?
Can I scan my mailbox wit a tool to check what is wrong ?
0
 
LVL 52

Assisted Solution

by:Manpreet SIngh Khatra
Manpreet SIngh Khatra earned 304 total points
ID: 38864203
Does a restore of the mailbox maybe help ? - I would say Export data using Exchange, Delete Mailbox and create a new one test login and Import PST

- Rancy
0
 

Author Comment

by:Eprs_Admin
ID: 38864279
cannot export to PST, have always errors.
Other mailboxes I could export to pst file.
0
 

Author Comment

by:Eprs_Admin
ID: 38864282
but first I want to scan the mailbox against errors.
Do you know a tool for it ?
0
 
LVL 52

Assisted Solution

by:Manpreet SIngh Khatra
Manpreet SIngh Khatra earned 304 total points
ID: 38864304
There is no such tool you can simply try to move force update attributes ...

- Rancy
0
 

Author Comment

by:Eprs_Admin
ID: 38864378
what about isinteg.exe ?
0
 
LVL 52

Assisted Solution

by:Manpreet SIngh Khatra
Manpreet SIngh Khatra earned 304 total points
ID: 38864491
Yes thats for the entire Database .... if you want to run yes but that means downtime for all users till its running

- Rancy
0
 

Author Comment

by:Eprs_Admin
ID: 38864893
Hi Experts,

i told you I have tested a lot with different user and mailboxes.
Now I have my system back online. And I can use my mailbox.

Are you interested in this solution ?
0
 
LVL 52

Assisted Solution

by:Manpreet SIngh Khatra
Manpreet SIngh Khatra earned 304 total points
ID: 38865193
Yes i would surely like to know what you did :)

- Rancy
0
 

Author Comment

by:Eprs_Admin
ID: 38867195
1. I disabled my mailbox
2. I deleted my AD user account
3. I created my account new with same name
4. I connected my mailbox to my new user
5. I checked the full access permission rights and edited my

Done.
I was able to connect to my outlook again.
0
 

Author Comment

by:Eprs_Admin
ID: 38867210
...and today after some office updates I have the same problem again.
But I think it is not the update.

When I check the Full Access Permission, I see now two times my username in.
This is because I deleted my account and forgot this permission.

Do you know some commands to clean this up, so both entries are out ?
See the picture how its looks like now.

You see two equal entries, but I can just delete one.
When I delete the second one, and error comes:
full-access-permissions.PNG
0
 

Author Comment

by:Eprs_Admin
ID: 38867471
ok, some news.
the second entry I could delete, after I restarted the exchange server.
Then just the sid was shown and I deleted it.
0
 

Author Comment

by:Eprs_Admin
ID: 38867475
Now the settings under FULL ACCESS PERMISSION are the same like from other users.
But still the error or loop NEED PASSWORD.

I changed my password within ADUC, but this also not helps.

Any more ideas ?
0
 
LVL 52

Assisted Solution

by:Manpreet SIngh Khatra
Manpreet SIngh Khatra earned 304 total points
ID: 38867478
Ohk so now everything is working fine for you :)

- Rancy
0
 
LVL 52

Assisted Solution

by:Manpreet SIngh Khatra
Manpreet SIngh Khatra earned 304 total points
ID: 38867486
Did you just remove the Mailbox or both Mailbox and Ad account ?

Sorry my last message was after i saw your post "ID: 38867471" :(

- Rancy
0
 

Author Comment

by:Eprs_Admin
ID: 38867538
I removed both, ad account and mailbox.
But now still the same problem.
0
 
LVL 52

Assisted Solution

by:Manpreet SIngh Khatra
Manpreet SIngh Khatra earned 304 total points
ID: 38867610
Thats aweful as removing both and creating new ones should be more like new

What groups is your account member of

- Rancy
0
 

Author Comment

by:Eprs_Admin
ID: 38873027
Hi Rancy,

I will close this ticket and give points to all here.
Because you took your time.
I will open an new ticket regarding exchange and RSG.
0
 

Author Closing Comment

by:Eprs_Admin
ID: 38873034
just to info, this case is not solved.
But thanks to all.
Maybe this is helpful for someone else.
0

Featured Post

Edgartown IT Case Study

Learn about Edgartown's quest to ensure the safety and security of the entire town's employee and citizen data. Read the case study!

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

This article shows the method of using the Resultant Set of Policy Tool to locate Group Policy that applies a particular setting.
Recently, Microsoft released a best-practice guide for securing Active Directory. It's a whopping 300+ pages long. Those of us tasked with securing our company’s databases and systems would, ideally, have time to devote to learning the ins and outs…
This Micro Tutorial hows how you can integrate  Mac OSX to a Windows Active Directory Domain. Apple has made it easy to allow users to bind their macs to a windows domain with relative ease. The following video show how to bind OSX Mavericks to …
This video shows how to use Hyena, from SystemTools Software, to bulk import 100 user accounts from an external text file. View in 1080p for best video quality.

730 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question