Want to protect your cyber security and still get fast solutions? Ask a secure question today.Go Premium

x
?
Solved

Wildcard certificate on Exchange 2010 IMAP\POP

Posted on 2013-02-07
8
Medium Priority
?
1,757 Views
Last Modified: 2013-11-29
Hi,
I am trying to use wildcard certificate on IMAP\POP services and require some help.
I'm using the following commands:
set-imapsettings -X509CertificateName mail.domain.com
set-popsettings -X509CertificateName mail.domain.com
enable-exchangecertificate -services POP,IMAP -thumbprint

And the result is:
Warning:
This certificate with thumbprint 0A02849AA284B4DB1D1670DCA1C6310BA7241864 and subject '*.domain.com' cannot used for POP SSL/TLS connections because the subject is not a Fully Qualified Domain Name (FQDN). Use command Set-POPSettings to set X509CertificateName to the FQDN of the service.

Warning:
This certificate with thumbprint 0A02849AA284B4DB1D1670DCA1C6310BA7241864 and subject '*.domain.com' cannot used for IMAP SSL/TLS connections because the subject is not a Fully Qualified Domain Name (FQDN). Use command Set-IMAPSettings to set X509CertificateName
to the FQDN of the service.

Can you please advice?
0
Comment
Question by:cloudbase
  • 4
6 Comments
 
LVL 19

Expert Comment

by:Kash
ID: 38864334
are you on service pack 1 >>>> http://support.microsoft.com/kb/948896
0
 

Author Comment

by:cloudbase
ID: 38865815
Actually I'm on Exchange 2010 SP2
0
 
LVL 15

Expert Comment

by:Antonio Vargas
ID: 38872198
you get those two warnings when running the enable-exchangecertificate, right?

the thing is.. you dont need to run the enable exchangecertificate.. you just need to set the pop and imapsettings with the fqdn that the users will connect to... after you've imported the certificate. please test and post the results.
0
Industry Leaders: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

 

Author Comment

by:cloudbase
ID: 38872462
Hi,

Thanks, I'm not sure that I completely understood it.
The certificate was imported and it is in use by IIS services.
The FQDN was set for pop\imap, now, I don't need to enable the certificate to have IMAP\POP with SSL?
0
 

Accepted Solution

by:
cloudbase earned 0 total points
ID: 38980294
We replaced the wildcard with SAN certificate and everything works.
0
 

Author Closing Comment

by:cloudbase
ID: 38993131
none of the other solutions worked, so we bought SAN certificate.
0

Featured Post

Independent Software Vendors: We Want Your Opinion

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

If you have come across a situation where you need to find some EDB mailbox recovery techniques, then here you will find the same. In this article, we will take you through three techniques using which you will be able to perform EDB recovery. You …
Exchange administrators are always vigilant about Exchange crashes and disasters that are possible any time. It is quite essential to identify the symptoms of a possible Exchange issue and be prepared with a proper recovery plan. There are multiple…
To show how to generate a certificate request in Exchange 2013. We show this process by using the Exchange Admin Center. Log into Exchange Admin Center.:  First we need to log into the Exchange Admin Center. Navigate to the Servers >> Certificates…
Whether it be Exchange Server Crash Issues, Dirty Shutdown Errors or Failed to mount error, Stellar Phoenix Mailbox Exchange Recovery has always got your back. With the help of its easy to understand user interface and 3 simple steps recovery proced…
Suggested Courses

571 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question