Go Premium for a chance to win a PS4. Enter to Win

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 2016
  • Last Modified:

Internet Address is not valid

When saving an Excel file back in the database the user receives: The Internet address' http://...xls'  is not valid. Sometimes it works and sometimes, usually, it does not.
See atatchment.
XLS-Not-valid.pdf
0
KBAguy
Asked:
KBAguy
  • 6
  • 5
1 Solution
 
Paul MacDonaldDirector, Information SystemsCommented:
It seems the saving computer is having trouble finding http://portal.keyfamily.local for some reason.  This is likely a DNS issue, but it's hard to say without knowing more about your network.

Also, I hope nothing in that screenshot is sensitive.
0
 
BobHavertyComhCommented:
The most simple thing to try first is to take your local copy and save it as a different name and load it up to SharePoint. Then, open it and save it back. If that works, then you can delete the original from SharePoint, and rename the new one to the original name, assuming all info in the docs are identical. Sometimes, there's a connection problem when a document had to be recovered on the client machine, while still maintaining an open link to SharePoint.
0
 
KBAguyAuthor Commented:
Neither solution resolved this issue. However, I had the user reduce the size the Excel file by removing some old history lines and so far the user is reporting NO issues.
0
What is SQL Server and how does it work?

The purpose of this paper is to provide you background on SQL Server. It’s your self-study guide for learning fundamentals. It includes both the history of SQL and its technical basics. Concepts and definitions will form the solid foundation of your future DBA expertise.

 
BobHavertyComhCommented:
Are your files bigger than the max upload setting in Central Admin?

By default SharePoint allows a maximum file size of 50MB that can be uploaded.
Application Management >> Web Application General Setting page. If it looks OK, this still might not be a size problem and instead something else and could come back up again. Is it possible that you could have removed something it didn't like in the spreadsheet itself?
0
 
KBAguyAuthor Commented:
Unfortunately not it. Maximum Upload size is setting at the default of 50MB. The file in question is only 2.48MB.
0
 
BobHavertyComhCommented:
What do you see when you go to your browser and enter the url from the error message minus the file name? Do you see the shared docs library? That's an odd url.
0
 
KBAguyAuthor Commented:
Yes I see the Shared Docs Library. It shows the document in question along with several others.
0
 
KBAguyAuthor Commented:
Even though the file in question was only 2.48MB, the only solution to-date has been to export it out into a new file name, reduce the number of lines and then save in it's reduced file size and add back into the library. They have not had a problem since.
0
 
BobHavertyComhCommented:
Do you have ForeFront AV? It scans files before they are uploaded into SharePoint and it treats them as "containers" so that it can do it's scan. There are settings for maximum container size and maximum scan timeout for ForeFront. I've seen this cause problems before, but your file size looks pretty small to cause this.

Or, maybe SharePoint itself doesn't like those rows for some reason if they violate a Sharepoint list rule in some way. It's possible that by invalid url in the error message, it really means invalid document that it references via it's url. So the url is actually the fully qualified doc name, and that is what is invalid. Have you ever been able to upload this doc with the apparently offending rows? If not, then that has to be your answer. Maybe the rows in question contain a duplicate row with another row that SharePoint doesn't like. You mentioned "history" rows. If you have been able to upload these rows in the past, then a broken link between this doc and SharePoint has occurred and is still left over. I would guess the former, assuming you have literally created a new doc locally, copied the contents of the failing doc into it, and tried uploading it as something that SharePoint has no previous connection to.
0
 
KBAguyAuthor Commented:
Per a previous post even though the file in question was only 2.48MB, the only solution to-date has been to export it out into a new file name, reduce the number of lines and then save in it's reduced file size and add back into the library. They have not had a problem since.
0
 
BobHavertyComhCommented:
There were a couple of questions that I asked such as if you were ever able to upload this doc in the past with the currently offending rows, but, if you're happy with your solution, then that's fine.
0
 
KBAguyAuthor Commented:
It's the only solution that has satisfied the user and I don't currently have the time to pursue this issue any further.
0

Featured Post

VIDEO: THE CONCERTO CLOUD FOR HEALTHCARE

Modern healthcare requires a modern cloud. View this brief video to understand how the Concerto Cloud for Healthcare can help your organization.

  • 6
  • 5
Tackle projects and never again get stuck behind a technical roadblock.
Join Now