Link to home
Start Free TrialLog in
Avatar of odewulf
odewulfFlag for United States of America

asked on

cisco Asa 5505 IPSec vpn

I am setting up an ipsec vpn tunnel but i am getting this error when enabling the crypto isakmp enable outside

Crypto ikev1 enable outside

Ikerereceiverinit, unable to bind to port

there are no blocked ports that I am aware of.

I've never had an issue with any other setup

let me know what you think

thank you

Gaetan
Avatar of Marius Gunnerud
Marius Gunnerud
Flag of Norway image

Do you have any NAT/PAT configuration for UDP port 500 and/or 4500?  If so, you will need to remove this configuration, then clear xlate, then add the crypto map to the interface.
Avatar of Pete Long
Yep

From http://www.cisco.com/en/US/products/ps6120/products_tech_note09186a00807e0aca.shtml

You can also get this error when you enable the ISAKMP on the outside interface:

UDP: ERROR - socket <unknown> 62465 in used
ERROR: IkeReceiverInit, unable to bind to port
The cause of the error can be that the Client behind ASA/PIS gets PAT'd to udp port 500 before isakmp can be enabled on the interface. Once that PAT translation is removed (clear xlate), the isakmp is able to be enabled.

Note: Always make sure that UDP 500 and 4500 port numbers are reserved for the negotiation of ISAKMP connections with the peer.
Avatar of odewulf

ASKER

those are the only Natting I have and they are the basic ones

nat (inside,outside) source static NETWORK_OBJ_10.6.2.0_24 NETWORK_OBJ_10.6.2.0_24 destination static NETWORK_OBJ_10.6.2.192_26 NETWORK_OBJ_10.6.2.192_26 no-proxy-arp route-lookup
!
object network obj_any
 nat (inside,outside) dynamic interface

Open in new window


here is the whole code, maybe I have been looking at it too long to find the issue

Result of the command: "sh run"

: Saved
:
ASA Version 8.4(4) 
!
hostname 
enable password b9HPeJMJmAKC9D8z encrypted
passwd 2KFQnbNIdI.2KYOU encrypted
names
!
interface Ethernet0/0
 switchport access vlan 2
 speed 100
 duplex full
!
interface Ethernet0/1
!
interface Ethernet0/2
!
interface Ethernet0/3
!
interface Ethernet0/4
!
interface Ethernet0/5
!
interface Ethernet0/6
!
interface Ethernet0/7
!
interface Vlan1
 nameif inside
 security-level 100
 ip address 10.6.2.90 255.255.255.0 
!
interface Vlan2
 nameif outside
 security-level 0
 ip address IP 255.255.255.248 
!
ftp mode passive
object network obj_any
 subnet 0.0.0.0 0.0.0.0
object network NETWORK_OBJ_10.6.2.0_24
 subnet 10.6.2.0 255.255.255.0
object network NETWORK_OBJ_10.6.2.192_26
 subnet 10.6.2.192 255.255.255.192
access-list inbound extended permit icmp any any echo 
access-list Watershed_splitTunnelAcl standard permit 10.6.2.0 255.255.255.0 
access-list group1_splitTunnelAcl standard permit 10.6.2.0 255.255.255.0 
pager lines 24
logging asdm informational
mtu inside 1500
mtu outside 1500
ip local pool VPNpool 10.6.2.200-10.6.2.250 mask 255.255.255.0
icmp unreachable rate-limit 1 burst-size 1
no asdm history enable
arp timeout 14400
nat (inside,outside) source static NETWORK_OBJ_10.6.2.0_24 NETWORK_OBJ_10.6.2.0_24 destination static NETWORK_OBJ_10.6.2.192_26 NETWORK_OBJ_10.6.2.192_26 no-proxy-arp route-lookup
!
object network obj_any
 nat (inside,outside) dynamic interface
route outside 0.0.0.0 0.0.0.0 GW 1
timeout xlate 3:00:00
timeout pat-xlate 0:00:30
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 icmp 0:00:02
timeout sunrpc 0:10:00 h323 0:05:00 h225 1:00:00 mgcp 0:05:00 mgcp-pat 0:05:00
timeout sip 0:30:00 sip_media 0:02:00 sip-invite 0:03:00 sip-disconnect 0:02:00
timeout sip-provisional-media 0:02:00 uauth 0:05:00 absolute
timeout tcp-proxy-reassembly 0:01:00
timeout floating-conn 0:00:00
dynamic-access-policy-record DfltAccessPolicy
user-identity default-domain LOCAL
http server enable
http 10.6.2.0 255.255.255.0 inside
http 0.0.0.0 0.0.0.0 outside
no snmp-server location
no snmp-server contact
snmp-server enable traps snmp authentication linkup linkdown coldstart warmstart
crypto ipsec ikev1 transform-set ESP-AES-256-MD5 esp-aes-256 esp-md5-hmac 
crypto ipsec ikev1 transform-set ESP-DES-SHA esp-des esp-sha-hmac 
crypto ipsec ikev1 transform-set ESP-3DES-SHA esp-3des esp-sha-hmac 
crypto ipsec ikev1 transform-set ESP-DES-MD5 esp-des esp-md5-hmac 
crypto ipsec ikev1 transform-set ESP-AES-192-MD5 esp-aes-192 esp-md5-hmac 
crypto ipsec ikev1 transform-set ESP-3DES-MD5 esp-3des esp-md5-hmac 
crypto ipsec ikev1 transform-set ESP-AES-256-SHA esp-aes-256 esp-sha-hmac 
crypto ipsec ikev1 transform-set ESP-AES-128-SHA esp-aes esp-sha-hmac 
crypto ipsec ikev1 transform-set ESP-AES-192-SHA esp-aes-192 esp-sha-hmac 
crypto ipsec ikev1 transform-set ESP-AES-128-MD5 esp-aes esp-md5-hmac 
crypto dynamic-map SYSTEM_DEFAULT_CRYPTO_MAP 65535 set pfs group1
crypto dynamic-map SYSTEM_DEFAULT_CRYPTO_MAP 65535 set ikev1 transform-set ESP-AES-128-SHA ESP-AES-128-MD5 ESP-AES-192-SHA ESP-AES-192-MD5 ESP-AES-256-SHA ESP-AES-256-MD5 ESP-3DES-SHA ESP-3DES-MD5 ESP-DES-SHA ESP-DES-MD5
crypto map outside_map 65535 ipsec-isakmp dynamic SYSTEM_DEFAULT_CRYPTO_MAP
crypto map outside_map interface outside
crypto map inside_map 65535 ipsec-isakmp dynamic SYSTEM_DEFAULT_CRYPTO_MAP
crypto map inside_map interface inside
crypto ikev1 policy 10
 authentication crack
 encryption aes-256
 hash sha
 group 2
 lifetime 86400
crypto ikev1 policy 20
 authentication rsa-sig
 encryption aes-256
 hash sha
 group 2
 lifetime 86400
crypto ikev1 policy 30
 authentication pre-share
 encryption aes-256
 hash sha
 group 2
 lifetime 86400
crypto ikev1 policy 40
 authentication crack
 encryption aes-192
 hash sha
 group 2
 lifetime 86400
crypto ikev1 policy 50
 authentication rsa-sig
 encryption aes-192
 hash sha
 group 2
 lifetime 86400
crypto ikev1 policy 60
 authentication pre-share
 encryption aes-192
 hash sha
 group 2
 lifetime 86400
crypto ikev1 policy 70
 authentication crack
 encryption aes
 hash sha
 group 2
 lifetime 86400
crypto ikev1 policy 80
 authentication rsa-sig
 encryption aes
 hash sha
 group 2
 lifetime 86400
crypto ikev1 policy 90
 authentication pre-share
 encryption aes
 hash sha
 group 2
 lifetime 86400
crypto ikev1 policy 100
 authentication crack
 encryption 3des
 hash sha
 group 2
 lifetime 86400
crypto ikev1 policy 110
 authentication rsa-sig
 encryption 3des
 hash sha
 group 2
 lifetime 86400
crypto ikev1 policy 120
 authentication pre-share
 encryption 3des
 hash sha
 group 2
 lifetime 86400
crypto ikev1 policy 130
 authentication crack
 encryption des
 hash sha
 group 2
 lifetime 86400
crypto ikev1 policy 140
 authentication rsa-sig
 encryption des
 hash sha
 group 2
 lifetime 86400
crypto ikev1 policy 150
 authentication pre-share
 encryption des
 hash sha
 group 2
 lifetime 86400
telnet 10.6.2.0 255.255.255.0 inside
telnet timeout 5
ssh timeout 5
ssh key-exchange group dh-group1-sha1
console timeout 0
management-access inside

dhcpd dns 66.28.0.45 66.28.0.61
!
dhcpd address 10.6.2.100-10.6.2.199 inside
dhcpd enable inside
!
threat-detection basic-threat
threat-detection statistics access-list
no threat-detection statistics tcp-intercept
webvpn
group-policy group1 internal
group-policy group1 attributes
 dns-server value 8.8.8.8 4.2.2.1
 vpn-tunnel-protocol ikev1 
 split-tunnel-policy tunnelspecified
 split-tunnel-network-list value group1_splitTunnelAcl
group-policy VPN internal
group-policy VPN attributes
 dns-server value 8.8.8.8 8.8.4.4
 vpn-tunnel-protocol ikev1 
 split-tunnel-policy tunnelspecified
 split-tunnel-network-list value VPN_splitTunnelAcl
username user nopassword privilege 0
username user attributes
 vpn-group-policy VPN
tunnel-group group1 type remote-access
tunnel-group group1 general-attributes
 address-pool VPNpool
 default-group-policy group1
tunnel-group group1 ipsec-attributes
 ikev1 pre-shared-key *****
!
class-map inspection_default
 match default-inspection-traffic
!
!
policy-map type inspect dns preset_dns_map
 parameters
  message-length maximum client auto
  message-length maximum 512
policy-map global_policy
 class inspection_default
  inspect dns preset_dns_map 
  inspect ftp 
  inspect h323 h225 
  inspect h323 ras 
  inspect rsh 
  inspect esmtp 
  inspect sqlnet 
  inspect skinny  
  inspect sunrpc 
  inspect xdmcp 
  inspect netbios 
  inspect tftp 
  inspect ip-options 
  inspect icmp 
policy-map asa_global_fw_policy
!
service-policy global_policy global
prompt hostname context 
no call-home reporting anonymous
Cryptochecksum:16014ce206f0758e1bcfe238ea609f1a
: end

Open in new window

have you checked the remote site to see if there is a NAT/PAT rule configure for UDP 500 and/or 4500?
Avatar of odewulf

ASKER

sorry there is no VPN tunnel just a regular VPN connection using the cisco VPN client
Are all users experiencing this issue?  Is this happening when connecting from a specific location?  What happens if you connect from another location?
Avatar of odewulf

ASKER

yes all users. it just doesn't allow me to configure it without that error. I tried with the VPN IPsec wizard and I get the same error
ASKER CERTIFIED SOLUTION
Avatar of Marius Gunnerud
Marius Gunnerud
Flag of Norway image

Link to home
membership
This solution is only available to members.
To access this solution, you must be a member of Experts Exchange.
Start Free Trial
Avatar of odewulf

ASKER

typing clear xlate worked

strange that it didn't it automatically every 3 hours

anyway it works now

thank you