Link to home
Create AccountLog in
Avatar of cpatte7372
cpatte7372Flag for United Kingdom of Great Britain and Northern Ireland

asked on

Windows Installer Package Won't Install

Hello Experts

I'm getting the following error message (see attached) each time I attempt to install an application.

Can someone please tell me how to overcome it?

Im running Windows 7 64 Bit

Cheers

Carlton
installer.jpg
ASKER CERTIFIED SOLUTION
Avatar of cpmcomputers
cpmcomputers
Flag of United Kingdom of Great Britain and Northern Ireland image

Link to home
membership
Create an account to see this answer
Signing up is free. No credit card required.
Create Account
Avatar of cpatte7372

ASKER

cpm,

Thanks for responding. I've tried installing with 'run as administrator'. The application is compatible with Windows 7 64 bit as I have installed it on my laptop.

The application is a SSL VPN application called cisco AnyConnect

http://software.cisco.com/download/release.html?mdfid=283000185&flowid=17001&softwareid=282364313&release=3.1.02040&relind=AVAILABLE&rellifecycle=&reltype=latest

Any other thoughts?

It was suggested that a common cause is firewall. But the firewall is disabled.
Apparently the install uses either activeX or java
This link may help (it suggests a problem with Internet explorer in protected mode)
In working through some options

https://faq.oit.gatech.edu/node/464
Hi cpm,

Thanks again for responding. I have been trying out the suggestions in the link, but still no luck.

I get the following error message (see attached)
anyconnect.jpg
CPM/Experts,

Its when I try to manually install the application when I get the 'Windows Installer Package' error.
Yes sorry I am following that I just thought that it may be an activeX java issue with the manual install (as opposed to the download method )
The error message refers to "a program run as part of the installer "
Seems there is some sort of problem with a helper process during the install ?
Interesting it does not give a specific error code?
Anything recorded in the event logs ?
Did you have an earlier version installed that has not been fully removed ?
If so, might be worth running a registry cleaner
I would also try deleting the contents of your temp folders in windows (a common install killer)
Just found this article
It covers an install error and fix (almost at the bottom of the item)
Also specifies where the install log files are stored ?
http://www.cisco.com/en/US/products/ps8411/products_qanda_item09186a00809aec31.shtml
cpm,

Thanks again for responding. Going to check out your suggestion now...
cpm,

From the link you provided, I strongly feel the issue relates to the following:

Q. AnyConnect VPN Client installation fails with this error message: Error 1722. There is a problem with this Windows Installer package. How can I resolve this issue?
 


A. AnyConnect installation fails with this error:

MSI (s) (D8:70) [14:59:10:750]: Product: Cisco AnyConnect VPN Client
-- Error 1722. There is a problem with this Windows Installer package

A program run as part of the setup did not finish as expected. Contact
 your support personnel or package vendor. Action VACon_Install,
      location: C:\Program Files\Cisco\Cisco AnyConnect VPN Client\VACon.exe, command:
      -install "C:\Program Files\Cisco\Cisco AnyConnect VPN Client\vpnva.inf" VPNVA
The 1722 error is an generic code for an MSI action failure. In this case, as revealed in the MSI log, the Virtual Adapter installer has failed. Therefore, you need to check whether this registry key is present or not: HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\RunOnce.

In addition, you can try one of these actions in order to resolve the issue:
 •
Execute this command in order to perform a quiet installation of AnyConnect:

 msiexec /quiet /norestart /i anyconnect.msi


Scan your registry for AnyConnect related bogus keys and remove them.
My thoughts entirely

They specify a fix
Must be worth a try

If it fails go to the log location and post them here ?
Hi cpm,

Thanks for sticking with me with this.

I'm not sure where the log location is?
Ok what I would do from here
Download ccleaner (from either piraform or filehippo websites ) google will give you the links to this free utility
Install it (make sure to deselect any google browser offers )

Run both the file and registry cleaner options
Don't worry if it finds a lot
Do backup registry (it will do this for you)

Then
Download a fresh copy of your cisco application install file

Disconnect from the Internet
Disable any Av/firewall software temporarily

Install program using run as administrator
(If unsuccessful the logs will be in the windows/temp folder (this is a hidden folder I will explain how to unhide it later if required)

If install is  successful re-enable av/Firewall and restore Internet connection

Let me know how it goes
I am going out shortly so there may be a delay before  I can get back to you
Cool.

I will give it a go and let you know how I get on.

Cheers

Carlton
I've requested that this question be closed as follows:

Accepted answer: 0 points for cpatte7372's comment #a38872848

for the following reason:

Cheers
Cheers mate.