Link to home
Create AccountLog in
Avatar of minniejp
minniejpFlag for United Kingdom of Great Britain and Northern Ireland

asked on

DPM 2010

All,

I have a strange problem with DPM 2010 Backup.  The backup to tape looks like it worked perfectly, however, when I got to do a restore, it is only giving me options to choose from disk and not from the tape.  When I check back at the logs, it shows the backup worked fine.

Also, as the backup worked fine to tape, I am still getting "backup to tape failed" within my protection group.....and finally, how long can I expect roughly for it to take to backup 1TB.

Cheers
Avatar of ArneLovius
ArneLovius
Flag of United Kingdom of Great Britain and Northern Ireland image

Unless the backup is to tape only, DPM does not backup to tape, it copies the disk backup to tape

The time it takes to write 1TB will depend on the Tape drive and the performance of the LUN storing the backup on disk.
Avatar of minniejp

ASKER

I am currently backing up to disk and then to tape for offsite storage.  If there is a problem with the network and i need to recover from tape, why is it not showing an option to recover from tape?

I'm not sure what you mean "unless the backup is to tape only, DPM does not backup to tape, it copies the disk backup to tape"...surely this is a backup to tape though that I need for offsite storage?

Cheers
a backup to tape (unless only tape is used) is a copy backup of a disk backup, it is not a backup that only goes to tape.

It will only ask you for a tape if it cannot supply the data to be restored from disk

Presuming that your tape retention is longer than your on disk retention, use the "calendar" on the recovery tab to go back in time, and you should see backups that are only on tape.

In the event of you losing the disk storage, you would re-index your tapes to be able to restore from them.
Yes the retention is longer than the disk retention.  When I use the calendar option, it shows me dates in the past but it doesn't let me select 2012.....it just defaults back to 2013.

What is strange is that the backup to tape looks like it is working but when I go into protection, it says the backup to tape failed.  Some times I log in and see the job is waiting for a tape and I have to force DPM to use the tapes that have been assigned, even though when i view the tapes content, it says expires on that particular date???
Then I would question is the tape backups  have completed.

I usually "mark as free" when I put tapes into the library,
I try to mark as free but then get a error message and I have to force it free using forcefree.ps1.  It shows as writting to the tape and it is available afterwards as well as disk but it still says failed.
I think it is possible that you do not have any good backups on tape.

I would suggest that you tried indexing the tapes to see if DPM can find anything on them, it will take some time to index, but then you will know if they actually contain anything...

What tape library do you have ?
Can you explain how to index?  It's a dell tape library, I can't remember the exact model.
When I checked the tapes this evening, the status tape is available.  When I try to mark it free I get the following error:

The selected tapes cannot be marked as free
because they belong to protection groups.

you need to stop protection of the associated
protection groups before you can mark the tapes
as free.

When I view the tapes contents the backup time was 26th March and expires today.

I only have one protection group, although I want/need to change this but what is the problem here?

Cheers
I'm fairly sure indexing can be done after "right clicking" on the tape
what do you think of my comment above?  why are the tapes not free to use?
There is a time as well as date on the expiry, but the console only shows the date...
where can i see the time?
I think you can expose it in a report, but I don't have a DPM 2010 to test against, I've been running 2012 for a while now...

Have you run an index on the tape yet ?
I found that the tapes I am using have an expiry date of i.e. today at 8pm but until a maintenance job is completed at midnight, the tapes are not marked as expired until then.  I found a URL online: http://support.microsoft.com/kb/2718797 of which I installed but following the install, the reg keys mentioned in this article were not created.I created them, restarted the server but still my tapes which should have expired still are not.

I am getting really sick of DPM.....
Any ideas?
ASKER CERTIFIED SOLUTION
Avatar of minniejp
minniejp
Flag of United Kingdom of Great Britain and Northern Ireland image

Link to home
membership
Create an account to see this answer
Signing up is free. No credit card required.
Create Account
Backup to tape was not including system states.