Modem Frustrations with CallerID

I have just installed a Conexant USB CX93010 ACF modem on Windows 7 64bit. This morning I set about trying to configure it to report caller ID. Using Putty I ran the command AT+VCID=1 and lo and behold it returned the caller ID. This afternoon I find that it no longer detects the callerid. I have tried ATZ and then reconfiguring the country in the windows applet. Then running AT+VCID=1 again. nothing. AT+VCID? returns 1 as I would expect. I'm tearing my hair out on this can anyone help?
LVL 1
cescentmanAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Davis McCarnOwnerCommented:
Are you calling the modem after initializing it?
Here ia an article on testing with Hyperterminal: http://www.talkingcallerid.com/CallerIDCapable.htm
0
cescentmanAuthor Commented:
Thanks for the response. Not sure what you mean: "... Are you calling the modem after initializing it ..."?

I'm using Windows7 64bit so no Hyperterminal hence using Putty. I have been through the tests on that link. The only command that doesn't return an error is AT+VCID=1:-

Putty console
0
Davis McCarnOwnerCommented:
That link I gave you suggested you may also need the AT#CLS=8 or AT+CLS=8 to put it into voice mode.
0
10 Tips to Protect Your Business from Ransomware

Did you know that ransomware is the most widespread, destructive malware in the world today? It accounts for 39% of all security breaches, with ransomware gangsters projected to make $11.5B in profits from online extortion by 2019.

cescentmanAuthor Commented:
As I say I have been through those tests before:-

More command errors
0
cescentmanAuthor Commented:
I have tried forcing voice mode AT+FCLASS=8, this doesn't solve the problem and inexplicably forces the modem to report a ring as R:-

Voice Mode
Here is the PDF with the commands for the modem:-

Modem-commands.pdf
For voice commands go to page 193.
0
Davis McCarnOwnerCommented:
I could not open that manual; but, found this: http://www.xmodus.ch/Downloads/XM3000S/XM3000S-A00-103.pdf
Section 3.3 covers voice commands and references a -SCID=1 command to allow CID before going off-hook.
I take it you have already cycled power on the modem to set it back to default?
0
cescentmanAuthor Commented:
Hmm section 3.3 of the PDF you have linked to appears to cover S-Parameters. IOt is I think the same one I posted. There's also a copy here:-

https://www.southcot.co.uk/TempFiles/Modem_commands.pdf

Yes I've powered cycled the modem a number of times.

Can you set out the AT commands line per line you feel I should be entering after it's been power cycled and I'll try them in that order?
0
Davis McCarnOwnerCommented:
There is a table at the bottom of page 3-4 which says the ATZ command disables ALL of the caller id options (!)
And, it says that all you need to do is issue AT-SCID=1 enables formatted caller id and line-in-use so that may be the only command you need.
ATZ
AT-SCID=1
P.S. I used the link I posted for the manual: http://www.xmodus.ch/Downloads/XM3000S/XM3000S-A00-103.pdf
0
cescentmanAuthor Commented:
No joy I'm afraid, I first power cycled the modem then:-

Trying scid
0
Davis McCarnOwnerCommented:
I don't have one of your modems so I'm shooting (kinda) in the dark; but, the next command in the reference is +VRID which sets the caller id formatting.
ATZ
AT-SCID=1
AT+VRID=0
0
cescentmanAuthor Commented:
How depressing, still no joy:-

AT+VRID=0
0
cescentmanAuthor Commented:
Fancy trying a remote session to resolve this? As long as I outline any solutions we arrived at here for future reference that would fit with EEX guidelines.
0
Davis McCarnOwnerCommented:
Let's try a few more first:

AT&F0  restores factory profile zero
AT+SCID=1

If no joy do it again with AT&F1

What country are you in and what result do you get from ATI5 and ATI12?
0
cescentmanAuthor Commented:
I'm in the UK:-

AT&f0 etc
0
Davis McCarnOwnerCommented:
I'm sorry; it's supposed to be AT-SCID=1

AT&F0
AT+GCI=B4 (sets UK)
AT-SCID=1
0
cescentmanAuthor Commented:
Sorry no joy:-

AT-SCID=1
0
Davis McCarnOwnerCommented:
OK, we need to backup a bit and, boy, you've got me reaching deep into the guts of modern modems!
First, please tell me that you can plug in an analog phone which supports caller id and it works?In the UK, you have to tell your telco to turn it on and some companies charge a monthly fee.  If it doesn't work on a plain phone, it won't ever work on the modem!
Second, I suspect that when you issued the ATZ command, you reset one of the registers which had been set by whomever you bought it from.  The standard callerid type in the US is Bell202.  In the UK it's V23.
What we need to do is to try the factory default types and see what countries they are set for.  To do that, stay away from the control panel entirely and issue:
AT&F0
AT+GCI=?
You should get a response of +GCI:(<contrycode>, <contrycode>, <contrycode>) and we want the first one to be B4!  If it isn't, try:
AT&F1
AT+GCI=?
and
AT&F2
AT+GCI=?
Hopefully, one will be a winner!  But; make sure it works with a phone first, OK?
0
cescentmanAuthor Commented:
Phone line definitely supports Caller ID and our phones are analogue and show the ID of callers:-

AT+GCI=?
0
Davis McCarnOwnerCommented:
Try ATF3 which sets the modem standard to CCITT V.23 (your callerid comspec)
0
cescentmanAuthor Commented:
Error again:-

ATF3
0
Davis McCarnOwnerCommented:
You've got me doing a lot of work here and the real problem may be that the modem just doesn't like the UK.  It is definitely one which was made for the US.

AT&F0
AT+GCI=B4 (sets UK)
AT+MS=V23C (from page 3-54 of the manual)
AT-SCID=1
0
cescentmanAuthor Commented:
:>(€

I'm grateful for your efforts:-

AT+GCI=B4
0
Davis McCarnOwnerCommented:
Read sections 5 and 6 of this: http://www.tapiex.com/help/faqcallerid.htm#Q_6

And, from about halfway down this: http://www.identafone.com/modems.html

"Modems in the UKIf BT in the UK is your TelCo then you are limited to modems made by MainPine, USR (Message Modem External, 56K Professional Message), Zoom UK (3025C), Pace (56k external and internal, Solo external), and Hayes (Optima 56 External). This is because most modems are designed for the Bellcore FSK type of CID sent by North American TelCos."

The only way we can move forward on the Conextant is to enable logging in Putty so we can see the errors: http://the.earth.li/~sgtatham/putty/0.60/htmldoc/Chapter4.html
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
cescentmanAuthor Commented:
This is all very puzzling as first time around I got Caller ID to display. It was only after I issued an ATZ command it stopped.

I have enabled logging on the putty session but to be honest I'm not sure that gives us anything other than a print out of the screen results?

As to the Amazon link that is of course a different modem.
0
Davis McCarnOwnerCommented:
Unless whomever you bought the Conextant from made special changes, the AT&F0 or AT&F1 commands should have restored the callerid functionality.  The only suggestion I can make on that is that you try AT&F0, close putty, set your country in the control panel, then see what you get in putty.  If no joy, try again with AT&F1.
0
Davis McCarnOwnerCommented:
Here is the kind of stuff which ought to be in the log:
http://mattcollinge.wordpress.com/projects/caller-id/
0
cescentmanAuthor Commented:
I abandoned getting this working and bought the modem listed at Amazon
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Hardware

From novice to tech pro — start learning today.