Link to home
Create AccountLog in
Avatar of Chocablockie
Chocablockie

asked on

Nagios Xi returned 139 error 'out of bounds'

Hi Experts

I am really baffled by this 'return code of 139 is out of bounds' in my Nagios Xi installation on one particular host.  We have installed agents to plenty of servers with differing o/s and choosing different services to monitor without issue, yet we have one instance on a particular server that kicks off this error?

Firstly, the server with the problem is a w2k8 r2, has nagios 64-bit agent version 0.4.1installed and has the basic services set to monitor.  The problem occurs when we try to monitor disk space usage on a secondary hard disk and the error above returns.

We have researched the error and have already tried the following proposed solutions without success:
1) changing the warning / critical values by adding '1' on the service
2) reinstalling the agent / installing an older agent / restarting services
3) checking the configuration file incase of incorrect ip address / drive letter

I am an absolute Nagios beginner so if anyone out there can suggest what is going on, I would be very grateful.
Avatar of Chris H
Chris H
Flag of United States of America image

http://www.nsclient.org/nscp/ticket/261

Check NT only works with fixed/networked drives. Use the NRPE command instead!
Avatar of Chocablockie
Chocablockie

ASKER

Thanks for the suggestion choward16980.  I tried setting it to use the NRPE command but this caused further failures on other drives.  I have restarted the service but this also didn't help.

Sorry for the delay in responding but do apprecaite your help
ASKER CERTIFIED SOLUTION
Avatar of Chocablockie
Chocablockie

Link to home
membership
Create an account to see this answer
Signing up is free. No credit card required.
Create Account
I hadn't realised the P: was a partition of C: - it was a good solution just because i finally found the problem (being my own problem!)