The .net framework 3.5 SP1 full install package

Dear all,

when I install the Microsoft .NET Framework 3.5 Service pack 1 (Full Package), and I found only one machine has the installation problem, please help to suggest why.

I have .net 2.0 install but it keep saying it is not, please see attachment.,

pLease tell me how to fix this or the litespeed backuop software can't install. I tyr to instlal .net 4.0 but the backup software still asking for the 3.5 or 3.5 SP1.
.net-3.5-install-error--1.jpg
.net-3.5-install-error--2.jpg
.net-3.5-install-error.txt
LVL 1
marrowyungSenior Technical architecture (Data)Asked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Meir RivkinFull stack Software EngineerCommented:
uninstall current .net 2.0 and .net 4.0 installations, reinstall .net 2.0, make sure to choose the right environment (32/64 bit).
then install .net 3.5 full package.
0
Abhishek ChakravartyCommented:
PLs check the following article
 http://blogs.msdn.com/b/astebner/archive/2005/04/16/408856.aspx

Helped me when i had similar problem

Abhishek
0
David Johnson, CD, MVPOwnerCommented:
What O/S are we dealing with here? .net 3.5 uses the .net 2.0 CLR, .net 4.0 is a total rewrite and uses the .net 4.0 clr

vista/Server2008 and higher have .net 3.5 as part of the o/s
0
Cloud Class® Course: CompTIA Cloud+

The CompTIA Cloud+ Basic training course will teach you about cloud concepts and models, data storage, networking, and network infrastructure.

*** Hopeleonie ***IT ManagerCommented:
This KB has helped me a lot:
http://support.microsoft.com/kb/976982/en-us

Did you try the FixIt:
http://go.microsoft.com/?linkid=9666880
and

Microsoft .NET Framework Repair Tool:
http://www.microsoft.com/en-us/download/details.aspx?id=30135  ?
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
marrowyungSenior Technical architecture (Data)Author Commented:
hopeleonie,

you send me more than one thing, that is a Windows 2003 R2 enterprise edition. that server can't go to the internet at all.

sedgwick,

"uninstall current .net 2.0 and .net 4.0 installations, reinstall .net 2.0, make sure to choose the right environment (32/64 bit).
then install .net 3.5 full package. "

will the uninstlal of current .net 2.0 and .net 4.0 require the boot ?

what is the sequence of uninstall and install ?

just uninstall all of them and then just install .net framework 3.5 is ok  ?

the litespeed backup tools I am using just like .net 3.0 or 3.5 .
0
*** Hopeleonie ***IT ManagerCommented:
You can download the Tools and take it to the Server... Both Tools will work on Windows 2003 R2 enterprise edition.
0
marrowyungSenior Technical architecture (Data)Author Commented:
if that server can't be restart, is it impossible to uninstall both ?
0
marrowyungSenior Technical architecture (Data)Author Commented:
Dear all,

Microsoft .NET Framework Repair Tool:
http://www.microsoft.com/en-us/download/details.aspx?id=30135  ?  

doesn't work, it detect that the Windows installer has prolbme and it restart it for me.

but it still doesn't work, then it repair the .net framework 4 for me but it still doesn't work.

they then need me to exact the reprot nad send to microsoft and don't provide where to send the log.

Any idea?
0
*** Hopeleonie ***IT ManagerCommented:
0
marrowyungSenior Technical architecture (Data)Author Commented:
hopeleonie,

that installer 5.0 do not have redistribution package at this moment, right?

or where to download it?

1) do any previous .net framework needs to be install before installing it?
2) need to reboot after installing it?
0
David Johnson, CD, MVPOwnerCommented:
It is now part of the Windows SDK for Windows 7. http://www.microsoft.com/en-ca/download/details.aspx?id=3138
0
marrowyungSenior Technical architecture (Data)Author Commented:
yeah, that's why we can't download it and instlal it on Windowws 2003 R2 server.
0
David Johnson, CD, MVPOwnerCommented:
0
*** Hopeleonie ***IT ManagerCommented:
Try the link from ve3ofa and let us know.
0
marrowyungSenior Technical architecture (Data)Author Commented:
I think this is the sames files I use before and the process failed also.
.net-3.5-SP1-installation-error.jpg
0
*** Hopeleonie ***IT ManagerCommented:
Did you try this FixIt:
http://go.microsoft.com/?linkid=9666880 ???
0
marrowyungSenior Technical architecture (Data)Author Commented:
yes, I did ! but it doesn't work, it will start saying the windows installer has problem, then it cna't fix it as the installation doesn't work also, then it will say repair .net 4 client, then it still doens't work.

it will gernerate the log and tell you to email to Microsoft, but it don't tell you the email address !
0
David Johnson, CD, MVPOwnerCommented:
uninstall .net 4.0
0
marrowyungSenior Technical architecture (Data)Author Commented:
and then ?
0
marrowyungSenior Technical architecture (Data)Author Commented:
forget about that and I don't think I need to do it now. a reboot is needed I think.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Microsoft Server OS

From novice to tech pro — start learning today.