2008R2 terminal VM on 2012 hyper v host slow to access network resources

Hey guys,

I'm having a strange issue here. I have 2 2012 server hyper-v servers. Hardware is identical. I created a VM on 1 host, configured everything I wanted on it with terminal services. I removed it from the domain and copied the VM several times over the 2 servers. I renamed and joined them to the network.

I created each machine with the hyper-v wizard to generate the config files. I just pointed it to the proper vhd to use.

The machines that are sitting on host 1 work very fast and everything is fine.

Machines on host 2 are slow to login and skip a beat when you try to access a file on the network.

With the Native hyper-V adaptor: ping times are 100+ms (server was pretty much unusable)
with a legacy adaptor: ping times are <1ms (better, but still a bit slow to open network files)


Things I have already tried:

Verified that network drivers are identical on both machines
copied one of the slow machines back to the original host and everything is fast
Am currently using a legacy adapter
Tried to take it off the domain and still slow
tried to disable ipv4 checksum offload
Tried different adapters on the servers

Network info:
2 cisco catalyst 48 port switches stacked
2012 machines have the latest updates

Any help would be greatly appreciated
LVL 4
every1isevil2Asked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Svet PaperovIT ManagerCommented:
The used method of distributing virtual machines is not supported - you should always use Sysprep to reset the GUID of the servers. You could try it on one of the VMs.

If you don't want to use Sysprep, another option is to remove and add the network adapters of the virtual machines and use fixed MAC addresses from the range on the second server.

The last option is a hardware issue with the host server.
every1isevil2Author Commented:
I just tried sysprep on the server and no go.
I also tried the fixed mac addresses and no go.

Any suggestions on the hardware issue diagnosis?
Svet PaperovIT ManagerCommented:
How many NICs do you have on the server? Did you try attaching different virtual adapters (of different physical NICs) to the virtual machine?

If you create a VM on server 2 instead of moving one from server 1, do you have the same issue?

Possible hardware issues: bad cables, bad NIC ports, bad switch ports, bad switchport configuration... etc.
every1isevil2Author Commented:
I found the problem. i figured I would post to help the next person that encounters this.

The problem is that the Broadcom NetXtreme drivers have a feature called Virtual Machine Queues enabled by default. I disabled the feature and everything was immediately resolved.

(need to have the control suite installed to enable/disable this setting)

Hope this helps someone in the future.

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
every1isevil2Author Commented:
Problem resolved
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Windows Server 2012

From novice to tech pro — start learning today.