OWA and Outlook Anywhere work after Service 3 for Exchange 2010 is installed

MarkSnark1
MarkSnark1 used Ask the Experts™
on
After installing service pack 3 remote connectivity to the exchange 2010 server no longer works.  When I run the connectivity analyzer the following message appears.

A Web exception occurred because an HTTP 440 - 440 response was received from Unknown

I believe it has something to do with the OWA virtual server but otherwise do not know how to trouble shoot or repair.  Thank you for your help.
Comment
Watch Question

Do more with

Expert Office
EXPERT OFFICE® is a registered trademark of EXPERTS EXCHANGE®

Commented:
Have you tried running an iisreset command, or restarting the Exchange services?

Anything in event viewer?
Did you reboot the server after applying updates..?
Can you disable IPv6 on the server and check once..?

OWA page internally works or not..?
What about mailflow..? Can you send emails through outlook..?
Can you check whether RPC virtual directories pointings are correct or not.
Run a test in testexchangeconnectivity.com and check errors..

Author

Commented:
It is just the owa and outlook anywhere. that is not working.  Inside sends and receives just fine.  How do you check to see if the RPC is pointed correctly?  That seems like the problem.
 When I run the connectivity analyzer the following message appears.

A Web exception occurred because an HTTP 440 - 440 response was received from Unknown
Should you be charging more for IT Services?

Do you wonder if your IT business is truly profitable or if you should raise your prices? Learn how to calculate your overhead burden using our free interactive tool and use it to determine the right price for your IT services. Start calculating Now!

Commented:
RPC web directory can be checked under IIS default web site.

Just realized myself, I have the same issue. I didn't check this after upgrading to SP3. My IIS web directories' redirection is messed up. Working on it. Will keep you posted.
piyushranusriSystem Cloud Specialist
Top Expert 2012

Commented:
did you check the connectivity by this Link

https://www.testexchangeconnectivity.com/


Setup an internal contoso.com DNS zone
Add (A) record for mail in internal contoso.com and point it at the internal IP address of your CAS server.
Test www.testexchangeconnectivity.com outlook anywhere test again as the above may have resolved your issue

Then go into the internal Outlook HTTP settings and tell it connect over HTTP on fast networks. Fire up outlook with /rpcdiag and you should see it attempting to connect over HTTP if it can't make the connection it will fail back to TCP/IP



White Paper: Exchange 2007 Autodiscover Service
http://technet.microsoft.com/en-us/library/bb332063(EXCHG.80).aspx

please share the output
Commented:
In my case, I had redirection applied on my default web site (for OWA URL simplification). After SP3 upgrade, IIS on the CAS server had applied the URL redirection on all the subdirectories. I removed the redirection from the proper subdirectories (Autudiscover, ecp, EWS, ActiveSync, OAB, OWA, Powershell, PowerShell-proxy,rpc, rpcwithcert) and did a IISRESET. All went back to normal.

This seems to only affect CAS server where the HTTP redirection has been setup on the root of the default web site (Exchange 2010). My DR server don't have redirection applied, don't have this issue.

You need to check your web site sub directories in IIS. check "HTTP redirect" settings for the above sub directories.

Author

Commented:
Msmamji,


I am not sure I am looking in the right place in iis-->http redirect but there is only one setting:

Redirect requests to this location is checkes "https://remote.mydomain.org/owa" 

and it appears to be correct for my domain.  I do not know where to check the Http redirect for the various sub directories you mentioned in your last post. Can you help with that?

Thank you for your time.
Commented:
See the attached screenshots
IIS Conf I
All the marked directories should have the setting unchecked
IIS Conf II

Author

Commented:
Msmamji,

Excellent instructions however, I removed the check for the sub directories you showed on the screenshot and did the iisreset and still the Outlook Anywhere and OWA do not work.

I do notice a decrepancy between your posts. In the screen shots you leave off the OWA but in your prior post you list all of the subdirectories. I left the check mark in place on the OWA per your screen shot. Prehaps that one should be removed as well?

Hmm. I take that back.  While I was composing this comment the Outlook Anywhere started working; Which is most important and which is why you are a genius Msmamji.

Also, I removed the check for OWA and it started working too.  Thank you very much.  Now I get some sleep.
Mark

Commented:
Well, it depends if you are using redirection for OWA. If yes then OWA virtual directory needs to have the Http redirection checked. If No then you can uncheck it. However, your RPC issue is only due to rpc virtual directory.
Check to see if SSL is configured correct on the rpc directory.
SSL Setting in RPC directory

Author

Commented:
Great job. Thank you again.  All is working.

Do more with

Expert Office
Submit tech questions to Ask the Experts™ at any time to receive solutions, advice, and new ideas from leading industry professionals.

Start 7-Day Free Trial