Avatar of russell12
russell12
Flag for United States of America asked on

Remote Desktop Connection behind 2 routers

We have a buisness VOIP phone setup with a DLINK router.  The DLINK router connects to a port on the VOIP hub and that port supplies internet.  I have port forward setup in the DLINK for remote desktop on port 3389 that directs to the server.  I have also contacted the phone company to open port 3389 to the DLINK's gateway.  I still can not get into the server through remote desktop.  I have disabled the firewall on the server.  Can someone please direct me in the right direction as to what I need to do next?   Also I am running Server 2003 Standard R2

Thanks in advance
Remote AccessMicrosoft Server OSWindows Server 2003

Avatar of undefined
Last Comment
russell12

8/22/2022 - Mon
ASKER CERTIFIED SOLUTION
David Johnson, CD

Log in or sign up to see answer
Become an EE member today7-DAY FREE TRIAL
Members can start a 7-Day Free trial then enjoy unlimited access to the platform
Sign up - Free for 7 days
or
Learn why we charge membership fees
We get it - no one likes a content blocker. Take one extra minute and find out why we block content.
Not exactly the question you had in mind?
Sign up for an EE membership and get your own personalized solution. With an EE membership, you can ask unlimited troubleshooting, research, or opinion questions.
ask a question
SOLUTION
cpmcomputers

Log in or sign up to see answer
Become an EE member today7-DAY FREE TRIAL
Members can start a 7-Day Free trial then enjoy unlimited access to the platform
Sign up - Free for 7 days
or
Learn why we charge membership fees
We get it - no one likes a content blocker. Take one extra minute and find out why we block content.
Not exactly the question you had in mind?
Sign up for an EE membership and get your own personalized solution. With an EE membership, you can ask unlimited troubleshooting, research, or opinion questions.
ask a question
cpmcomputers

Can you rdp internally ?
If your certain the dlink has both a firewall rule allowing the port inbound and a port forward to the correct ip of the server
Then it could be your providers have not done likewise on the dlink (Ie allow port inbound traffic to be forwarded to the gateway ip ?
cpmcomputers

Sorry typo mean to say VoIP device nor dlink
In final paragraph

Apologies (on iPhone)
SOLUTION
Log in to continue reading
Log In
Sign up - Free for 7 days
Get an unlimited membership to EE for less than $4 a week.
Unlimited question asking, solutions, articles and more.
russell12

ASKER
I can rdp internally.  The way the setup is:
Internet--->VOIP modem---->DLINK Router---->Server.  The VOIP Modem is controlled by the cable/phone company.  I have no access to the VOIP modem.  The VOIP is a router.  The gateway for the DLINK is 192.168.0.1.  I have had the cable company open up port 3389 TCP traffic to 192.168.0.1.  I am going to say that the DLINK performs IP NATing.  The VOIP Modem is directly connected to the internet through fiber optics.  Thanks for the help!
Also to answer the first comment, I can not change the line up, I wish I could, but the VOIP modem has the fiber optics comming into it.
Your help has saved me hundreds of hours of internet surfing.
fblack61
David Johnson, CD

Did you try enabling remote management on your router and see if you can access it using your remote address..  I'm also assuming that you forwarded port 3389 on the dlink router to your local computers ip address.
russell12

ASKER
No I have not had a chance to enable remote management, I will do that tomorrow when I get to the office and post an update.  And yes I have pointed port 3389 to the servers address.
russell12

ASKER
Ok I accepted everyones answers because they all were very informational and they were directing me in the right direction, but we finally resolved this issue by getting our cable company representative on site with me and we change the whole setup and we now have the VOIP router handling dhcp and were using the wireless router as access point only.  Thats the initial way I would had set it up, but after talking with him multiple times, we came up with this solution, so now I can use remote desktop.  I gave best answer to "ve3ofa" because "ve3ofa" pointed out it is probably in the VOIP modem and "ve3ofa" was correct.  Thank you all for your help on this.
Get an unlimited membership to EE for less than $4 a week.
Unlimited question asking, solutions, articles and more.