Avatar of ittechlab
ittechlabFlag for Canada

asked on 

VLAN question

I want to remove all the vlan. How do i do that?

Switch#show ver
Cisco Internetwork Operating System Software
IOS (tm) C3500XL Software (C3500XL-C3H2S-M), Version 12.0(5)WC3b, RELEASE SOFTWARE (fc1)
Copyright (c) 1986-2002 by cisco Systems, Inc.
Compiled Fri 15-Feb-02 10:51 by antonino
Image text-base: 0x00003000, data-base: 0x00337600

ROM: Bootstrap program is C3500XL boot loader

Switch uptime is 2 hours, 2 minutes
System returned to ROM by power-on
System image file is "flash:c3500XL-c3h2s-mz.120-5.WC3b.bin"


cisco WS-C3524-XL (PowerPC403) processor (revision 0x01) with 8192K/1024K bytes of memory.
Processor board ID FHK0619Z2GP, with hardware revision 0x00
Last reset from power-on

Processor is running Enterprise Edition Software
Cluster command switch capable
Cluster member switch capable
24 FastEthernet/IEEE 802.3 interface(s)
2 Gigabit Ethernet/IEEE 802.3 interface(s)

32K bytes of flash-simulated non-volatile configuration memory.
Base ethernet MAC Address: 00:09:B7:14:48:00
Motherboard assembly number: 73-6788-02
Power supply part number: 34-0963-01
Motherboard serial number: FOC06180PT5
Power supply serial number: PHI061204FR
Model revision number: R0
Motherboard revision number: A0
Model number: WS-C3524-XL-EN
System serial number: FHK0619Z2GP
Configuration register is 0xF


Switch#show vlan
VLAN Name                             Status    Ports
---- -------------------------------- --------- -------------------------------
1    default                          active    Fa0/1, Fa0/2, Fa0/8, Fa0/9,
                                                Fa0/10, Fa0/11, Fa0/12, Fa0/18,
                                                Fa0/19, Fa0/20, Fa0/21, Fa0/22,
                                                Fa0/23, Gi0/1, Gi0/2
10   VLAN0010                         active    Fa0/3, Fa0/4, Fa0/5, Fa0/6,
                                                Fa0/7
20   VLAN0020                         active    Fa0/13, Fa0/14, Fa0/15, Fa0/16,
                                                Fa0/17
30   VLAN0030                         active
1002 fddi-default                     active
1003 token-ring-default               active
1004 fddinet-default                  active
1005 trnet-default                    active

VLAN Type  SAID       MTU   Parent RingNo BridgeNo Stp  BrdgMode Trans1 Trans2
---- ----- ---------- ----- ------ ------ -------- ---- -------- ------ ------
1    enet  100001     1500  -      -      -        -    -        0      0
10   enet  100010     1500  -      -      -        -    -        0      0
20   enet  100020     1500  -      -      -        -    -        0      0
30   enet  100030     1500  -      -      -        -    -        0      0
1002 fddi  101002     1500  -      -      -        -    -        0      0
1003 tr    101003     1500  -      -      -        -    -        0      0
1004 fdnet 101004     1500  -      -      -        ieee -        0      0
1005 trnet 101005     1500  -      -      -        ibm  -        0      0
RoutersSwitches / HubsNetworking

Avatar of undefined
Last Comment
ittechlab
Avatar of Shane McKeown
Shane McKeown
Flag of Ireland image

Exact list of commands you need...

conf t
interface range fa 3-7/13-17
switchport access vlan 1
exit
no vlan 20
no vlan 30
no vlan 10
exit
Avatar of ittechlab
ittechlab
Flag of Canada image

ASKER

Switch(config)#interface range fa 3-7/13-17
                         ^
% Invalid input detected at '^' marker.


I getting this error
Avatar of ittechlab
ittechlab
Flag of Canada image

ASKER

Switch(config)#interface ?
  FastEthernet       FastEthernet IEEE 802.3
  GigabitEthernet    GigabitEthernet IEEE 802.3z
  Multilink          Multilink-group interface
  Port-channel       Ethernet Channel of interfaces
  VLAN               Switch VLAN Virtual Interface
  Virtual-TokenRing  Virtual TokenRing
Avatar of ittechlab
ittechlab
Flag of Canada image

ASKER

Here is my running-config output  

Switch#show running-config
Building configuration...

Current configuration:
!
version 12.0
no service pad
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname Switch
!
enable password mano
!
!
!
!
!
!
ip subnet-zero
!
!
!
interface FastEthernet0/1
!
interface FastEthernet0/2
!
interface FastEthernet0/3
 switchport access vlan 10
!
interface FastEthernet0/4
 switchport access vlan 10
!
interface FastEthernet0/5
 switchport access vlan 10
!
interface FastEthernet0/6
 duplex full
 switchport access vlan 10
!
interface FastEthernet0/7
 switchport access vlan 10
!
interface FastEthernet0/8
!
interface FastEthernet0/9
!
interface FastEthernet0/10
!
interface FastEthernet0/11
!
interface FastEthernet0/12
!
interface FastEthernet0/13
 duplex full
 switchport access vlan 20
!
interface FastEthernet0/14
 switchport access vlan 20
!
interface FastEthernet0/15
 switchport access vlan 20
!
interface FastEthernet0/16
 switchport access vlan 20
!
interface FastEthernet0/17
 switchport access vlan 20
!
interface FastEthernet0/18
!
interface FastEthernet0/19
!
interface FastEthernet0/20
!
interface FastEthernet0/21
!
interface FastEthernet0/22
!
interface FastEthernet0/23
!
interface FastEthernet0/24
 duplex full
 switchport trunk encapsulation dot1q
 switchport mode trunk
!
interface GigabitEthernet0/1
!
interface GigabitEthernet0/2
!
interface VLAN1
 ip address 192.168.2.2 255.255.255.0
 no ip directed-broadcast
 no ip route-cache
!
!
line con 0
 password cisco
 login
 transport input none
 stopbits 1
line vty 0 4
 password cisco
 login
line vty 5 15
 password cisco
 login
!
end
Avatar of Shane McKeown
Shane McKeown
Flag of Ireland image

Sorry, might have that backways, or there is no range command for your version

Ok, long winded way...

You need to go into each inteface and move them to vlan 1 like so

conf t
interface fa 0/3
switchport access vlan 1
exit
interface fa 0/4
switchport access vlan 1
exit

etc etc...

Do that for all ports 3-7 and 13-17(since they are not currently in vlan 1)

Then you can delete the vlans...
Avatar of ittechlab
ittechlab
Flag of Canada image

ASKER

do i have to do one by one? is there any other way to do at once.
Avatar of Shane McKeown
Shane McKeown
Flag of Ireland image

You dont have the range command...so no

Its only 10 ports so its not that long
Avatar of rochey2009
rochey2009

Hi,

 Try

Conf t
Interface range fa0/1 - 23
 Switchport access vlan 1
Avatar of Akinsd
Akinsd
Flag of United States of America image

To completely remove VLAN data, you need to delete the VLAN.dat file and reboot the switch

delete flash:vlan.dat
Reload
ASKER CERTIFIED SOLUTION
Avatar of Akinsd
Akinsd
Flag of United States of America image

Blurred text
THIS SOLUTION IS ONLY AVAILABLE TO MEMBERS.
View this solution by signing up for a free trial.
Members can start a 7-Day free trial and enjoy unlimited access to the platform.
See Pricing Options
Start Free Trial
Avatar of ittechlab
ittechlab
Flag of Canada image

ASKER

Thanks
Networking
Networking

Networking is the process of connecting computing devices, peripherals and terminals together through a system that uses wiring, cabling or radio waves that enable their users to communicate, share information and interact over distances. Often associated are issues regarding operating systems, hardware and equipment, cloud and virtual networking, protocols, architecture, storage and management.

102K
Questions
--
Followers
--
Top Experts
Get a personalized solution from industry experts
Ask the experts
Read over 600 more reviews

TRUSTED BY

IBM logoIntel logoMicrosoft logoUbisoft logoSAP logo
Qualcomm logoCitrix Systems logoWorkday logoErnst & Young logo
High performer badgeUsers love us badge
LinkedIn logoFacebook logoX logoInstagram logoTikTok logoYouTube logo