Link to home
Get AccessLog in
Avatar of MattyS82
MattyS82

asked on

Httpd Server won't start Red hat 6.3

Hi all,

When attempting to run the command
service httpd status it tells me httpd is stopped. I then attempt to start httpd I get a return of FAILED with the following message;

Starting httpd: [Mon Mar 25 10:32:44 2013] [warn] _default_ VirtualHost overlap on port 443, the first has precedence
                                                           [FAILED]
I have also run httpd -e DEBUG and I get the out put (http-error.txt,attached).
I have also obtained the logs in /etc/httpd/logs/error_log. This is also attached.

I have also performed reboots on the server and still having this issue. I have checked the chkconfig file and httpd is set to start on boot up.

Can anyone tell me how and why httpd is having issues starting? Thanks for your time.
httpd-error.txt
httpd-errorlogs.txt
Avatar of MattyS82
MattyS82

ASKER

within the /etc/httpd/logs location I notice there are the following files;

access_log             mod_jk.shm.2246  mod_jk.shm.9071
error_log              mod_jk.shm.2276  mod_jk.shm.9090
jboss_access_log       mod_jk.shm.4855  mod_jk.shm.9127
jboss_error_log        mod_jk.shm.4871  mod_jk.shm.9570
mod_jk.log             mod_jk.shm.4886  mod_jk.shm.9613
mod_jk.shm.10042       mod_jk.shm.5732  mod_jk.shm.9613.lock
mod_jk.shm.10042.lock  mod_jk.shm.5748  mod_jk.shm.9943
mod_jk.shm.1483        mod_jk.shm.5763  mod_jk.shm.9943.lock
mod_jk.shm.1483.lock   mod_jk.shm.5971  mod_jk.shm.9959
mod_jk.shm.1487        mod_jk.shm.5987  mod_jk.shm.9959.lock
mod_jk.shm.1776        mod_jk.shm.6002  mod_jk.shm.9974
mod_jk.shm.1995        mod_jk.shm.8412  mod_jk.shm.9974.lock
mod_jk.shm.2101        mod_jk.shm.8426  nssp_request_log
mod_jk.shm.2101.lock   mod_jk.shm.8449  ssl_access_log
mod_jk.shm.2103        mod_jk.shm.8470  ssl_error_log
mod_jk.shm.2103.lock   mod_jk.shm.8494  ssl_request_log
mod_jk.shm.2131        mod_jk.shm.8549

Do these .lock files point to any issues?
Avatar of Mazdajai
Check your certificate, make sure the format is correct.

After that, verify it -

openssl x509 -noout -text -in Domain.local.crt

Open in new window

Mazdgajai,

The following output was obtained using the command listed above in your post

140637925926728:error:02001002:system library:fopen:No such file or directory:bss_file.c:355:fopen('domain.local.crt','r')
140637925926728:error:20074002:BIO routines:FILE_CTRL:system lib:bss_file.c:357:
unable to load certificate
There is a problem with your cert. If this is self-signed I recommend generating a new one, take a look of  the guide and let us know the outcome.

http://www.sslshopper.com/article-how-to-create-and-install-an-apache-self-signed-certificate.html
ASKER CERTIFIED SOLUTION
Avatar of arnold
arnold
Flag of United States of America image

Link to home
membership
This content is only available to members.
To access this content, you must be a member of Experts Exchange.
Get Access
Arnold,

Thanks for the reply. In regards to the ssl.conf there is only one entry within this conf file

Listen 443.

I can't find any other entries pertianing to 443.  There should be only one SSL site on the system.
You may have one in httpd.conf
or within the conf.d

run httpd -t -D DUMP_VHOSTS

See what is being returned there.
/etc/httpd/conf.d/*.conf