Avatar of leblanc
leblanc
 asked on

gns3 vlan routing

I am using gns3 for my vlan routing. I using the c3640-ik9o3s-mz.124-25c Cisoc IOS for my routers. I also set the router with nm-16ESW to use the switching port.
Can you tell me why R1 cannot ping R3 (192.168.2.3) (see attached)? Is it because of gns3 software?

R1 has a route to R3 subnet via R2. R1 should be able to ping R3 as R2 is directly connected to R2 subnet.

Thanks
tmp2.jpg
Switches / HubsNetwork AnalysisNetworking

Avatar of undefined
Last Comment
Ramin_G

8/22/2022 - Mon
ASKER CERTIFIED SOLUTION
Ramin_G

Log in or sign up to see answer
Become an EE member today7-DAY FREE TRIAL
Members can start a 7-Day Free trial then enjoy unlimited access to the platform
Sign up - Free for 7 days
or
Learn why we charge membership fees
We get it - no one likes a content blocker. Take one extra minute and find out why we block content.
Not exactly the question you had in mind?
Sign up for an EE membership and get your own personalized solution. With an EE membership, you can ask unlimited troubleshooting, research, or opinion questions.
ask a question
Don Johnston

It would help if you would post the configs of the routers.
leblanc

ASKER
Yes but R3 has a default route pointed to R2. Below are the configs.

!
!
version 12.4
!
hostname R1
!
!
interface FastEthernet0/0
 description to R2
!
interface FastEthernet0/1
!
interface FastEthernet0/2
!
interface FastEthernet0/3
 description to R4
 switchport mode trunk
!
...
!
interface FastEthernet0/15
!
interface Vlan1
 ip address 192.168.1.1 255.255.255.0
!
interface Vlan200
 ip address 192.168.19.1 255.255.255.0
!
ip default-gateway 192.168.1.40
no ip http server
no ip http secure-server
...
!
end
--------------------------------------------------------------

version 12.4
!
hostname R2
!
!
interface FastEthernet0/0
 description to R1
 no switchport
 ip address 192.168.1.40 255.255.255.0
!
interface FastEthernet0/1
 no switchport
 ip address 192.168.2.1 255.255.255.0
!
interface FastEthernet0/2
!
...
!
interface FastEthernet0/12
!
interface FastEthernet0/13
!
interface FastEthernet0/14
!
interface FastEthernet0/15
!
interface Vlan1
 no ip address
!
no ip http server
no ip http secure-server
!
ip forward-protocol nd
ip route 192.168.19.0 255.255.255.0 192.168.1.1
!
end
----------------------------------------------
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R3
!
...
!
interface FastEthernet0/0
!
interface FastEthernet0/1
 description to R2
!
interface FastEthernet0/2
...
!
interface FastEthernet0/14
!
interface FastEthernet0/15
!
interface Vlan1
 ip address 192.168.2.3 255.255.255.0
!
ip default-gateway 192.168.2.1
no ip http server
no ip http secure-server
!
ip forward-protocol nd
!
end
--------------------------------
version 12.4
!
hostname R4
!
...
!
interface FastEthernet0/0
!
interface FastEthernet0/1
!
interface FastEthernet0/2
!
interface FastEthernet0/3
 description to R1
 switchport mode trunk
!
interface FastEthernet0/4
!
...
!
interface FastEthernet0/14
!
interface FastEthernet0/15
!
interface Vlan1
 ip address 192.168.1.18 255.255.255.0
!
ip default-gateway 192.168.1.1
no ip http server
no ip http secure-server
!
ip forward-protocol nd
!
...
!
end
Ramin_G

For this to work you need to assign ip address to interface fa0/0 from subnet 192.168.1.0/24 on R1 and for interface fa0/1 assign ip address from subnet 192.168.2.0/24.
Then they will be able to ping each other.

Or you can assign this interfaces on R1 and R3 to proper vlans, and also change interface configuration on R2.

interface fa0/0
switchport mode access
switchport access vlan XXX
Your help has saved me hundreds of hours of internet surfing.
fblack61
leblanc

ASKER
I want R2 to be a router so there is no notion of vlan.
R1 has a SVI of subnet 192.168.1.1 and its interface is an access switchport vlan1 to R2.
R3 has a SVI of subnet 192.168.2.3 and its interface is in access switchport vlan 1 to R2.

Currently, R1 can ping R2 f0/0 and R3 can ping R2 f0/1. But R1 cannot ping R3 svi 192.168.2.3.

I implemented this scenario with a L3 switch and it works with ip routing enable. It seems that even though I am using NM-16ESW 16 port fastethernet on the router, you need to explicitly configure static routes. The ip routing does not work for the router.
Ramin_G

IP routing is automatically enabled by default on all Cisco IOS software.
For troubleshooting you can try to debug pings.

On R2 f0/1 issue debug ip icmp and you will have answer why it's failing to ping.
leblanc

ASKER
I did the debug command. On R3, I can see the echo reply. But it seem the echo reply did not go through R2 to get back to R1.
Anyway, I change all the default-gateway to ip route 0.0.0.0 and it all works now.
Get an unlimited membership to EE for less than $4 a week.
Unlimited question asking, solutions, articles and more.
SOLUTION
Ramin_G

Log in or sign up to see answer
Become an EE member today7-DAY FREE TRIAL
Members can start a 7-Day Free trial then enjoy unlimited access to the platform
Sign up - Free for 7 days
or
Learn why we charge membership fees
We get it - no one likes a content blocker. Take one extra minute and find out why we block content.
Not exactly the question you had in mind?
Sign up for an EE membership and get your own personalized solution. With an EE membership, you can ask unlimited troubleshooting, research, or opinion questions.
ask a question