Link to home
Start Free TrialLog in
Avatar of intangiblemedia
intangiblemediaFlag for Afghanistan

asked on

Apache Configuration Issue - mod_fcgid: error reading data from FastCGI server

Hey all,

I have a script that requires to upload 36 photos to an ecommerce store - but there is some memory issue, and I can get a "Internal Server Error" via http admin control panel when trying to save the record with the files to database.

> ==> /var/log/apache2/mydomainerror.log <== [Mon Mar 25 12:52:35
> 2013] [warn] [client 80.28.211.165] (104)Connection reset by peer:
> mod_fcgid: error reading data from FastCGI server, referer:


> [Mon Mar 25 12:52:35 2013] [client 80.28.211.165] Premature
> end of script headers: index.php, referer:
>

Any ideas which parameter I need to change? Currently my fcgid.conf looks like this:

<IfModule mod_fcgid.c>
  AddHandler    fcgid-script .fcgi
  FcgidConnectTimeout 20
  FcgidMaxRequestLen 1073741824
  IPCCommTimeout  9200
  FcgidBusyTimeout 600
</IfModule>

Help!! Thanks everyone!
SOLUTION
Avatar of Wylie Bayes
Wylie Bayes
Flag of United States of America image

Link to home
membership
This solution is only available to members.
To access this solution, you must be a member of Experts Exchange.
Start Free Trial
SOLUTION
Link to home
membership
This solution is only available to members.
To access this solution, you must be a member of Experts Exchange.
Start Free Trial
With 36 photos, you would probably want to bypass HTTP entirely and use an FTP client.  FileZilla is your friend.
ftp is obsolete since ages 'cause of obvious security reasons
IMHO it's a bad idea to suggest it to be used over public transport
just my 2 pence ...
I'm still putting my money on simply increasing the amount memory a php script can eat up.  See this choke out sites, like wordpress blogs, many times.
ASKER CERTIFIED SOLUTION
Link to home
membership
This solution is only available to members.
To access this solution, you must be a member of Experts Exchange.
Start Free Trial
Avatar of intangiblemedia

ASKER

Thank you everyone - I can't seem to get to the bottom of the problem - How do I turn on php error logging to see what exactly is causing this issue?

@wakemup - I updated the default 20 to 40, the number of files is 36 - restarted Apache which I presume would "restart" php with new config.

Still not working, Im getting desperate now.

Help. thanks.