Avatar of TripapHoniC
TripapHoniC
Flag for United States of America asked on

vSphere 5.1 "The server committed a protocol violation"

I am connecting to an vCenter 5.1 instance running on ESXi 5.1 with vSphere Client 5.1 over a VPN.

When I attempt to connect over the secured port 7444 I get an error.  I was prompted to accept the certificate prior to the error.  

vSphere Client could not connect to "xxx.xxx.xxx.xxx". An unknown connection error occured.  (The client received an invalid response from the server. (The Server committed a protocol violation.  Section=ResponseStatusLine))

If I try to connect over port 81 I get an error about the traffic not being encrypted and throws an error stating "The server 'xxx.xxx.xxx.xxx' could not interpret the client's request. (The remote server returned an error: (404) Not Found.)

Error stack
Call "ServiceInstance.RetrieveContent" for object "ServiceInstance" on Server "xxx.xxx.xxx.xxx" failed.

Thanks guys.
VMware-vSphere-7444-error.JPG
VMware

Avatar of undefined
Last Comment
TripapHoniC

8/22/2022 - Mon
Force_Reaction

Under server name\IP address, are adding the port number after the name or IP address(vmwareserver.com:7444)?

If so, have you tried it without the port number in it?
Andrew Hancock (VMware vExpert PRO / EE Fellow/British Beekeeper)

can you connect directly to the ESXi server?
TripapHoniC

ASKER
Thanks Force, I am using the port after the IP.  The error is the same and only shows the IP address.

hanccocka, I can connect directly to ESXi.  I also tried to connect via public IP and with some firewall policies I was able to connect to the vCenter server but recevied the same error.  Both on 7444 and 81.
Your help has saved me hundreds of hours of internet surfing.
fblack61
ASKER CERTIFIED SOLUTION
TripapHoniC

Log in or sign up to see answer
Become an EE member today7-DAY FREE TRIAL
Members can start a 7-Day Free trial then enjoy unlimited access to the platform
Sign up - Free for 7 days
or
Learn why we charge membership fees
We get it - no one likes a content blocker. Take one extra minute and find out why we block content.
Not exactly the question you had in mind?
Sign up for an EE membership and get your own personalized solution. With an EE membership, you can ask unlimited troubleshooting, research, or opinion questions.
ask a question
TripapHoniC

ASKER
My own root cause analysis resolved this issue which I annotated in my last post.