Avatar of anotherjallen
anotherjallen
Flag for United States of America asked on

Exchange 2k7 OWA redirects to server name

Hi,

I have two Server 2003 boxes running the CAS 2k7 roll.  They are load balanced through the firewall for external access.  When someone externally tries to access our owa website (https://mail.company.com/owa) there is an issue.  If the load balancer takes them to one of the servers (call it cas1) it has no issues at all.  If it takes them to the other one (cas2) it tries to redirect them to https://cas2.company.com/owa.  This just started happening after we enabled Forms Based Authentication.  I have checked all of the settings in EMC and IIS and cannot find any differences between the two.

Anyways, I am stumped.  I thought it might be a firewall issue but I cannot find a single error there, and the fact that it didn't start happening until after enabled Forms Based Authentication has me thinking that something changed there but I have no idea what would have.  If anyone has ran into this issue before or has an idea I would greatly appreciate the help!
ExchangeWindows Server 2003

Avatar of undefined
Last Comment
anotherjallen

8/22/2022 - Mon
ASKER CERTIFIED SOLUTION
jimmithakkar

Log in or sign up to see answer
Become an EE member today7-DAY FREE TRIAL
Members can start a 7-Day Free trial then enjoy unlimited access to the platform
Sign up - Free for 7 days
or
Learn why we charge membership fees
We get it - no one likes a content blocker. Take one extra minute and find out why we block content.
Not exactly the question you had in mind?
Sign up for an EE membership and get your own personalized solution. With an EE membership, you can ask unlimited troubleshooting, research, or opinion questions.
ask a question
anotherjallen

ASKER
Brilliant, thank you!
This is the best money I have ever spent. I cannot not tell you how many times these folks have saved my bacon. I learn so much from the contributors.
rwheeler23