Avatar of ITimpulse
ITimpulse
 asked on

DCOM Event ID : 10010 Error Message : The server {7D1933CB-86F6-4A98-8628-01BE94C9A575} did not register with DCOM within the required timeout.

Hi Experts,

I getting this error on one of my server having Windows Server 2008 R2 installed and i have searched and tried many solutions but issue could not be resolved yet.
GUID that is mentioned in the event is relates to Virtual Disk Service and I'm unable modify security permission for "Virtual Disk Service" through "Component Services" because security permission for "Launch and Activation Permission" is grayed out.
I have tried to set security permission in registry for respective GUID but no go.

Kindly help.


Thanks.
Microsoft Legacy OSMicrosoft Server OSWindows Server 2008

Avatar of undefined
Last Comment
Radhakrishnan

8/22/2022 - Mon
Radhakrishnan

Hi,

As you know that most of the DCOM erros appears due to permissions, since it's grayed out in component services, this could be the ownership of the GUID in registry.

Go to regedit and locate the GUID, select permissions and advanced, the current ownership of the GUID would be "TrustedInstaller", you have to change it to domain administrator. Once its changed, you will be able to modify the permission in component services.
ITimpulse

ASKER
Hi Radhakrishnan,

Thanks for your response.

I have already changed ownership for that GUID to Domain administrator but still I'm unable to modify permission in component services.
ITimpulse

ASKER
Hello Friends,

I'm waiting for your update.

Your help would be highly appreciated.


Thanks.
This is the best money I have ever spent. I cannot not tell you how many times these folks have saved my bacon. I learn so much from the contributors.
rwheeler23
ASKER CERTIFIED SOLUTION
Radhakrishnan

Log in or sign up to see answer
Become an EE member today7-DAY FREE TRIAL
Members can start a 7-Day Free trial then enjoy unlimited access to the platform
Sign up - Free for 7 days
or
Learn why we charge membership fees
We get it - no one likes a content blocker. Take one extra minute and find out why we block content.
Not exactly the question you had in mind?
Sign up for an EE membership and get your own personalized solution. With an EE membership, you can ask unlimited troubleshooting, research, or opinion questions.
ask a question
ITimpulse

ASKER
Hello,

I have performed following steps but still getting this alert on the server.
1. Changed Ownership to Domain Administrator for this particular GUID in registry 2.
2. Verified the Security permissions for Registration folder under %WinDir%. All permissions are as recommended
3. Verified that Everyone group has Bypass traverse checking user right.
4.  Added "LOCALSERVICE" and "NETWORK SERVICE" with full permissions in Launch and Activation permission under Dcom Config for Virtual Disk Service.
5. Verified Full Permission is set to Administrator account.

Please help us to resolve this issue permanently.

Thanks
Radhakrishnan

Hi,

In 2003 server there was a hotfix for this error http://support.microsoft.com/kb/873375#appliesto. But in your case it is 2008 server, so it can't be applied. Also, i am not too sure whether simular hotfix available for 2008 as well.

Also, the CLSID {7D1933CB-86F6-4A98-8628-01BE94C9A575} seems to be related to citrix or Virtual Disk Service may be some users are trying to logon to citrix and the machine doesn't have the component installed.

If you could check these from component services then make "Everyone" with full permission and see it makes any difference.