Avatar of susithra
susithra
 asked on

SSPI Apache2.2 - Perl CGI

I am trying to do integrated windows authentication for intranet site using mod_auth_sspi.so for apache2.2 on windows 2008 server. I have installed mod_auh_sspi.so in my apache bin. I am not getting the initial authentication pop-up either and neither is the CGI ENV REMOTE_USER/AUTH_USER variable set. My changes in the httpd.conf file is as follows. Appreciate any inputs .
Thanks in advance.

<IfModule !mod_auth_sspi.c>
    LoadModule sspi_auth_module modules/mod_auth_sspi.so
</IfModule>

Open in new window

<Location "C:/Program Files (x86)/Apache Software Foundation/Apache2.2/htdocs/test">
Options FollowSymLinks
Order allow,deny
Allow from all
    
AuthName "test"
AuthType SSPI 
SSPIAuth On 
SSPIAuthoritative On 
SSPIOfferBasic on
Require valid-user 
SSPIDomain corp.company.com
</Location>

Open in new window

Scripting LanguagesPerlApache Web Server

Avatar of undefined
Last Comment
susithra

8/22/2022 - Mon
ASKER CERTIFIED SOLUTION
susithra

Log in or sign up to see answer
Become an EE member today7-DAY FREE TRIAL
Members can start a 7-Day Free trial then enjoy unlimited access to the platform
Sign up - Free for 7 days
or
Learn why we charge membership fees
We get it - no one likes a content blocker. Take one extra minute and find out why we block content.
Not exactly the question you had in mind?
Sign up for an EE membership and get your own personalized solution. With an EE membership, you can ask unlimited troubleshooting, research, or opinion questions.
ask a question
I started with Experts Exchange in 2004 and it's been a mainstay of my professional computing life since. It helped me launch a career as a programmer / Oracle data analyst
William Peck