troubleshooting Question

SSPI Apache2.2 - Perl CGI

Avatar of susithra
susithra asked on
PerlApache Web ServerScripting Languages
1 Comment1 Solution690 ViewsLast Modified:
I am trying to do integrated windows authentication for intranet site using mod_auth_sspi.so for apache2.2 on windows 2008 server. I have installed mod_auh_sspi.so in my apache bin. I am not getting the initial authentication pop-up either and neither is the CGI ENV REMOTE_USER/AUTH_USER variable set. My changes in the httpd.conf file is as follows. Appreciate any inputs .
Thanks in advance.

<IfModule !mod_auth_sspi.c>
    LoadModule sspi_auth_module modules/mod_auth_sspi.so
</IfModule>
<Location "C:/Program Files (x86)/Apache Software Foundation/Apache2.2/htdocs/test">
Options FollowSymLinks
Order allow,deny
Allow from all
    
AuthName "test"
AuthType SSPI 
SSPIAuth On 
SSPIAuthoritative On 
SSPIOfferBasic on
Require valid-user 
SSPIDomain corp.company.com
</Location>
ASKER CERTIFIED SOLUTION
susithra

Our community of experts have been thoroughly vetted for their expertise and industry experience.

Join our community to see this answer!
Unlock 1 Answer and 1 Comment.
Start Free Trial
Learn from the best

Network and collaborate with thousands of CTOs, CISOs, and IT Pros rooting for you and your success.

Andrew Hancock - VMware vExpert
See if this solution works for you by signing up for a 7 day free trial.
Unlock 1 Answer and 1 Comment.
Try for 7 days

”The time we save is the biggest benefit of E-E to our team. What could take multiple guys 2 hours or more each to find is accessed in around 15 minutes on Experts Exchange.

-Mike Kapnisakis, Warner Bros