Avatar of Michael Pfister
Michael Pfister
Flag for Germany asked on

Internet Explorer 9 start page gets redirected every time

One of my users was logged in at a hotel WLAN.
Now the start page does no longer work, he always gets redirected to Google.

When opening IE, there is a short display of a page

http://www.my-cloud.eu/redirector


And "Welcome to The Cloud network, we are still trying to get you redirected - please wait !"

Then Google opens and not the company web site thats set as start page in IE.

What I already tried and did not help:

- ran virus scan, no findings
- checked extension in IE extensions manager, nothing suspicious
- reset of all IE settings
- checked hosts, no entries
- checked proxy settings, empty
- ran Hijackthis, no strange BHOs
- deactivated all extensions via IE extensions manager
- its not the router, it also happens when connected via mobile
- looked at the automatically started programs, nothing suspicious

What helped:
- starting iexplore.exe with parameter -noext
 (this is of course no solution)
- Installed Firefox, its not affected

The 64-bit Internet Explorer is redirected as well!

Any ideas where to look or what to look for?
Windows 7Windows OSWeb Browsers

Avatar of undefined
Last Comment
Michael Pfister

8/22/2022 - Mon
ASKER CERTIFIED SOLUTION
n2fc

Log in or sign up to see answer
Become an EE member today7-DAY FREE TRIAL
Members can start a 7-Day Free trial then enjoy unlimited access to the platform
Sign up - Free for 7 days
or
Learn why we charge membership fees
We get it - no one likes a content blocker. Take one extra minute and find out why we block content.
Not exactly the question you had in mind?
Sign up for an EE membership and get your own personalized solution. With an EE membership, you can ask unlimited troubleshooting, research, or opinion questions.
ask a question
Alexios

Hello

An add-on is responsible for this behavior or IE cache
Disable all add-ons, accelerators, toolbars, search providers. All of them by once
Clean all cache via CCLEANER

To turn add-ons on or off in Internet Explorer
Open Internet Explorer by clicking the Start button . In the search box, type Internet Explorer, and then, in the list of results, click Internet Explorer.
Click the Tools button , and then click Manage add-ons.
Under Show, click All add-ons
Click an add-on, and then do one of the following:
To make the add-on available for use in the browser, click Enable.
To turn the add-on off so it can't be used in the browser, click Disable.
Repeat step 4 for each add-on that you want to turn on or off. When you're finished, click Close.


If the error stops then enable one by one the add-ons
Peter Kwan

Here is the source code for your provided link:

<html>
<head>
    <title>Welcome </title>
<meta http-equiv="Refresh" content="1; URL=http://www.google.com" />
</head>

<body bgcolor="#FFFFFF">
<p><a href="http://ganag.com"><img src="auth_logo.gif" width="150" height="40" border="0"></a> </p>
<p><font face="Arial, Helvetica, sans-serif" size="3"><b>Welcome to The Cloud
  network, we are still trying to get you redirected - please wait !</b></font> </p>
<p><br>
<img src="bug.gif" width="75" height="56" border="0">
</p>
</body>

</html>


As you can see, it is hardcoded to redirect to google.com when accessing the page. Therefore, the only way you can go to start page is press "Home" button after loading the Google page.
Michael Pfister

ASKER
pkwan, the problem is: the start page in IE is set  to http://companysite.com, but IE just seems to ignore that.
It loads http://www.my-cloud.eu/redirector everytime I press the home button and redirects then to Google...
http://www.my-cloud.eu/redirector is NOT the start page I've set in IE.
The start page I have set in IE is NOT redirecting to http://www.my-cloud.eu/redirector.
I started with Experts Exchange in 2004 and it's been a mainstay of my professional computing life since. It helped me launch a career as a programmer / Oracle data analyst
William Peck
Michael Pfister

ASKER
n2fc, that sounds promising... I will check it on Friday when the system hopefully arrives at my desk...
Michael Pfister

ASKER
Kostasp, I've disabled all add-ons and it didn't help. The only thing I didn't try was CCLEANER. Will do that on Friday...
Alexios

Hope to solve it

"see" you on Friday then...
Get an unlimited membership to EE for less than $4 a week.
Unlimited question asking, solutions, articles and more.
n2fc

Good luck! Interested to hear what eventually works for you...

If you don't get anywhere with the solutions provided, you might consider upgrading to IE 10, which is now available for WIN 7 to see if that solves the issue for you.
Michael Pfister

ASKER
n2fc, I've already considered upgrading to IE 10 but Windows Update is broken as well. This stupid error where you have to download the "System Update Readiness Tool"... 400 MB over a line with small bandwith ... have to fix that in the office with a fast internet connection.
Michael Pfister

ASKER
Great, that solved it... so easy ... thanks a lot
Experts Exchange has (a) saved my job multiple times, (b) saved me hours, days, and even weeks of work, and often (c) makes me look like a superhero! This place is MAGIC!
Walt Forbes