Link to home
Start Free TrialLog in
Avatar of flynny
flynnyFlag for United Kingdom of Great Britain and Northern Ireland

asked on

Updating AJAX dll on site

Hi all,

Sorry for being dumb here.

I'm getting the following error after updating the AjaxControlToolkit.dll on a site, after copying the new DLL to the bin folder;

Could not load file or assembly 'AjaxControlToolkit' or one of its dependencies. This assembly is built by a runtime newer than the currently loaded runtime and cannot be loaded.

After googling around to fix the issue, I changed the application pool on IIS (Version 7.5.7600) fromt he default site named pool to be ASP.NET Classic (I have also tried Integrated).

However I then get a 500 error when I try to navigate the site?

Can anyone direct me in the right direction please?
Avatar of gaurav05
gaurav05
Flag of India image

Hi,

Make sure you install the correct version of the AjaxControlToolkit:

Version 3.0.20229 2008-02-29 release of the AJAX Control Toolkit targets the official release of .NET Framework 3.5 and Visual Studio 2008.

Version 1.0.20229 You can also download the Toolkit for .NET Framework 2.0, ASP.NET AJAX 1.0 and Visual Studio 2005.

Version 3.0.40412

April 12, 2010 release of the AJAX Control Toolkit for ASP.NET 3.5 Service Pack 1 and Visual Studio 2008 SP1.

Version 4.1.51116.0

Nov 16 2011 release of the AJAX Control Toolkit for ASP.NET 4.0 and Visual Studio 2010

Version 4.1.60919

September 2012 release of the AJAX Control Toolkit for ASP.NET 4.5 and Visual Studio 2012
Avatar of flynny

ASKER

Hi gaurav05,

Thanks for the reply.

sorry, do you mean is installed on the server?

I have browsed to programs and featutes (the server is running windows web server 2008).

Currently installed is Microsoft .NET Framework 4 extended and Microsoft Framework 4 Client Profile.

There is also Microsoft ASP.NET 2.0 AJAX Extensions 1.0 installed (there is no installed in the Binary .NET 4 zip i downloaded?) Do I need to physically run an installer on the server?

The original DLL file which was working was 3.5.40412.2

however I wanted to use the MultiHandleSlider which did not appear to be in this release? So I have downloaded the 4.1.7.0123 version, which is causing the issues.

I assumed by having .NET 4 installed this would support itdo I need to install anything further?
ASKER CERTIFIED SOLUTION
Avatar of gaurav05
gaurav05
Flag of India image

Link to home
membership
This solution is only available to members.
To access this solution, you must be a member of Experts Exchange.
Start Free Trial
Avatar of flynny

ASKER

Sorry,

I uploaded the 3.5 version and all is back to normal.

Is there any benefit from me updating to 4.0?

Also I seem to have 4.0 installed and like i mentioned earlier i set the pool to be 4.0 but this didnt seem to work? any reason why you think this owul dhappen?