Avatar of Teavana
Teavana
Flag for United States of America asked on

Install Exchange 2010

I am try to install Exchange 2010 on a new 2008 server that I joined and promoted as a DC in a SBS 2003 Environment (migration).

When I run the following commands on the 2008 R2 server they both fail.

•Run D:\setup /PrepareLegacyExchangePermissions - Say that the Forest Functional Level is not server 2003 native or later.

I did a domain prep and a Forest prep before I promoted the new 2008 R2 server but I had some prelication issues (the older server was not replicating to the new server). I resolved this issue now.

Should I re-run the forestprep command ?

•Run D:\setup /PrepareSchema - FAILED
ExchangeSBSWindows Server 2008

Avatar of undefined
Last Comment
Teavana

8/22/2022 - Mon
SOLUTION
Dmitriy Ilyin

Log in or sign up to see answer
Become an EE member today7-DAY FREE TRIAL
Members can start a 7-Day Free trial then enjoy unlimited access to the platform
Sign up - Free for 7 days
or
Learn why we charge membership fees
We get it - no one likes a content blocker. Take one extra minute and find out why we block content.
Not exactly the question you had in mind?
Sign up for an EE membership and get your own personalized solution. With an EE membership, you can ask unlimited troubleshooting, research, or opinion questions.
ask a question
Teavana

ASKER
Thank you for responding..... I already did steps 1 - 5 and I am still getting this message.

I also changed the Exchange mode to native.

So the next step would be to re-run the /forestprep and domainprep.

Will this break anything ? I a doing this in a live production environment. Thank you!
Dmitriy Ilyin

this will not break anything. Dirung this operation your scheme will be modified to support Exchange 2010 attribiutes and properties.
If you afraid, you can select custom installation and install only management tools. After this you can add needed roles.
PrepareLegacyExchangePermissions should be run only after you domain will be prepared for 2010 Exchange.
Teavana

ASKER
Thank you, I will re-run the forestprep and domainprep command again on the SBS2003 server then run the PrepareLegacyExchangePermissions command.

Hopefully this will fix this issue the second time arround now since the replication issue is now resolved.

Thank you, I will let you know the results after I do this today.
I started with Experts Exchange in 2004 and it's been a mainstay of my professional computing life since. It helped me launch a career as a programmer / Oracle data analyst
William Peck
Teavana

ASKER
I was able to get Exchange installed sucessfully. I now have both servers running as of now. I would like to be able to transffer some of the mailboxes over. I will not be able to X all the mail boxes at the same time.

How do I configure  a connetor between the two servers, that way they can both be use to send and recive emails untill I finished the migration?

I am using Exchange 2010 on server 2008 R2 OS from a  SBS 2003 with Exchange.
SOLUTION
Exchange_Geek

Log in or sign up to see answer
Become an EE member today7-DAY FREE TRIAL
Members can start a 7-Day Free trial then enjoy unlimited access to the platform
Sign up - Free for 7 days
or
Learn why we charge membership fees
We get it - no one likes a content blocker. Take one extra minute and find out why we block content.
Not exactly the question you had in mind?
Sign up for an EE membership and get your own personalized solution. With an EE membership, you can ask unlimited troubleshooting, research, or opinion questions.
ask a question
Teavana

ASKER
Just to be clear, I should use Winows powershell or Excange Management shell ?  Thanks
ASKER CERTIFIED SOLUTION
Log in to continue reading
Log In
Sign up - Free for 7 days
Get an unlimited membership to EE for less than $4 a week.
Unlimited question asking, solutions, articles and more.
Teavana

ASKER
Thank you
Get an unlimited membership to EE for less than $4 a week.
Unlimited question asking, solutions, articles and more.