Link to home
Start Free TrialLog in
Avatar of duncanb7
duncanb7

asked on

SSH access on CentOS Linux

Dear Experts,

I just switch to my share server to VPS server on one hosting company.
Now I got root password and access right.

When I connect to root 's SSH access through Putty , it is okay and logged into the root's directory.

When I connect to my user account trhough Putty , it failed and echo out message as
such as
"Shell access is not enabled on your account!
If you need shell access please contact support"

What I should change on SSH in order to enable my shell access ?

now my root login is  on VP server
login:root
servername:vps

my old user account in shared-server
login:duncan
servername:duncan.com


How to enable my SSH access from shared-server to VPS server
Now I don't use any Cpanel anymore since now it needs to pay fee on VPS

Please advise
Duncan
ASKER CERTIFIED SOLUTION
Avatar of comfortjeanius
comfortjeanius
Flag of United States of America image

Link to home
membership
This solution is only available to members.
To access this solution, you must be a member of Experts Exchange.
Start Free Trial
Avatar of duncanb7
duncanb7

ASKER

I could not go to my account except
root@vps[~]#


when I type at root directory su - duncan it also echo out the warning message
"Shell access is not enabled on your account!
If you need shell access please contact support"
Are you the hosting provider; because you would have to obtain this information from them about the VPS setup email and server information.
No , I just have one account of shared-server in one hosting  company and now
I swithced to VPS account in the same hosting company. Since the VPS account is unmanaged and no Cpanel provide, I need to do some Linux system command to change some system setting
You will need to contact your web hosting provider about this first or try to authenticate to the share account, that you have access to, and see if you can enable shh.  Look for something that pertain to web hosting or hosting and try to find settings; there should be something that allows you to enable ssh.
Just change the /etc/passwd file

for username duncan

duncan:x:500:500::/home/duncan:/bin/bash  from
duncan:x:500:500::/home/duncan:/usr/local/cpanel/bin/noshell

the issue is fixed
The command chsh does just that: change shell.