Failed to connect to server. Error: 0x800401F0 - Windows 7

I'm having some hard time with a clients Windows 7 x64 PC.

I'm trying to install a HP printer software which I have successfully installed on all the Windows XP machines but it keeps failing on this Win7 computer. I have also tried downloading the same software package.

After every try I get an error logged in the Windows Logs / Applications:
MSIInstaller Error ID1015
Failed to connect to server. Error: 0x800401F0

I have tried "clean" boot by deselecting everything from the msconfig file but no luck.

I have also done cfg /scannow which brought up no errors

Any help would be very welcome.
kirretAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

kirretAuthor Commented:
Wanted to add that this PC is not part of a domain but just a workgroup
0
MHMAdminsCommented:
When you run the installer first off make sure the driver is compatible with windows 7 64-bit, secondly due to the UAC (User Account Control) in windows 7 you have to right click the installer file and run as administrator.
0
Mike RoeCommented:
What type of printer
0
Cloud Class® Course: Microsoft Office 2010

This course will introduce you to the interfaces and features of Microsoft Office 2010 Word, Excel, PowerPoint, Outlook, and Access. You will learn about the features that are shared between all products in the Office suite, as well as the new features that are product specific.

kirretAuthor Commented:
@ Fredbear891 - as I said at the beginning of mu original post it's x64

It's a brand new HP OfficeJet Pro 8600.

@MHMAdmins - As I said I've downloaded the software separately from HP's site, which gives me the correct version for Win x64 anyway so it can't be that the printer isn't compatible Win x64.
Regarding UAC and right-clicking on it, I did it both ways before posting this question - didn't quite consider it as a step of troubleshooting the actual error I'm getting therefore didn't post it here before.

Thanks
0
MHMAdminsCommented:
Try this and then run the installer again:

1. On the "Start" menu, click "Run:.
 
2. In the "Open" box, type "msiexec /unreg", and then press ENTER.
 
3. On the "Start" menu, click "Run".
 
4. In the "Open" box, type "msiexec /regserver", and then press ENTER.
0
kirretAuthor Commented:
ok, so I tried the first option you gave with the installer from HPs website, still fails at the exact same place.

With this "msiexec /unreg" when I do that and I get it listed I'll do right click and Run as an Admin I get a Windows Installer box up on the screen with different options like /a or /uninstall etc I think it's just showing what else I should be using to do certain tasks.
And the same applies when I do msiexec /regserver, the same box on the screen again. So I'm not sure anything actually happens. Should I try to reinstall the package anyway now?

Thanks for your help
0
MHMAdminsCommented:
try to uninstall the software first as something may be sticking in the registry.
0
kirretAuthor Commented:
Sorry, I actually just pasted "msiexec /regserver" into the Start menu box and did Run as an admin. I followed your instructions again, got the Run box but got nothing on the screen when pressed OK
0
kirretAuthor Commented:
I did remove all of the HP software before actually
0
kirretAuthor Commented:
I've just run the HP removal tool, will try to reinstall again but I don't think it will work as there's something with Windows and the Installer service or something...
0
Mike RoeCommented:
Is the filename hppiw.exe

I have had very good success with this program on multiple printers
0
Mike RoeCommented:
disable firewall also
0
kirretAuthor Commented:
Let's come back to the error message guys, MSI Installer and Error ID 1015, and as I mentioned before I did a "clean" boot so no firewall was enabled as the Antivirus program was disabled.
0
Mike RoeCommented:
Sorry I pissed you off.  Throwing a lot of things at you since there are so many things to deal with on a printer unlike most hardware

there are 5 different 8600 printers that do different things.  So when i ask what printer dont you think you would say 8600 plus or 8600e

Thanks
0
Mike RoeCommented:
There is a print and scan doctor and also a hardware diagnostics for these printers.  Have you run any of them.

Firmware updates
0
MHMAdminsCommented:
You may also want to try the Microsoft Installer Clean up Utility just to make sure: http://gallery.technet.microsoft.com/MSI-cleanup-utility-3889c8db
0
kirretAuthor Commented:
All it says both on the box and on the printer itself is OfficeJet Pro 8600. I've also checked the sticker on the back and that adds no additional information.

I'm 99% sure that the software I have is the correct one as I had no problems installing the same printer using the same CD on other 2 PCs, although they were XPs.

If I'm correct then installing an incorrect version of the software would flag up differently, usually by a pop up box on the screen stating that this is an incorrect software for this hardware. It's not the case here.

I've installed a lot of printers in the last 8 years and something tells me it's not the printer what's the problem here, or the software I'm trying to install (because even the install wizard you pointed out beforehand failed with the same problem)

You don't get MSIInstaller related errors when you have a wrong piece of software (and it's not the hardware because it works from other PCs)

I'm going to try the Microsoft Installer Clean up utility, let's see what that does.

Thanks.
0
kirretAuthor Commented:
Clean up Utility went through it's process but still no luck with the HP installation...
0
kirretAuthor Commented:
I've also created another user account to see if the same problem exists there and it's nothing to related to this user account I'm using but no, still nothing.
0
MHMAdminsCommented:
Try going into regedit to HKEY_LOCAL_MACHINE>SYSTEM>CURRENTCONTROLSET>CONTROL>PRINT>  and under the Environment and printers dropdown see if it has the officejet listed, then delete those keys and re-try.
0
Mike RoeCommented:
Ok i am just throwing this out there what about malware
0
kirretAuthor Commented:
I'll try the regedit later but can't see that fixing it because that regedit fix is used mainly when you can't delete the printers from Devices list (have used it a lot of times before)

I scanned with Combofix  earlier today + it has a proper antivirus installed so can't see malware being an issue either as nothing was found.

The website with an exact same error - not quite the same error as he had problems with adding the Scan functionality, and the "HP OfficeJet Pro 8600 Basic Device Software" installed fine for him (this is the 1st step in the installation process) but mine fails even before that, won't install anything at all.
0
kirretAuthor Commented:
An update. Because installing the HP OfficeJet Pro 8600 keeps still failing I re-installed the software for LaserJet CP1525 which had no problems with installing from the file I downloaded from HP Support site... So can install one installation package but not the other, strange
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
kirretAuthor Commented:
I wouldn't say my own update was an answer to the problem but as no working solution has been provided I'm going to close the question. Thanks everyone for help.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Windows 7

From novice to tech pro — start learning today.