GPO to redirect Outlook OST location (VMware Persona Management)

elorc
elorc used Ask the Experts™
on
I'm responsible to implementing and maintaining a VMware View environment, and a problem was recently brought up to me. We have VMware Persona Management configured for a Windows 7 VDI pool. It's working well, but the issue is that users are having a problem with their OST file for Outlook 2010. When they open Outlook, it always downloads the OST file because it is being stored in the Local structure of their profile, which is not part of the Persona Management. We'd rather not add the Local folders to Persona, so I'm trying to see if there's a way that I can redirect the OST to be within folders that are already roamed. Honestly, I'd be happy if I could drop it into their home directory.

Is there a group policy that I can use to change the location of Outlook's OST file? Thanks!
Comment
Watch Question

Do more with

Expert Office
EXPERT OFFICE® is a registered trademark of EXPERTS EXCHANGE®
IT Manager
Commented:
See screen shot.
OM Gang

GPO setting
Marshal HubsEmail Consultant
Commented:
Hi,

You can use the GPO setting to force a change path for the OST file

1. Locate and then select the following registry subkey:
HKEY_CURRENT_USER\Software\Microsoft\Office\11.0\Outlook
2. After you select the subkey, point to New on the Edit menu, and then click Expandable String Value.
3. Type ForceOSTPath, and then press ENTER.
4. Right-click ForceOSTPath, and then click Modify.

We could use Group Policy Preference to add a registry key item, please follow the steps below:User(Computer) Configuration->Preferences->Windows Settings->Registry key
Right click Registry key, choose New Registry Item, then enter the Key path, Value name is : ForceOSTPath

Value data is the path you specified.

Author

Commented:
I figured there must be a relatively simple way to do it, but I have never really done much with the Office ADM templates (and they're not currently installed on this domain). That seems like it's the way to go.

Thanks!
We have Citrix environment and Outlook 2010 as a published app. When I set the path for the OST file in the GPO shown above it creates path but does not move or create an OST file in that path. When I go into the user's Mail Profile is still shows the default location.

I have also deleted the mail profile and let it be recreated but it again puts the OST file in the default location.

I have also tried setting the ForceOSTPath registry entry with no change in the result.

Outlook is fully patched and the Citrix servers are Windows Server 2008 R2.

Any suggestions here would be most appreciated.

Commented:
Did anyone find a workaround/fix for the GPO preference not being applied and OST still defaulting to it's original path? Using the Office 2013 Admin Templates on a Windows 2012 R2 RDS server

Do more with

Expert Office
Submit tech questions to Ask the Experts™ at any time to receive solutions, advice, and new ideas from leading industry professionals.

Start 7-Day Free Trial