Solved

RDP problem

Posted on 2013-05-09
3
585 Views
Last Modified: 2013-07-08
rdpWhen ever i VPN and try to rdp any server or desktop on the remote network i get the following error message...

Because of an error in data encryption, this session will end. Please try connecting to the remote computer again.

Any suggestions?rdp
0
Comment
Question by:dscla
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 2
3 Comments
 

Author Comment

by:dscla
ID: 39154049
if i am not connected to the vpn, i can rdp my local servers without any issues.
0
 
LVL 38

Accepted Solution

by:
Hypercat (Deb) earned 500 total points
ID: 39155510
I think this will resolve your issue - quoted from the following article:  

http://technet.microsoft.com/en-us/library/cc770833.aspx

To configure the server authentication and encryption settings for a connection:

1.  On the RD Session Host server, open Remote Desktop Session Host Configuration. To open Remote Desktop Session Host Configuration, click Start, point to Administrative Tools, point to Remote Desktop Services, and then click Remote Desktop Session Host Configuration.

2.  Under Connections, right-click the name of the connection, and then click Properties.

3.  In the Properties dialog box for the connection, on the General tab, select the server authentication and encryption settings that are appropriate for your environment, based on your security requirements and the level of security that your client computers can support.

4.  If you select SSL (TLS 1.0), either select a certificate that is installed on the RD Session Host server, or click Default to generate a self-signed certificate. If you are using a self-signed certificate, the name of the certificate will display as Auto generated.

5.  Click OK.

You can also configure server authentication and encryption settings by applying the following Group Policy settings:

Set client connection encryption level
Require use of specific security layer for remote (RDP) connections
Server Authentication Certificate Template
Require user authentication for remote connections by using Network Level Authentication

These Group Policy settings are located in Computer Configuration\Policies\Administrative Templates\Windows Components\Remote Desktop Services\Remote Desktop Session Host\Security and can be configured by using either the Local Group Policy Editor or the Group Policy Management Console (GPMC). Note that these Group Policy settings will take precedence over the settings configured in Remote Desktop Session Host Configuration, with the exception of the Server Authentication Certificate Template policy setting.
0
 
LVL 38

Expert Comment

by:Hypercat (Deb)
ID: 39155514
Oops - forgot to say that you want to set the security to "RDP Security Layer."
0

Featured Post

Edgartown IT Case Study

Learn about Edgartown's quest to ensure the safety and security of the entire town's employee and citizen data. Read the case study!

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

I was prompted to write this article after the recent World-Wide Ransomware outbreak. For years now, System Administrators around the world have used the excuse of "Waiting a Bit" before applying Security Patch Updates. This type of reasoning to me …
Windows 10 Creator Update has just been released and I have it working very well on my laptop. Read below for issues, fixes and ideas.
This tutorial will walk an individual through the process of installing of Data Protection Manager on a server running Windows Server 2012 R2, including the prerequisites. Microsoft .Net 3.5 is required. To install this feature, go to Server Manager…
Windows 8 came with a dramatically different user interface known as Metro. Notably missing from that interface was a Start button and Start Menu. Microsoft responded to negative user feedback of the Metro interface, bringing back the Start button a…

688 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question