help with rsync on AIX

I would like to copy directory from the source server with the following using rsync:

ignore symbolic links
skip the file/directory if it is the same on the target server

Can someone please help?
Who is Participating?
woolmilkporcConnect With a Mentor Commented:
- recursively: the "-r" option. Implied with "-a"

- ignore symlinks: the "--no-links" option. Not implied with "-a"!

- skip if the same: That's the default behaviour anyway. You can additionally instruct rsync to ignore files that are newer on the target server by means of the "-u" option.

So your command should look similar to this:

rsync -a --no-links -u -e "/usr/bin/ssh" /source/dir/ user@target-server:/target/dir

Please note that the trailing slash in the source dir spec tells rsync not to create an additional directory level on the target.

I used "-e /usr/bin/ssh" to  force using the ssh protocol. Please adjust the ssh path if it's different, or replace "ssh" with "rsh" if you don't have ssh installed. The latter requires modifying the .rhosts file on the target to include the source host, however.
AIX25Author Commented:
Thank you! I was able to run this over ssh.
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.