Solved

Exchange 2007 Restore Mailbox Data Deleting

Posted on 2013-05-10
7
68 Views
Last Modified: 2015-03-25
Summary: Trying to restore an old Exchange 2007 Mailbox, the restore seems to work as I see data in Outlook however as soon as the restore is complete the data gets deleted.

Details: We have Exchange 2010 with all users moved over.  One user was missing some very old mail from our Exchange 2007 server.  I powered on the Exchange 2007 server, recreated the DB the users mail was in as it was no longer there and created a Restore User in a different existing DB on it.  Via Arcserve I restored the DB into a Recovery Group, mounted it and selected the user's mailbox to restore to the Restore user /restore folder. The restore starts OK and runs for 6+ hours (huge mailbox).  I can open Outlook of the Restore user and view the mail in the /Restore folder and was able to copy some to a .PST archive.  When the restore completes, the data starts deleting itself and within a few seconds GBs worth or recovered data is gone.  I've tried two different tapes from different times with the same results.
Any help would be greatly appreciated.
0
Comment
Question by:DigitalInfuzion
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 4
  • 3
7 Comments
 
LVL 16

Expert Comment

by:Carol Chisholm
ID: 39155279
I would guess that somewhere there is a POP account somewhere connecting to the mailbox - as the POP account downloads the mail it is deleted from the mailbox.
This is how POP works.
Why not disable POP and then it will not be able to download?
0
 
LVL 1

Author Comment

by:DigitalInfuzion
ID: 39156176
Thanks for the suggestion however it doesn't look like it's the issue.  My CAS server is offline and the setting for the mailbox is set to POP3 False.
I did some more tests with individual folders running Restore-Mailbox.  When the restore completes or if I Break out of PowerShell, the data gets deleted.  If during the restore I set Outlook to work offline, the data that has been restored to that point will stay.  When I set Outlook back to work online the data gets deleted.
0
 
LVL 16

Expert Comment

by:Carol Chisholm
ID: 39156241
So turn off the Exchange cache in Outlook before you start - looks like Outlook has registered an empty mailbox, more recently than the restored stuff!
0
Are your AD admin tools letting you down?

Managing Active Directory can get complicated.  Often, the native tools for managing AD are just not up to the task.  The largest Active Directory installations in the world have relied on one tool to manage their day-to-day administration tasks: Hyena. Start your trial today.

 
LVL 1

Author Comment

by:DigitalInfuzion
ID: 39156956
Actually when I originally ran into the problem, cache mode was off and I turned it on.  I have played around with some permissions to set delete to none and tried a few other things.  In any event the data seems to be staying now.

Thanks...
0
 
LVL 16

Expert Comment

by:Carol Chisholm
ID: 39157668
Glad to be of help. It's not a nice sort of thing to watch stuff vanish before you eyes.
0
 
LVL 1

Accepted Solution

by:
DigitalInfuzion earned 0 total points
ID: 40679131
(overdue update) Ended up building an Exchange test environment and using Kernel for Exchange Server to restore data.
1
 
LVL 1

Author Closing Comment

by:DigitalInfuzion
ID: 40686643
final solution
0

Featured Post

Announcing the Most Valuable Experts of 2016

MVEs are more concerned with the satisfaction of those they help than with the considerable points they can earn. They are the types of people you feel privileged to call colleagues. Join us in honoring this amazing group of Experts.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Find out what you should include to make the best professional email signature for your organization.
This article aims to explain the working of CircularLogArchiver. This tool was designed to solve the buildup of log file in cases where systems do not support circular logging or where circular logging is not enabled
In this video we show how to create an email address policy in Exchange 2013. We show this process by using the Exchange Admin Center. Log into Exchange Admin Center.:  First we need to log into the Exchange Admin Center. Navigate to the Mail Flow…
In this video we show how to create a mailbox database in Exchange 2013. We show this process by using the Exchange Admin Center. Log into Exchange Admin Center.: First we need to log into the Exchange Admin Center. Navigate to the Servers >> Data…
Suggested Courses

626 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question