Still celebrating National IT Professionals Day with 3 months of free Premium Membership. Use Code ITDAY17

x
?
Solved

Dynamics CRM 2011 copy form "the specified organization is disabled"

Posted on 2013-05-10
11
Medium Priority
?
1,704 Views
Last Modified: 2013-05-16
I'm getting the "specified organization is disabled" message when trying to create a lead with a new form. I took the existing lead form, opened it and went to customization, and then did a save as for a form with a different name.

When ever I try to add a lead using this new form I get the "The specified organization is disabled"

How do you change the org a form is associated with? and why would it change just because i did a save as?

thank you
0
Comment
Question by:HeartsOnFire
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 5
  • 4
  • 2
11 Comments
 
LVL 30

Expert Comment

by:Feridun Kadir
ID: 39155486
There is no provision for forms to be linked to different organizations in Dynamics CRM. When you create a new form an entity, it is for the same organization.

When in the process do you get the error, is it when you open the form, after you the open form and click save or some other time?
0
 
LVL 27

Expert Comment

by:Chinmay Patel
ID: 39155496
Hi HeartsOnFire,

Try restarting IIS. Also is this the only organization? or you have other organization on this server?

Regards,
Chinmay.
0
 
LVL 1

Author Comment

by:HeartsOnFire
ID: 39155881
I tried the iis reset with no luck.

We have 3 organizations in crm -
Blank      enabled
HOF        disabled
HOFCRM    endabled

we do all our work in HOFCRM. I believe the blank one and the HOF one are there for when we move stuff into our test and dev servers

I'm copying the Leads form we use for our marketing team. I get the error when I go to marketing.. leads.. then click new to create a lead.. switch the form to the "new form"

The marketing form was created as part of a managed solution. The new form is not in the solution. I tried this in our dev environment and it worked fine.

I enabled the HOF org and was able to get in.. but I don't want that one enabled. I don't know why it's tied to that org
0
Get free NFR key for Veeam Availability Suite 9.5

Veeam is happy to provide a free NFR license (1 year, 2 sockets) to all certified IT Pros. The license allows for the non-production use of Veeam Availability Suite v9.5 in your home lab, without any feature limitations. It works for both VMware and Hyper-V environments

 
LVL 30

Expert Comment

by:Feridun Kadir
ID: 39155903
Hmm, managed solutions. They do seem to cause a lot of trouble.

I would consider deleting the new form that you created that is not working and creating a new one (but not copying the one that came from the managed solution try instead copying the out of the box information form).  I realise this will require more work but I don't have another suggestion for you.
0
 
LVL 1

Author Comment

by:HeartsOnFire
ID: 39156058
feridum.. great suggestion!

I just tried open the default lead form.. information form and get the same error. I'm wondering if they over wrote something when everything was installed.. if I enable that other org they work.

I just don't know what happens if that org is started... hmmmm..
0
 
LVL 30

Accepted Solution

by:
Feridun Kadir earned 1200 total points
ID: 39156091
Sounds as if things have really got messed up - you might need to raise a support ticket with Microsoft.

If the default form works when you enable the other org, perhaps you will be able to copy the form while the other is enabled?

Did you try unistalling the managed solution? Or does that have many other items in as well as the forms?
0
 
LVL 1

Author Comment

by:HeartsOnFire
ID: 39156251
The managed solution has a lot of things in it. It's funny, I almost think if it was just an unmanaged solution I'd be ok.

almost feels like the managed solution was part of the org that is disabled and it was brought over incorrectly to this org or has some link to the disabled on. I think i may just enable the other org.. I'm not sure what the worst that can happen is...

I may open the ticket at some point. My marketing team just wants to play around with adding a bunch of new fields to a form and playing with it.
0
 
LVL 30

Expert Comment

by:Feridun Kadir
ID: 39156370
I strongly advocate against the use of managed solutions unless you are an ISV developing add-ons for CRM for resale.

But, having said that importing a managed solution with changes to forms should work and the import of the solution should update forms in the organization that you are importing to and not reference the original organization. Something is not right.
0
 
LVL 27

Expert Comment

by:Chinmay Patel
ID: 39156838
Are there any plugin/s configured on lead?
0
 
LVL 1

Author Closing Comment

by:HeartsOnFire
ID: 39171177
feridum,

i'm still not sure what the real answer is yet, but I'm going to award the points for all the help and suggestions you gave. i need to have someone come in and tear it apart..

thank you for trying

RS
0
 
LVL 30

Expert Comment

by:Feridun Kadir
ID: 39171724
Thanks for the points. Sorry you didn't resolve the issue.
0

Featured Post

What is SQL Server and how does it work?

The purpose of this paper is to provide you background on SQL Server. It’s your self-study guide for learning fundamentals. It includes both the history of SQL and its technical basics. Concepts and definitions will form the solid foundation of your future DBA expertise.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

On Sep 22nd 2014 Microsoft released Update Rollup 1 for Microsoft Dynamics CRM 2013 Service Pack 1 and back in July Update Rollup 3 was released.  So we now have:   Update Rollup 1Update Rollup 2Update Rollup 3Service Pack 1Update Rollup 1 for S…
Desired Skill Set for Microsoft Dynamics CRM Technical Resources – Part II
Video by: ITPro.TV
In this episode Don builds upon the troubleshooting techniques by demonstrating how to properly monitor a vSphere deployment to detect problems before they occur. He begins the show using tools found within the vSphere suite as ends the show demonst…
Want to learn how to record your desktop screen without having to use an outside camera. Click on this video and learn how to use the cool google extension called "Screencastify"! Step 1: Open a new google tab Step 2: Go to the left hand upper corn…

688 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question