Solved

Xenapp 6.5 Server

Posted on 2013-05-10
21
396 Views
Last Modified: 2013-06-05
I am getting the following error message ' An error occured while making the requested connection.'   when I try to launch any published application via web interface on one particular Xenapp 6.5 Servers.  

All other servers are alright.  All are upto date with HRP 01.  Logons are enabled on this server.  It has been rebooted but did not make any difference.  

Any idea what else to cheeck ? Nothing in the event logs on this server.
0
Comment
Question by:jafrullahm
  • 11
  • 6
  • 3
  • +1
21 Comments
 
LVL 9

Expert Comment

by:hodgeyohn
Comment Utility
1.  can you telnet to port 1494  to the server that is not working.
2.. if you go to the command line on one of your servers issue the command qfarm /load   please post the results..
0
 

Author Comment

by:jafrullahm
Comment Utility
I can telnet 1494 to the affected server from any other server and to any other server from this server.

The load on this server is 499 , Load Throttling load is 5000 ..... Logons enabled..  File attached. I have highlighed the affected sever with Red line..
0
 
LVL 9

Expert Comment

by:hodgeyohn
Comment Utility
check the application and system logs on the web interface server for sta, and xml errors.
0
 

Author Comment

by:jafrullahm
Comment Utility
Checked them but nothing specific to this server..
0
 
LVL 9

Expert Comment

by:hodgeyohn
Comment Utility
are there any STA, or XML errors on the web interface?
0
 

Author Comment

by:jafrullahm
Comment Utility
No...
0
 
LVL 10

Expert Comment

by:Casey Herman
Comment Utility
Check that the XTE and the IMA service are running.

Also do a qfarm /load from the command prompt and see if the server is showing a full load or not.

Let me know your results.
0
 
LVL 10

Expert Comment

by:Casey Herman
Comment Utility
sorry didnt see that you already read did the qfarm..
Have you done the Qfarm /load repeatedly to monitor the load. If you are at a ltl load of 5000 plus your 499, if another login happens that throws the total load to 10499.

What lb policies do you have in place?
0
 
LVL 2

Expert Comment

by:mlwa12144
Comment Utility
Telnet the server on port 1494 from the user machine and not from the server and check if the port is opened.
0
 

Author Comment

by:jafrullahm
Comment Utility
I can telnet 1494 from the user machine.

We only have one load balancing policy which is Office 2003 which is filtered for one AD group.
So, if user is a member of that AD group then he goes on to the servers in Office 2003 Worker Group and the rest of the users go to the server in Office 2010 WG.  The problem server is located in Office 2010 WG and the testing user is not in the 2003 AD group.
I have tested this server with the Load balancing for both options but still same error.
0
How your wiki can always stay up-to-date

Quip doubles as a “living” wiki and a project management tool that evolves with your organization. As you finish projects in Quip, the work remains, easily accessible to all team members, new and old.
- Increase transparency
- Onboard new hires faster
- Access from mobile/offline

 

Author Comment

by:jafrullahm
Comment Utility
Hi

  Any more Ideas how to resolve this server.  I dont want to rebuild it if it can be resolved.
0
 
LVL 10

Expert Comment

by:Casey Herman
Comment Utility
Have you tried publishing notepad to that server and seeing if it opens to figure out if it is a xenapp issue or an office 2010 issues?

-Casey
0
 
LVL 9

Expert Comment

by:hodgeyohn
Comment Utility
ok, crazy suggestion but works for a lot of things..

on each of your xenapp servers

1.  stop the ima service
2.  run the command dsmaint recreatelhc
3.  restart the ima, and any services it stopped
4.  restart the Citrix xml service
5.  on your web interface server run the command iireset.

at this point I think something went south on our xml service, and the ima service is where it gets its info.
0
 

Author Comment

by:jafrullahm
Comment Utility
Its same even with Notepad.

Hodgeyohn,  I have stopped IMA, recreated LHC and started the service but it did not make any difference. Restarted citrix xml service as well...
To be honest I am not sure if I want to do IISreset on production webinterface servers.
It did not affect any other servers at all.
Any other ideas ?
0
 
LVL 9

Expert Comment

by:hodgeyohn
Comment Utility
please run a qfarm /load and post the results...
0
 

Author Comment

by:jafrullahm
Comment Utility
Done it already, please see my initial comments....
0
 

Author Comment

by:jafrullahm
Comment Utility
I have looked again properly on the Web interface event viewer and this is the event id in application log

event id 30107

description: Site path: C:\inetpub\wwwroot\Citrix\External.

The Citrix servers reported that they are too busy to provide access to the selected resource. This message was reported from the XML Service at address http://10.128.120.72:80 [com.citrix.xml.NFuseProtocol.RequestAddress].  [Unique Log ID: a145d4a]
0
 

Author Comment

by:jafrullahm
Comment Utility
Any more ideas ?
0
 
LVL 9

Expert Comment

by:hodgeyohn
Comment Utility
it is either an ima issue, (recreatelhc usually take care of this), or it is a license issue.
check both the xenapp server and the license server for any errors.
0
 

Accepted Solution

by:
jafrullahm earned 0 total points
Comment Utility
It is strange but the issue is now resolved.  I had a look at Remote desktop session host configuration - there were two ICA-TCP connections, one says old_ica-tcp and the other one is normal one.  The old_ica-tcp is disabled.  When i re enable it then it starts accepting connections.  when I looked at properties of all the tabs they both have similar ones, but not sure why disabling old one stopped the connection.s
0
 

Author Closing Comment

by:jafrullahm
Comment Utility
It is resolved after enabling the connection.
0

Featured Post

Top 6 Sources for Identifying Threat Actor TTPs

Understanding your enemy is essential. These six sources will help you identify the most popular threat actor tactics, techniques, and procedures (TTPs).

Join & Write a Comment

Suggested Solutions

Title # Comments Views Activity
vmotion VMs with melio fs 1 491
Xen App SQL Log Files are huge 5 47
citrix farm discovery issue 1 35
Use of Training Budget 12 63
Citrix XenDesktop, Citrix Studio, Citrix Policies, Citrix XenApp
#Citrix #XenApp #Citrix Scout #Citrix Insight Services #Microsoft VMMAP #Microsoft ADEXPLORE #Microsoft RAMMAP #Microsoft TCPVIEW #Microsoft AUTORUNS #Microsoft PROCESS EXPLORER #Microsoft PROCESS MONITOR
How to install and configure Citrix XenApp 6.5 - Part 1. In this video tutorial we have explained step by step installation of Citrix XenApp 6.5 Server on Windows Server 2008 R2 is explained in this video. We have explained the difference between…
This demo shows you how to set up the containerized NetScaler CPX with NetScaler Management and Analytics System in a non-routable Mesos/Marathon environment for use with Micro-Services applications.

763 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

12 Experts available now in Live!

Get 1:1 Help Now