disabling export and data feed icons on SSRS tool bar

Using SSRS 2008 standard Edition.
I am trying to disable the data feed and export icons on the SSRS toolbar, as I do not want any one to be able to export/download my report data.

I have my HTMLViewer.css set as follows:
.ToolbarExport
{
	display: none
}
.ToolbarPrint
{
	display: none
}

.ToolbarAtomDataFeed
{
	display: none
}

Open in new window


The rsreportserver.config has the following:
<Extension Name="ATOM" Type="Microsoft.ReportingServices.Rendering.DataRenderer.AtomDataReport,Microsoft.ReportingServices.DataRendering" Visible="false"/>

Open in new window


I still see both the icons active when I load my report.

What else do I need to do?

Is there another way I can disable them?

Thank You.
patd1Asked:
Who is Participating?
 
ValentinoVConnect With a Mentor BI ConsultantCommented:
See Charlie's reply here: http://social.msdn.microsoft.com/Forums/en-US/sqlreportingservices/thread/200ae3eb-5032-4502-a7fa-73ae34205788

To hide the atom feed, basically you need to comment out the entire line. Setting the Visible property to False is, weirdly enough, not sufficient.
0
 
Alpesh PatelConnect With a Mentor Assistant ConsultantCommented:
ReportViewer1.ShowExportControls = false;
            ReportViewer1.ShowPrintButton = false;
0
 
patd1Author Commented:
I have already set [ReportServer].[dbo].[EnableClientPrinting]  to false, but I don't have any property name for export.

SELECT *
  FROM [ReportServer].[dbo].[ConfigurationInfo]
  where name like '%exp%' --no rows returned.
0
Free Tool: Site Down Detector

Helpful to verify reports of your own downtime, or to double check a downed website you are trying to access.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

 
Alpesh PatelAssistant ConsultantCommented:
Its' c# code. you can write code on page.




ReportViewer1.ShowExportControls = false;
            ReportViewer1.ShowPrintButton = false;
 

Open in new window

0
 
patd1Author Commented:
I commented out the whole line and re-started the service. I still see the icons.
/*
#.ToolbarExport
#{
#	display: none
}#
*/

/*
#.ToolbarAtomDataFeed
#{
#	display: none
#}
*/

Open in new window


I set the visible = false for all of the rendering options in the ReportServer.config. This made all the drop down options on the export icon disappear, which is good, serves my purpose, but, I still can use the data feed. When I click on the data feed icon it downloads the file and gives me a file save popup. How to disable that?


<Render>
			<Extension Name="XML" Type="Microsoft.ReportingServices.Rendering.DataRenderer.XmlDataReport,Microsoft.ReportingServices.DataRendering" Visible="false"/>
			<Extension Name="NULL" Type="Microsoft.ReportingServices.Rendering.NullRenderer.NullReport,Microsoft.ReportingServices.NullRendering" Visible="false"/>
			<Extension Name="CSV" Type="Microsoft.ReportingServices.Rendering.DataRenderer.CsvReport,Microsoft.ReportingServices.DataRendering" Visible="false"/>
			<Extension Name="ATOM" Type="Microsoft.ReportingServices.Rendering.DataRenderer.AtomDataReport,Microsoft.ReportingServices.DataRendering" Visible="false"/>
			<Extension Name="PDF" Type="Microsoft.ReportingServices.Rendering.ImageRenderer.PDFRenderer,Microsoft.ReportingServices.ImageRendering" Visible="false"/>
			<Extension Name="RGDI" Type="Microsoft.ReportingServices.Rendering.ImageRenderer.RGDIRenderer,Microsoft.ReportingServices.ImageRendering" Visible="false"/>
			<Extension Name="HTML4.0" Type="Microsoft.ReportingServices.Rendering.HtmlRenderer.Html40RenderingExtension,Microsoft.ReportingServices.HtmlRendering" Visible="false"/>
			<Extension Name="MHTML" Type="Microsoft.ReportingServices.Rendering.HtmlRenderer.MHtmlRenderingExtension,Microsoft.ReportingServices.HtmlRendering" Visible="false"/>
			<Extension Name="EXCEL" Type="Microsoft.ReportingServices.Rendering.ExcelRenderer.ExcelRenderer,Microsoft.ReportingServices.ExcelRendering" Visible="false"/>
			<Extension Name="RPL" Type="Microsoft.ReportingServices.Rendering.RPLRendering.RPLRenderer,Microsoft.ReportingServices.RPLRendering" Visible="false" LogAllExecutionRequests="false"/>
			<Extension Name="IMAGE" Type="Microsoft.ReportingServices.Rendering.ImageRenderer.ImageRenderer,Microsoft.ReportingServices.ImageRendering" Visible="false"/>
			<Extension Name="WORD" Type="Microsoft.ReportingServices.Rendering.WordRenderer.WordDocumentRenderer,Microsoft.ReportingServices.WordRendering" Visible="false"/>
		</Render>

Open in new window

0
 
ValentinoVConnect With a Mentor BI ConsultantCommented:
"I commented out the whole line and re-started the service. I still see the icons."

Ow, but it's the rsreportserver.config which you need to edit, not the css.  You need to comment out (or remove) the line that starts with:

<Extension Name="ATOM"

(the one you mentioned in your question)
0
 
patd1Author Commented:
Hmmmmmmmmm. ok that solves the issue now :-)
0
All Courses

From novice to tech pro — start learning today.