Solved

Exchange Port 25

Posted on 2013-05-10
13
295 Views
Last Modified: 2013-05-17
I manage my own emails via Exchange 2010 at my home. I was thinking of switching my internet provider from ATT to Comcast but Comcast blocks port 25 and they will not allow it for residential connections. They are only allowing port 465 and 587, so the question is can I use port 465 for Exchange to send and recieve mail, and will my SSL certificate be affected or will I need to create a new CSR. Comcast has a really good deal but I don't know if I can use exchange with the ports they allow. Please and let me know and give instructions or a link on doing this. Thanks in advance.
0
Comment
Question by:timgreen7077
  • 4
  • 2
  • 2
  • +3
13 Comments
 
LVL 14

Expert Comment

by:Juan Ocasio
ID: 39157312
Are you sure they block port 25?  I used to have a test exchange server and never had a problem, just had to port forward to the exchange server (which was actually hosted in VM).  It's been a while since I've had the test config up and running, but that is news to me.
0
 

Author Comment

by:timgreen7077
ID: 39157339
Yes, I'm positive they block it for residental. They actually told me, that is why I'm looking at an alternative.
0
 
LVL 19

Expert Comment

by:n2fc
ID: 39157358
Receiving is normally done via 110 (POP3)...
You can normally use any of the alternates allowed as well as 26 (not blocked for SMTP...

You certificates should still be good as they are not associated with a particular port.
0
 

Author Comment

by:timgreen7077
ID: 39157367
0
 
LVL 19

Expert Comment

by:n2fc
ID: 39157373
I would try it anyway...
I have had Comcast for years and have NEVER had 110 blocked!

25 on Comcast here is open to Comcast's own servers, but blocked to other networks!
0
 
LVL 82

Expert Comment

by:Dave Baldwin
ID: 39157573
Comcast had allowed port 25 until very recently.  The date of that article is last week.  Guess I'll have to change a few more settings!

I just checked.  Port 25 is not working now.
0
How your wiki can always stay up-to-date

Quip doubles as a “living” wiki and a project management tool that evolves with your organization. As you finish projects in Quip, the work remains, easily accessible to all team members, new and old.
- Increase transparency
- Onboard new hires faster
- Access from mobile/offline

 
LVL 63

Accepted Solution

by:
Simon Butler (Sembee) earned 500 total points
ID: 39158027
If you want to recieve email in to Exchange then you will have to use a mail hop service. You point your MX records at them, then they forward the email to you on another port (like 465). You should be able to use HTTPS for getting your email when away from the office without having to use POP or IMAP.

For outbound email, either go through the mail hop service again, or use the SMTP servers of the ISP, both of which will be a smart host in Exchange on the Send Connector.

Simon.
0
 
LVL 14

Expert Comment

by:Juan Ocasio
ID: 39158046
The other option, especially if you have to pay for a mail hop service (I'm not sure if it's free or not), is to use a Comcast Business.  In my location, it only costs about $30.00 more a month, but you get 5 static IP addresses (no more need to use a DDNS service your dynamic IP addresses), and all of the ports are open.  I'm really surprised Comcast is closing ports like that.  Like I said (and others in this post), it used to work like a charm.
0
 
LVL 7

Expert Comment

by:msifox
ID: 39159364
Clarification:
When others try to send email to your server, they will send to port 25, not 587, 110 or anything else. Those other ports are used in other situations, not in this one.

Hint:
When your ISP says that they block port 25, chances are that they block if only outgoing, but not incoming. In this case you could receive emails, but would have to configure your email server to send outgoing emails through the email server of your ISP (probably on port 587 with authentication).
0
 

Author Comment

by:timgreen7077
ID: 39159751
MSIFOX ---  I just contacted comcast and they block port 25 on outgoing and incoming mail.
0
 
LVL 7

Expert Comment

by:msifox
ID: 39159778
Ouch. Blocking it for incoming makes not much sense. It does not stop anybody from sending spam emails, which is the typical reason for blocking it for outgoing connections. The only effect this block has is to prevent their users from running servers.
0
 
LVL 82

Expert Comment

by:Dave Baldwin
ID: 39159805
"The only effect this block has is to prevent their users from running servers. "

Precisely.  Exactly.  In addition to the general problem of spam referred to in the Comcast message above, Comcast also sells business services where all these things are available for a premium price.  Like many other ISPs, Comcast is not interested in supporting business level traffic at consumer prices.  But I still can't get any of them to bring a fiber to my door.
0
 

Author Comment

by:timgreen7077
ID: 39159806
I believe that is really their main goal. I will contact DYNDNS tomorrow and look into mail hop. I will take so of the suggestion and test tomorrow. Thanks for everyones help and I will report on what I find as a viable fix.
0

Featured Post

IT, Stop Being Called Into Every Meeting

Highfive is so simple that setting up every meeting room takes just minutes and every employee will be able to start or join a call from any room with ease. Never be called into a meeting just to get it started again. This is how video conferencing should work!

Join & Write a Comment

We are happy to announce a brand new addition to our line of acclaimed email signature management products – CodeTwo Email Signatures for Office 365.
Not sure what the best email signature size is? Are you worried about email signature image size? Follow this best practice guide.
In this video we show how to create an Address List in Exchange 2013. We show this process by using the Exchange Admin Center. Log into Exchange Admin Center.: First we need to log into the Exchange Admin Center. Navigate to the Organization >> Ad…
To show how to generate a certificate request in Exchange 2013. We show this process by using the Exchange Admin Center. Log into Exchange Admin Center.:  First we need to log into the Exchange Admin Center. Navigate to the Servers >> Certificates…

743 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

11 Experts available now in Live!

Get 1:1 Help Now