Solved

sleep mode for Win 7

Posted on 2013-05-10
14
498 Views
Last Modified: 2013-05-30
I just reformatted my HD and something does not see right because even though there is an application running, the PC still goes to sleep. How do i fix that? Thanks
0
Comment
Question by:leblanc
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 4
  • 4
  • 4
  • +2
14 Comments
 
LVL 95

Accepted Solution

by:
John Hurst earned 167 total points
ID: 39157471
Go to Windows 7 Power Management and set the Sleep Modes. I set it Not to Sleep on AC (plugged in) for example. You can set it in a variety of ways here.

.... Thinkpads_User
0
 
LVL 8

Assisted Solution

by:Dipak
Dipak earned 56 total points
ID: 39157549
To adjust the power options to prevent the computer from automatically going to sleep mode after being idle for some time. Here is how it is done on Windows 7.

Power Options control panel: Start button > Control Panel > Hardware and Sound > Power Options.

On the Power Options control panel you can also create a second power plan configured this way. In Windows 7 there are three plans:

    - Balanced (sleeps in 30 minutes),
    - Power saver (15 min) and
    - High performance (Never sleep).

Two are always visible, but the third one is often hidden. The third one can be made visible by clicking "Show additional plans". To prevent the computer from automatically going to sleep, just select the "High performance" plan.

You can also just edit your current power plan:

    Go to the Power Options control panel
    On the left hand menu, select "Change when the computer sleeps"
    Change the "Put the computer to sleep" value to "Never".
0
 
LVL 1

Author Comment

by:leblanc
ID: 39157568
I want it to go to sleep when there is no applications. But when there are applications running, do not go to sleep. Will what you describe accomplishes it? Thx
0
Complete VMware vSphere® ESX(i) & Hyper-V Backup

Capture your entire system, including the host, with patented disk imaging integrated with VMware VADP / Microsoft VSS and RCT. RTOs is as low as 15 seconds with Acronis Active Restore™. You can enjoy unlimited P2V/V2V migrations from any source (even from a different hypervisor)

 
LVL 3

Assisted Solution

by:AliQahtani
AliQahtani earned 56 total points
ID: 39157909
Hi,


If there is no user interaction for a certain amount of time, then the computer will go into sleep mode even if an application is running in the background"this is how Microsoft build it" . You may have to change the power option settings accordingly.

Sleep and hibernation: frequently asked questions
http://windows.microsoft.com/en-us/windows7/Sleep-and-hibernation-frequently-asked-questions
 
Change, create, or delete a power plan (scheme)
http://windows.microsoft.com/en-US/windows7/Change-create-or-delete-a-power-plan-scheme
0
 
LVL 95

Assisted Solution

by:John Hurst
John Hurst earned 167 total points
ID: 39157942
I want it to go to sleep when there is no applications

There is always something running. Excel may be open and unused, but your Anti Virus or Windows Updates may be churning in the background

So (as noted above) the computer goes to sleep after a period of user inactivity.

If you are concerned, make the sleep process manual - not asleep until you put it to sleep. Otherwise, let it happen. It works fine.

.... Thinkpads_User
0
 
LVL 10

Assisted Solution

by:Mohammed Rahman
Mohammed Rahman earned 221 total points
ID: 39158174
Start--cmd--right click CMD and click on run as administrator.

type powercfg ? -- enter and scroll down to "-REQUESTS"  "-REQUESTSOVERRIDE" screen shot below. (please read description below -REQUESTS and -REQUESTSOVERRIDE)
sleep mode over rideNow, open task manager and go to "Processes", make a note of the process running (that should prevent computer to sleep) - Eg: if its excel.exe (just an example)

In command prompt, type the command below.

POWERCFG -REQUESTSOVERRIDE PROCESS excel.exe
** replace excel.exe with the name of process in interest.

** I have never tried this option, just read the powercfg? description and thought this might help you.
0
 
LVL 1

Author Comment

by:leblanc
ID: 39158802
I have a program that convert a video files to mkv. I have 20 files converted so it runs in the background but my PC just keeps going to sleep. I thought that if there are activities, the PC will not go to sleep. In this case, there are activities because there is a profess bar running.
0
 
LVL 95

Assisted Solution

by:John Hurst
John Hurst earned 167 total points
ID: 39158990
As noted above, the system can be running, but if there is no user interaction it will go to sleep. If you wish to prevent it going to sleep you can, then the process is under your control and not automatic.

.... Thinkpads_User
0
 
LVL 10

Assisted Solution

by:Mohammed Rahman
Mohammed Rahman earned 221 total points
ID: 39163464
As thinkpads_user said, Windows will automatically enter sleep mode if there is no user activity for defined period.

However, few programs have the ability to override sleep mode (if they are active).

Most audio/video (encoders/decoders) doesn't have the ability to override sleep mode. Hence, the PC steps into sleep mode even if they are running in back ground.

Have you tried the solution that I suggested in my previous post?

POWERCFG -REQUESTSOVERRIDE PROCESS excel.exe
** replace excel.exe with the name of process in interest.

Per description (refer the screen shot in my previous post), this command will override the sleep functionality if the selected program is running in background.
0
 
LVL 1

Author Comment

by:leblanc
ID: 39163566
The strange thing is I did not have this issue before the reformat of my hardrive.
0
 
LVL 10

Assisted Solution

by:Mohammed Rahman
Mohammed Rahman earned 221 total points
ID: 39167007
If this is the case, try perform Windows Update (to ensure all fixes are up to date) and also your video converter is updated (if applicable).

As you are experiencing this issue only after re installing Windows, chances are, Windows Update might fix this Windows 7 power management setting and over ride sleep in an event an application is running in background.
0
 
LVL 10

Assisted Solution

by:Mohammed Rahman
Mohammed Rahman earned 221 total points
ID: 39170457
Also, you can try the setting in the image below. (Not sure if this is a solution to this problem, hope this helps)
Prevent idling to sleep
0
 
LVL 95

Expert Comment

by:John Hurst
ID: 39209049
@pitachip - Thanks. I was happy to help you with this.

... Thinkpads_User
0
 
LVL 1

Author Comment

by:leblanc
ID: 39209653
Thank you.
0

Featured Post

Technology Partners: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

A list of useful business intelligence software.
Invest in your employees with these five simple steps to improve employee engagement and retention.
The viewer will learn how to successfully download and install the SARDU utility on Windows 8, without downloading adware.
The viewer will learn how to successfully download and install the SARDU utility on Windows 7, without downloading adware.

739 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question