Link to home
Start Free TrialLog in
Avatar of ZabagaR
ZabagaRFlag for United States of America

asked on

ESXI 5.1 deploy .OVF error

Hello All.  I'm using EXSi 5.1.  I performed an "export to .OVF template" on a windows 2008 R2 machine.  Now when I try to use it to Deploy OVF template I receive an error from my vSphere Client that says:

"Failed to Deploy an OVF package. Incompatible device backing specified for Device 9"

I'd like to figure out if I can fix or remove whatever component/device is hanging up the deployment and maybe edit the .ovf file.  Or worst case, if possible, use the 2 .vmdk files (1 for each disk on my virtual 2008 system) and bring my machine back from those.

What do you think?
Avatar of Andrew Hancock (VMware vExpert PRO / EE Fellow/British Beekeeper)
Andrew Hancock (VMware vExpert PRO / EE Fellow/British Beekeeper)
Flag of United Kingdom of Great Britain and Northern Ireland image

Do you still have the Windows 2008 R2 virtual machine?

I would always recommend, before deleting a virtual machine if you have Exported it to OVF, tested the Import before Deletion.

OVF deployment Import and Export is troublesome, even between VMware systems.

If you are trying to "transport" a virtual machine, I would recommend the use of VMware vCenter Converter Standalone 5.1 to complete a V2V.

see my EE Articles

HOW TO:  Synchronize changes when completing a P2V or V2V with VMware vCenter Converter Standalone 5.1
HOW TO:  P2V, V2V for FREE - VMware vCenter Converter Standalone 5.1


HOW TO:  P2V, V2V for FREE - VMware vCenter Converter Standalone 5.0

HOW TO: Improve the transfer rate of a Physical to Virtual (P2V), Virtual to Virtual Conversion (V2V) using VMware vCenter Converter Standalone 5.0

Back to your issue, if you only have the OVF and VMDKs now, the VMDKs are often compressed, and you need to re-import for them, to undergo the decompression.

Have you also tried to Import the OVF using the vSphere Web Client?
ASKER CERTIFIED SOLUTION
Avatar of ZabagaR
ZabagaR
Flag of United States of America image

Link to home
membership
This solution is only available to members.
To access this solution, you must be a member of Experts Exchange.
Start Free Trial
They are compressed.

Backup using VMware Converter or test your exports.

Are you using free ESXi?
Avatar of ZabagaR

ASKER

I think I'm just going to close this question out since I figured out what the error was caused by and fixed it in the .ovf file.
Avatar of ZabagaR

ASKER

I was able to figure out what the problem was. By searching around the web, I found similar people who had errors when there was a device listed in the .ovf file that couldn't be imported/brought back during the OVF deployment. I edited my OVF in notepad. I saw some people had problems when they created their OVF template while their guest machine had locally mapped the hosts CD rom drive. I hadn't done that. BUT - I did have the host's com1 port mapped in my guest 2008 vm.
I deleted that section out of the .ovf file. I also had to delete the .ovf checksum file - the .mf file. If you edit the .ovf file, the checksum fails on import, knowing the .ovf no longer matches the original state. Delete the .mf and you're ok.