Expiring Today—Celebrate National IT Professionals Day with 3 months of free Premium Membership. Use Code ITDAY17

x
?
Solved

Windows Server 2008 R2 Standard - Stop C00002e2 error after Acronis Backup 11.5 restore

Posted on 2013-05-12
12
Medium Priority
?
5,498 Views
Last Modified: 2016-10-27
As much relevant info as I can think of:

Major recovery problems on Windows Server 2008 R2 Standard - this particular server is a new environment to me. This guy had the server custom built bought from a client who works in IT. RAID 1 array has C: drive for OS and a P: drive for storing data, but both C and P are on the same RAID 1 array.

After an unexpected system power down, we arrive to find the client had broken the power button so we swapped the reset and power buttons, then on boot we were seeing an temp error on CPU, but no matter if you JUST booted or ran for a few hours, it's always 84deg (F) so I think it's misreporting - we told the BIOS to ignore CPU temp for now.

Meanwhile, RAID 1 array fell apart, system stopped booting, constant reboots. One of our techs ran a CHKDSK /F on the array and it found/fixed several errors, BUT we ended up with no P: drive able to be found anymore. Just "Unallocated Space" where the P: drive used to be.  Probably thanks to the CHKDSK?

Anyway, with these developments, I decided to remove the RAID array and replace with two new hard drives and NOT do RAID - I just was going to restore C: to one drive and P: to another using Acronis Backup and Recovery 11.5. I feel like this is where it got hairy. When restoring the data that was previously 2 partitions on one drive, there is an MBR for both C: and P: so I check the box for MBR 1 and 2 to restore and for Disk 1 and 2 to restore and assign them all to the appropriate disks. (after you see the error I get, maybe I should've only restored the MBR for C: drive and restored P: drive data to second drive? i don't know......)

Upon reboot, you load up, see a black screen and the cursor arrow in the middle of the screen for a few minutes, and then blue screen. After disabling auto restart, I see it says "STOP: c00002e2 Directory Services could not start because of the following error: A device attached to the system is not functioning. Error Status: 0xc0000001. Please shutdown this system and reboot into Directory Services Restore Mode, check the event log for more detailed information."

So I boot into DSRM and followed instructions found here to check the disks and make sure they are assigned correct drive letters. They are both C: and P: in DSRM just as they should be....

My next best guess is maybe the Intel Rapid Storage Software that runs when you boot into windows that tells you the status of your RAID array and if it's degraded, it attempts to rebuild and report the status to you. I mean, I'm not even getting to CTRL + ALT + DEL screen in normal mode so I can't really tell...

Where should I look in DSRM mode to get more info and fix this? Event viewer? Device Manager? This is a real puzzle to us. Thanks for your insight, guys
0
Comment
Question by:fecklessness
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 5
  • 3
  • 3
  • +1
12 Comments
 
LVL 12

Expert Comment

by:S00007359
ID: 39160254
when u did the restore, did u use the option to perform a restore using the Universal recovery mode.

also, when u have restored, have u changed the partition labels or drives names to how it actually was.

did u also has a recovery partition on the raid?
0
 
LVL 12

Expert Comment

by:S00007359
ID: 39160260
is this case, it appears that the disk are not initialised, or brough tonline.

when u get into DSRM mode , get into Device Manager, Disk Management and check if the disk are online, or initialised!, then reboot it.
0
 

Author Comment

by:fecklessness
ID: 39160291
thanks for replying. no i did not do universal restore mode. i did not change partition labels or drive letters compared to how it was.

how would i check that they are "initialized" as you put it? according to these instructions that makes no sense for me, because i went in to DSRM, Server Manager> Storage> Disk Management> and saw they had drive letters assigned same as they were before (C: and P:), were allocated correct space, it said "active, primary partition" and some other things - what more should i be looking for? i'm at home now, not at the office so i can't dig into this immediately, just thought i would reply while someone was looking at this. thanks
0
Complete VMware vSphere® ESX(i) & Hyper-V Backup

Capture your entire system, including the host, with patented disk imaging integrated with VMware VADP / Microsoft VSS and RCT. RTOs is as low as 15 seconds with Acronis Active Restore™. You can enjoy unlimited P2V/V2V migrations from any source (even from a different hypervisor)

 
LVL 12

Expert Comment

by:S00007359
ID: 39160332
okay, so i see, on aanother server, u will see that there is a system partition, called system reserve! this partition needs to be restored first!


1.In general, System Reserved partition should be selected when restoring system disk


The basic process is:
 1. Restore the System Reserved partition to the disk first,
2. Restore the boot partition (with Windows install)
3. Restore any other data volumes.


see here:

http://kb.acronis.com/content/16249
http://www.storagecraft.com/support/forum/windows-7-system-reserved-partition-restoring-and-virtual-machine-creation
0
 
LVL 47

Expert Comment

by:noxcho
ID: 39160600
Indeed, you drives are initialized. As you pointed it already they are formatted and having drive letters assigned. IMHO the problem is caused by Active Directory. It detected that hardware has been changed and thus refuses to run from this new configuration. Have you taken system state backup as well?
0
 
LVL 8

Expert Comment

by:teomcam
ID: 39160865
Since you have an Acronis backup all you need to follow the steps below. With my all respect to others.
1- I assume you finished RAID config and have run the consistency check patiently.
2- Put the Acronis cd and boot with it.
3- Go to Navigation menu and delete all partition and commit the task. This wil remove all partitions from your RAID volume and you will have unallocated drive. Attach your backup source (usb external or where ever your .tib file is)
4- On the destination section select your RAID volume and add all partitions from your backup one by one.
Note: If you are restoring the backup to the same machine please Go to step 6
5- If you are restoring to a different hardware choose Universal Restore option from drop down menu. (If you did not purchase this module separately, it will not be visible anywhere on the screen)
6- Hit the restore button and allow it to  automatically generate a new unique NT signature.
After recover and reboot, your machine will;
a)show you Ctrl+Alt+Screen, if its the same hardware
b)ask you drivers for the new hardware
0
 

Author Comment

by:fecklessness
ID: 39161057
S00007359 - you are off base with the "System Reserve Drive" and same for noxcho - I do not need an additional system state backup with Acronis. It's a full image of each disk, with all partitions, MBR, etc. If you are familiar with Acronis, you know what I'm talking about.

teomcam - The server was using RAID0. I am using the same hardware so Universal Restore is not required. Also AD should not be thrown off because it's the same exact configuration, just new hard drives. Since RAID0 was not working, we have now tried changing to IDE turning off RAID, using single drives to restore C: and P: to, it stripped all drivers using Acronis Universal Restore and STILL gave the same reaction of a black screen with arrow cursor, then C00002e2 error.

So it's definitely something with AD, but what could it be? Like I said, same hardware setup! I'm baffled! Would something being wrong with the motherboard cause an issue like this.
0
 
LVL 47

Accepted Solution

by:
noxcho earned 2000 total points
ID: 39161113
There are many guides on treating this problem. I was asking for system state backup because it is required when you restore the domain backup to the same machine again. I am familiar with Acronis and other backup software but still they are not Microsoft built backup tools and sometimes additional system state backup & recovery is required.
Check these links:
http://support.microsoft.com/kb/2737463
http://martijnwestera.blogspot.de/2013/01/stop-c00002e2-directory-services-could.html
0
 

Author Comment

by:fecklessness
ID: 39161132
I noticed the IT guy who sold this to him did setup a Windows System Backup to go to a separate partition, it's in VHD format. Maybe this has system state backed up in it, how would I go about checking?

I will complete current restore I am working on and login to DSRM and report what error messages it gives on booting into normal mode from the Event Log. I'll try to see if anything is relevant from either of the two links you posted, noxcho. Thanks for the input so far.
0
 

Author Comment

by:fecklessness
ID: 39161165
noxcho - http://support.microsoft.com/kb/2737463 - that article makes no sense because no admin attempted to remove the DirectoryServices-DomainController role so that can't add to this dialogue as I see it. going to follow through on the other article now.
0
 

Author Closing Comment

by:fecklessness
ID: 39161385
http://martijnwestera.blogspot.de/2013/01/stop-c00002e2-directory-services-could.html

That article solved it. The results didn't exactly mirror the guide, seems like the NTDS.DIT needed repair. That did it! THANKS!!!!
0
 
LVL 47

Expert Comment

by:noxcho
ID: 39161676
Glad to hear it helped.
Take care
Nox
0

Featured Post

Comprehensive Backup Solutions for Microsoft

Acronis protects the complete Microsoft technology stack: Windows Server, Windows PC, laptop and Surface data; Microsoft business applications; Microsoft Hyper-V; Azure VMs; Microsoft Windows Server 2016; Microsoft Exchange 2016 and SQL Server 2016.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Here's a look at newsworthy articles and community happenings during the last month.
The recent Petya-like ransomware attack served a big blow to hundreds of banks, corporations and government offices The Acronis blog takes a closer look at this damaging worm to see what’s behind it – and offers up tips on how you can safeguard your…
This tutorial will walk an individual through the steps necessary to configure their installation of BackupExec 2012 to use network shared disk space. Verify that the path to the shared storage is valid and that data can be written to that location:…
To efficiently enable the rotation of USB drives for backups, storage pools need to be created. This way no matter which USB drive is installed, the backups will successfully write without any administrative intervention. Multiple USB devices need t…
Suggested Courses

730 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question