• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 1807
  • Last Modified:

Exchange VSS writer missing (Exchange 2007 on Server 2003 R2 64)

Exchange VSS writer missing (Exchange 2007 on Server 2003 R2 64)
Please help me figure this out.  I cannot see an Exchange writer listed for Exchange 2007 when I run the "vssadmin list writers" command.  I have tried repairing with the following

1. Re-registered VSS library (DLLS)
2. CHecked registry for enabled Exchange writer http://www.storagecraft.com/support/kb/article/48
3.  Attempted to manually register the Exchange writer exwriter.dll


Thank you.
0
mrcannon
Asked:
mrcannon
  • 4
  • 3
1 Solution
 
Skyler KincaidNetwork/Systems EngineerCommented:
Do you have the most recent version of your backup software installed. I have seen this specific program have issues when the software is out-of-date because they release patches that fix issues like you described.

The StorageCraft forums are also full of stories about how updating the software fixed the issue. Would be another good thing to check.
0
 
mrcannonAuthor Commented:
Thank you xKincaidx.  I will check StoragCraft forum.  Do you have a link to a good example?
0
 
Skyler KincaidNetwork/Systems EngineerCommented:
I am not saying I have seen a forumf this exact situation but similar
0
Independent Software Vendors: We Want Your Opinion

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

 
mrcannonAuthor Commented:
No luck with the update of StorageCraft.  I did reinstall, however it was already the latest version.  I would believe that the Exchange VSS writer would be a component install of Exchange 2007 as opposed to third party backup software.  A previous and uninstalled instance of Backup Exec is what I suspect removed/damaged the Exchange VSS writer, but I have not found any complaints similar to this posted.  

Further brainstorming welcome and encouraged.
Thank you so much - MrCannon
0
 
Skyler KincaidNetwork/Systems EngineerCommented:
Here is a comment from on older EE post:

Check the registry for this key:

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\MSExchangeIS\ParametersSystem\Disable Exchange Writer

If its there and set to 1, set it to 0 and resart the Information Store.  Also try running regsvr32 against exwriter.dll.

You could try that. Here is a link to the post:

http://www.experts-exchange.com/Software/Server_Software/Email_Servers/Exchange/Q_21603093.html
0
 
mrcannonAuthor Commented:
I like it.  I will try it this evening.
0
 
mrcannonAuthor Commented:
Hello  xKincaidx.

  I am noticing now that you referenced a step I had already taken in the beginning of this thread.  BUT, it did cause me to revisit the registry key which in turn allowed me to see something I had not seen before.

The registry key was there and set to zero, however the registry  key seemed odd to me because it was a reg_binary key.  I Googled a bit and found that it is supposed to be reg_dword.  Deleted and recreated as reg_dword, restarted Exchange store and bingo - exchange writer is back.

Giving you some points for sending me back in the right direction - thank you.
0

Featured Post

Creating Active Directory Users from a Text File

If your organization has a need to mass-create AD user accounts, watch this video to see how its done without the need for scripting or other unnecessary complexities.

  • 4
  • 3
Tackle projects and never again get stuck behind a technical roadblock.
Join Now