Can I turn off touch and other Surface Pro tablet features when running certain desktop applications?

I found my self holding a camera in one hand and my Surface Pro in the other today. I was attempting to retake a 100 year old picture. I was using the Surface to display the old picture so I could use it as a reference to frame my shot.

I am using the Surface in Desktop mode and am running the Canon EOS Utility to control my camera.

I ran into 3 problems.

#1 I couldn't hold the Surface for any reasonable period of time before my thumb accidentally activated some touch feature, usually around the task bar and usually resulting in the current window losing focus or changing to a completely different window.

Is there a way to deactivate touch temporarily so I can use the Surface one-handed and not have to worry about my fingers and thumb slipping and accidently activating something?

#2 The display kept flipping and switching between landscape and portrait. I imagine it's designed to do this but I'd like to be able to turn this off when I in one-handed mode. Is this possible and if so, where do I find the settings?

#3 The screen kept dimming. It was a partly cloudy day and the sun was coming in and out every few minutes. Can I turn off the screen dimming feature?

Thanks
ou81aswellAsked:
Who is Participating?
 
Gary CaseConnect With a Mentor RetiredCommented:
I don't have a tablet running Windows 8, and the settings are slightly different with a desktop, but nevertheless ...

(1)  I don't believe you can disable touch on a "per application" basis, but you can disable it altogether, using one of two methods (both won't work on all systems, so you need to determine which works for yours):

(a)  Go to Control Panel - Hardware and Sounds; select Pen and Touch;  go to the Touch tab;  uncheck the "Use your finger as an input device" box; click Apply and OK.

(b)  Go to Device Manager;  expand the list by Human Interface Devices;  click the touch screen driver; right-click and click on Disable;  click Yes on the dialog.

Obviously to re-enable touch you reverse whichever one you did :-)

(2)  WIN + O  (Windows key plus "O") will toggle the on/off state of Auto Rotation :-)

(3)  Go to Power Options [Screen Saver - then power options];  disable "Adaptive brightness";  and in the Advanced power settings set "Dim the display" to Never.    You can also set the brightness here to whatever level you like.
0
 
ou81aswellAuthor Commented:
Thanks. I wish there was a "safety" switch on the side.

Good to know about Win + O. I'll remember it as Wino.

I couldn't find an adaptive brightness setting but could lengthen the time it waits before dimming from its default setting of 2 minutes. I could also adjust the times for blanking the screen and going to sleep, which I swear it did to me today while I was dragging a slider inside my camera's classic windows desktop app.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.