• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 582
  • Last Modified:

Prevent logging into Linux Ubuntu 12.04 without password

I have just set-up a new web server using Ubuntu 12.04 and configured it to allow remote connections so that I will be able to configure the machine remotely.  One thing that I have noticed is that for some reason, I am able to connect to the console session of the machine without a password.  This is not good.  If I can connect without a password, that means someone else can.

What do I need to change to make sure that users cannot login to the Linux Ubuntu 12.04 web server without using a password?

Thanks.
0
DanielAttard
Asked:
DanielAttard
  • 5
  • 3
1 Solution
 
MazdajaiCommented:
How to connect to session? What account?
0
 
DanielAttardAuthor Commented:
I changed the security setting to confirm each access to the machine.  Without this setting checked off, I seemed to be able to connect to the console session of the machine without specifying any account or password.
0
 
MazdajaiCommented:
Sorry, I am not following what you mean by remote connections - do you mean remote desktop into the server without a password? Can you post a screenshot?
0
Free Tool: Site Down Detector

Helpful to verify reports of your own downtime, or to double check a downed website you are trying to access.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

 
DanielAttardAuthor Commented:
What I was talking about were the Desktop Sharing Preferences.  I did not realize the security implications of allowing others to view the desktop, but checking the box to "Confirm each access to this machine".  Without that checkbox, I was permitting unrestricted access to the box which was obviously a bad thing.
0
 
MazdajaiCommented:
Under Remote Desktop Preferences, have you set a password under the security section?

Is there a reason you want to use remote desktop instead of ssh?
0
 
DanielAttardAuthor Commented:
The only reason I am using remote desktop is because I am not comfortable enough to do everything I need to do from the command line with ssh.   I want to be able to use the GUI.
0
 
serialbandCommented:
Just a note:

I believe that the Ubuntu Remote Desktop is plain old VNC which is not encrypted.  It shouldn't be used over the general internet because the password is sent in plain text.  You should only use the VNC tools on a local subnet you trust.  There are other ways to connect that are safer.  Use ssh with -X (capital X) to forward X11 and you can start your GUI tools remotely over an encrypted channel.  Or install nomachine, which uses ssh, & use the nxclient to connect.

It's good to have the GUI at the beginning, but don't rely it on it for everything.  It's good for the one off setting when you're a beginner.  There's a lot of things that can be more quickly done once you learn to script them on the command line, especially if you have a lot of systems to manage.
0
 
MazdajaiCommented:
Can you post your remote desktop setting?
0
 
MazdajaiCommented:
It sounds like you did not have password set on the remote control / view section. Need to check on my lab machine.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

Get your problem seen by more experts

Be seen. Boost your question’s priority for more expert views and faster solutions

  • 5
  • 3
Tackle projects and never again get stuck behind a technical roadblock.
Join Now