Solved

Configure CIsco router for VLANS

Posted on 2013-05-13
10
640 Views
Last Modified: 2013-05-14
I would like to know how to configure cisco router in the following scenarios:

Scenario 1:

We have layer 2 switches, configured with Vlans 10,20,30,40,50
we have windows DHCP Server, DNS Server  in Vlan 10 configured with static IP addresses, we have also some workstatyions plugged to Vlan10 that should get their IP from DHCP.
In this case , I believe I need to configure one port of the Layer2 switch as a Trunk and connect to the router port. once this done, how should I configure my router ?


Scenario 2:
the same as Scenario one, except that I need to replace Layer2 switch with Layer 3 switch.

Please post the configuration of the router for both scenarios

Thank you
0
Comment
Question by:jskfan
  • 5
  • 4
10 Comments
 
LVL 7

Assisted Solution

by:tolinrome
tolinrome earned 120 total points
ID: 39161443
I'm a little confused as to what your goal is, can you please be a little more specific?

I  think your goal is to have dhcp available on vlan 10 as well in scenario 1?
As long as in Windows DHCP you have the IP subnet that vlan 10 has been assigned it will issue dhcp ip addresses for that vlan. On the layer 2 switch and layer 3 switch make sure you use the "ip helper" command.

iphelper dhcpserveripaddress
then do a show run interface vlan x - verify the running configuratation



To trunk:

the layer 3 switch:
sw# vlan dot1q tag native
sw(config-if)# switchport mode trunk
sw(config-if)# switchport trunk native vlan #
sw(config-if)# switchport trunk allowed vlan all

the layer 2 switch:
sw(config-if)# switchport mode trunk
sw(config-if)# switchport trunk native vlan #
0
 
LVL 50

Expert Comment

by:Don Johnston
ID: 39161457
I believe I need to configure one port of the Layer2 switch as a Trunk and connect to the router port. once this done, how should I configure my router ?
Create subinterfaces on the router for each VLAN.

int f0/0.1
 encap dot1q 1 native
 ip address 192.168.1.1 255.255.255.0
int f0/0.10
 encap dot1q 10
 ip address 192.168.10.1 255.255.255.0
int f0/0.20
 encap dot1q 20
 ip address 192.168.20.1 255.255.255.0
etc....

Open in new window


the same as Scenario one, except that I need to replace Layer2 switch with Layer 3 switch.
No trunk, just create SVI's for each VLAN
interface vlan 10
 ip address 192.168.10.1 255.255.255.0
 no shut
interface vlan 20
 ip address 192.168.20.1 255.255.255.0
 no shut
etc...

Open in new window

0
 

Author Comment

by:jskfan
ID: 39162636
Ok...if I understand it is mandatory to configure IP helper "DHCP IP address" in both scenarios...?

IP helper "DHCP IP Address", should be configured a the router global configuration ?
0
 
LVL 50

Expert Comment

by:Don Johnston
ID: 39162695
Not in the scenario that you outlined.

we have windows DHCP Server, DNS Server  in Vlan 10 configured with static IP addresses, we have also some workstatyions plugged to Vlan10 that should get their IP from DHCP.

Since the DHCP server and the DHCP clients are on the same network, there is no need for an ip helper.
0
 

Author Comment

by:jskfan
ID: 39162752
what about other computers that are in Vlans 20,30,40,50. they are not in same vlan as the DHCP server ???
0
Threat Intelligence Starter Resources

Integrating threat intelligence can be challenging, and not all companies are ready. These resources can help you build awareness and prepare for defense.

 
LVL 50

Expert Comment

by:Don Johnston
ID: 39162758
Then you'll need ip helper-address statements on the interfaces for those VLANs.
0
 

Author Comment

by:jskfan
ID: 39162882
So IP Helper-address can be configured at the sub-interface (for each Vlan) level as well as at the global configuration level ?
0
 
LVL 50

Accepted Solution

by:
Don Johnston earned 380 total points
ID: 39163061
ip helper-address is an interface configuration mode command. Apply it on any interfaces which have hosts that need to communicate with a DHCP server.
0
 

Author Comment

by:jskfan
ID: 39163833
Thanks Donjohnston !!
0
 

Author Closing Comment

by:jskfan
ID: 39163839
Thank you all Guys!
0

Featured Post

How your wiki can always stay up-to-date

Quip doubles as a “living” wiki and a project management tool that evolves with your organization. As you finish projects in Quip, the work remains, easily accessible to all team members, new and old.
- Increase transparency
- Onboard new hires faster
- Access from mobile/offline

Join & Write a Comment

There are two basic ways to configure a static route for Cisco IOS devices. I've written this article to highlight a case study comparing the configuration of a static route using the next-hop IP and the configuration of a static route using an outg…
I recently attended Cisco Live! in Las Vegas, a conference that boasted over 28,000 techies in attendance, and a week of hands-on learning hosted by a solid partner with which Concerto goes to market.  Every year, Cisco displays cutting-edge technol…
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…

758 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

22 Experts available now in Live!

Get 1:1 Help Now