Link to home
Start Free TrialLog in
Avatar of SJATechsupport
SJATechsupportFlag for United States of America

asked on

Windows cannot connect to the printer operation failed with error 0x000003ab

Windows 7 x64. When trying to add a printer I receive error 0x000003ab. Please advise
Avatar of AdrienneSperber
AdrienneSperber
Flag of United States of America image

Go to the printer manufacturers website, find your printer, and download the printer driver for Windows 7 64 bit
Avatar of SJATechsupport

ASKER

It's not a driver issue - it happens with any printer I try to add. They're all networked printers attached to a Windows Server 2008 Print server
Avatar of sfields11
sfields11

The server most likely has 2 different types of print drivers associated witht the print queues you are trying to access - one for x64 and oen for x86. From the server, go to Print manager and check to make sure that both the x64 and x86 driver types are the EXACT same version level. If they do not match up, bring the lower version up to match the higher installed version. Restart print spooler service on the server, and attempt to connect again.
The printer drivers are the same version on the print server - nothing has changed on the back end. One day the user was able to print, the next day she wasn't
Check the same thing on the user's PC - make sure she has the same version of the driver that the server has, and that she didnt get a different copy from another source. 9 times out of 10 that is the issue when we see this problem. If they match up there also, try completely deleting all printers and drivers from problemPC, give it a reboot, and try reconnecting one or 2 printers and see if the problem remains.
Removed all printers and drivers, restarted the print spooler, restarted the computer, tried to reinstall the printer and it failed. I downloaded the driver from the manuf (xerox, in this case) website and tried to install it that way and it still failed, doesn't work with my HP printers either.. :(
ASKER CERTIFIED SOLUTION
Avatar of sfields11
sfields11

Link to home
membership
This solution is only available to members.
To access this solution, you must be a member of Experts Exchange.
Start Free Trial
Still unable to install the printer, I keep getting error 0x000003eb. Doesn't matter what printer or driver I use. Other computers can connect to the print server, download the driver, and print fine so it's something wrong with the client computer but I can't figure out what.
Erm.. it appears that even through deleting the drive in the registry and the print server settings didn't help, going into the windows/system32/spool/drivers folder and deleting the driver files there DID do the trick. thanks!
You can try running cleanspl.exe (part of Windows server resource kit) to wipe everything clean, then try again. That would be my next move.
Awesome, glad to hear! In the future, that Cleanspl.exe utility will do that for you though, just FYI.
Good to know! Will definitely add that to my toolkit. Cheers!