Link to home
Create AccountLog in
Avatar of cpeele
cpeele

asked on

Slow upload on 25/25 fiber

Our company had 3 T1s and we were getting about 2.5 upload and download. We have now switched over to a fiber line that is rated at 25 up and down. We are getting about 22 down so that is good. However we are barely getting 1Mbps UP which is very odd. Can you help me out with some suggestions on what might be causing this, in your experience?

Let me just add that when we connect directly to the fiber the upload is correct, so it's something in our equipment. The speed is tested with speedtest.net

Thanks!
Avatar of asavener
asavener
Flag of United States of America image

Are you using ASA with the IPS module?

According to this thread (https://supportforums.cisco.com/thread/2081067) there is a bug (CSCsv69844).

Workaround is to set the Regex Depth Setting to 800000.

Instructions here:  http://tools.cisco.com/Support/BugToolKit/search/getBugDetails.do?method=fetchBugDetails&bugId=CSCsv69844
Avatar of cpeele
cpeele

ASKER

We are using a PIX 515E. Maybe there is a similar issue? I will do a google search
The bug I reference only affects environments that have the IPS module, but I  expect that it affects PIX units with the IPS module, as well.

You can try disabling the IPS module (or not sending traffic to the IPS module) in order to test if it is the component causing the slow traffic.
Avatar of cpeele

ASKER

We are not using IPS. I also checked duplex settings as some articles mentioned that and they are 100full. Any other suggestions?
SOLUTION
Avatar of asavener
asavener
Flag of United States of America image

Link to home
membership
Create an account to see this answer
Signing up is free. No credit card required.
Create Account
SOLUTION
Link to home
membership
Create an account to see this answer
Signing up is free. No credit card required.
Create Account
Avatar of cpeele

ASKER

OK! Here is what we've found: We have a Cisco 3550 switch (our equipment) where fa0/15 goes to an Adtran NetVanta 4430 (ISP equipment). Fa0/15 on the Cisco switch has dropped down to half-duplex. This has got to be the problem. Or at least a problem. Now the question is why? The Cisco port is set to Auto Duplex, and when I force it to Full, it shuts the port. I assume the NetVanta is set to Auto, but even if it was forced to Full, it should work when I change the Cisco side, right?
In this case , better have them both in Full, as long they matching speed, and set speed manually as well.
Otherwise lowest speed between two should be set.
Avatar of cpeele

ASKER

Right, but I have tried the Cisco on Full and Auto, and either way, the port shuts down/disables. I don't understand that because the NetVanta has got to be either Full or Auto right? I don' think they'd set it to half. In any case, we do not have access to the NetVanta so I can't check it. I would have to get the ISP to do that. I will call them if I need to but it's new equipment just put in, I just wanted to see if there was anything I could do on my end first.
First thing is to try replacing the cable.

Second thing to try is a different port on the switch.

Third thing is to confirm the port setting with the ISP.
Avatar of cpeele

ASKER

Tried a different switch port, so I will try the cable, then contact ISP. thank you
Thought of another test.

Connect another device directly to the NetVanta and see what the port settings are.

Then move that back to where the switch is, and connect to the cable to that goes to the NetVanta and see what port settings you get.
ASKER CERTIFIED SOLUTION
Link to home
membership
Create an account to see this answer
Signing up is free. No credit card required.
Create Account
SOLUTION
Link to home
membership
Create an account to see this answer
Signing up is free. No credit card required.
Create Account
Avatar of cpeele

ASKER

Thanks for the tips guys! In the end, it was good old fashioned observation of switch lights and server monitor that told us about the duplex mismatch. Moral of the story - always go and physically check your server room for lights!