Still celebrating National IT Professionals Day with 3 months of free Premium Membership. Use Code ITDAY17

x
?
Solved

C# DLL issue

Posted on 2013-05-13
5
Medium Priority
?
2,442 Views
Last Modified: 2013-05-18
Guys,

Please help me in resolving this issue:

I am using the Microsoft.Exchange.WebServices.dll. I have referred this dll in my project and I have it in my using statement in the .cs file. When I run the application I get the below error. I dont get any compile time error. I get the error during run time. I see that it is something related to resources. Please help me to resolve this issue ASAP.

Error Finding Mail box Sys_File_Request
 Message: Could not load file or assembly 'Microsoft.Exchange.WebServices.resources, Version=15.0.0.0, Culture=en-US, PublicKeyToken=31bf3856ad364e35' or one of its dependencies. The system cannot find the file specified.    at NOVUS.Imports.DataSourceManager.ImportEmails(ImportDataSource imp, DataSource ds) in C:\NovusMain\Main\Workflow\Novus.Imports\Core\DataSourceManager.cs:line 457
0
Comment
Question by:aaradhana_gk
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 4
5 Comments
 
LVL 42

Expert Comment

by:sedgwick
ID: 39162531
Did u copy the dll to the same folder as the executable of your application?
0
 

Author Comment

by:aaradhana_gk
ID: 39162606
I saw this solution in microsoft forum and I already tried it. It doesn't work.
0
 

Author Comment

by:aaradhana_gk
ID: 39162614
Also please carefully see the error. It says 'Microsoft.Exchange.WebServices.resources'. I never use any resources. Not sure what is the meaning for this error.
0
 

Accepted Solution

by:
aaradhana_gk earned 0 total points
ID: 39163423
I found the solution myself. Microsoft.Exchange.WebServices.dll is in neutral culture and my project assembly is configured as "en-US" and it it looking for Microsoft.Exchange.WebServices with the same "en-US" culture.

When I changed my assembly to neutral culture it works.
0
 

Author Closing Comment

by:aaradhana_gk
ID: 39176942
No one was able to provide me solution. I had to fight and find the solution myself.
0

Featured Post

Industry Leaders: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

It was really hard time for me to get the understanding of Delegates in C#. I went through many websites and articles but I found them very clumsy. After going through those sites, I noted down the points in a easy way so here I am sharing that unde…
If you need to start windows update installation remotely or as a scheduled task you will find this very helpful.
This is Part 3 in a 3-part series on Experts Exchange to discuss error handling in VBA code written for Excel. Part 1 of this series discussed basic error handling code using VBA. http://www.experts-exchange.com/videos/1478/Excel-Error-Handlin…
How to fix incompatible JVM issue while installing Eclipse While installing Eclipse in windows, got one error like above and unable to proceed with the installation. This video describes how to successfully install Eclipse. How to solve incompa…

721 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question