Link to home
Start Free TrialLog in
Avatar of shadowtuck
shadowtuck

asked on

Getting a strange error in IIS

Test enviironment with Windows 2008 R2 and Exchange 2010 SP3 installed. We have been playing around with authentication in IIS and SSL settings to get services to work through a load balancer. This is just test so no big issues. In IIS, when I click on the Public virtual directory and select Authentication, I get the error below:

There was an error while performing this operation.

Details:

Filename c:\Program Files\Microsoft\Exchange Server\v14\ClientAccess\Owa\web.config
Line Number : 37
Error: Configuration section not allowed to be set below application.

Line 37 reads <authentication mode="Windows" />

I Googled as usual and found an article (Not Microsoft) that say to delete this line which I did. Error went away. Question I have is why should I have to delete it to begin with. This Exchange install is about 3 months old. By deleting this line, what else will break. I am sure its there for a reason. I really don't even understand that error. Can someone elaborate please?
ASKER CERTIFIED SOLUTION
Avatar of Amit
Amit
Flag of India image

Link to home
membership
This solution is only available to members.
To access this solution, you must be a member of Experts Exchange.
Start Free Trial
Avatar of shadowtuck
shadowtuck

ASKER

Seems to me messing with the web.config file is probably not good. I made a backup of course before doing anything but I am not sure why I had to delete that line. Perhaps those virtual directories do not get used anymore. I verified the Exchange and ExchWeb do not but not sure about the Public virtual directory. All the others seem fine. Basically the ones used by Exchange 2010. I wonder if this is just normal behavior when you try to examine Authentication of those directories.
Seems to be a generic error that most people are getting. Since the VDirs it complains about are not used anymore in Exchange 2010, I just chose to ignore it.