• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 371
  • Last Modified:

RS Error when Running Through Browser

I've got a bunch of reports that work fine when I preview them in Visual Studio.  The account I'm using in the datasource is db_owner, datareader and datawriter and when i test the datasource connection, it tests fine.  However, after publishing the report and running in IE, I get the following error.  The proc exists and works fine, but it seems like it's not connecting to the DB when run through a browser.

An error has occurred during report processing. (rsProcessingAborted)
Query execution failed for dataset 'ReportDate'. (rsErrorExecutingCommand)
Could not find stored procedure 'dbo.procName'.

SQL Server 2008 R2 SP2
IE 9
0
darrennelson
Asked:
darrennelson
1 Solution
 
ZberteocCommented:
Make sure the dataset connection points to the database where the store procedure actually resides.
0
 
darrennelsonAuthor Commented:
yes, it is.  I found something strange though.  I created a new embedded data source for the data sets and one of the reports now works.  Previously, they were all using a shared data source with the exact same connection info. Maybe migrating the reports did something to the original data source.

BTW - I didn't write these reports, I'm migrating them from a 2005 instance to a 2008R2 instance.
0

Featured Post

Get expert help—faster!

Need expert help—fast? Use the Help Bell for personalized assistance getting answers to your important questions.

Tackle projects and never again get stuck behind a technical roadblock.
Join Now