Solved

Cannot Check in Excel or Word documents in SharePoint 2010 over https

Posted on 2013-05-13
8
3,635 Views
Last Modified: 2013-06-22
I have a SharePoint 2010 environment that is not allowing users to check in their Excel or Word documents over https.   Users can save their documents over http.

This is what they are experiencing:

1. click Excel document which opens in Excel.
2. User clicks 'Check Out' in Excel
3. Edit Offline Pop up appears (States that Offline document will be stored on your computer in SharePoint Drafts)
4. user clicks OK
5. User makes their changes.
6. User clicks save (which saves locally with no issue).
7. When user attempts to close Excel they are prompted to check in.
8. User clicks yes and a pop up appears for Check In version comments. User enters their
comments and click ok.
9. A bar appears as if it is updating SharePoint, but Excel does not close.
10. User attempts to close Excel again and same process is repeated from step 7 above.
11. If user Clicks No to Check in, Excel is closed.
12. The document shows as checked out in SharePoint and does contain the changes.
13. In SharePoint if the user attempts to check in a pop up appears for comments.
14. After user enters their comments and clicks ok
15. Another pop up appears notifying the user that they are about to upload the file to SharePoint, Do you want to continue. The user clicks yes.
16. The user receives the following message:

This document was checked out to your local drafts folder but the local copy could not be checked in to the site. Close any application that is editing the document and try to check in again, or discard the checkout.

Note: Excel is not open nor is the file being edited.  Ultimately, the user has to discard the check out to get rid of the lock on the file.
0
Comment
Question by:macarrillo1
  • 4
8 Comments
 
LVL 9

Expert Comment

by:kukdai
ID: 39163551
which browser you are using. have you tried with all the browsers.
0
 
LVL 9

Author Comment

by:macarrillo1
ID: 39165092
No. My users are required to use IE 8 only. Not all my users are experiencing this issue.  I have not yet found anything that sets one user apart from another, with regard to this issue.
The users that have this problem always have this problem and those that do not, never do.
0
 
LVL 9

Author Comment

by:macarrillo1
ID: 39182662
Continueing to work the problem I have discovered the following:

This problem is restricted to https only. (does not occur with http)
Only affects files that require check in or check out.  Document libraries that do not have check in do not have problems.
If you  reboot your system Excel will work the first 5 minutes that you use it before the problem occurs again.
0
Free Trending Threat Insights Every Day

Enhance your security with threat intelligence from the web. Get trending threat insights on hackers, exploits, and suspicious IP addresses delivered to your inbox with our free Cyber Daily.

 
LVL 8

Expert Comment

by:vaderj
ID: 39242474
The following settings are located in Central Administration under the Applications Management heading, Web Application Management section:

For the web application, click on Authentication Providers
Select the provider that coorosponds to your HTTPS Alternate Access Mapping  (you can check Alternate Access Mappings, which is located under Application Management, to verify which zone it is in)
Ensure that, for the Authentication Provider for your HTTPS AAM, that the "Enable Client Integration" setting is set to "Yes"
Also, in the Web Application Management section, click on the General Settings button and maybe set your "Browser File Handling" setting to "Permissive"
0
 
LVL 9

Accepted Solution

by:
macarrillo1 earned 0 total points
ID: 39253240
It appears that we found the solution.

It turns out this is an Office issue and not a SharePoint issue.  SharePoint and Office both know this is a secure site. However, Office does not get the users credentials to verify that the user has permissions to checkin or save.  The fix that worked for us was as follows:

1. Set the registry key
HKLM\SYSTEM\CurrentControlSet\Services\WebClient\Parameters\"EnableCTLFilter
ing" to 0

2. Set the WebClient service to Automatic and start.
0
 
LVL 9

Author Closing Comment

by:macarrillo1
ID: 39267760
This was a very difficult solution to come up with.  Fortunately some associate SharePoint Administrators I work with had encountered this problem before and it took them 10 months to resolve.  

I appreciate everyone's help.

Thanks!
0

Featured Post

Do You Know the 4 Main Threat Actor Types?

Do you know the main threat actor types? Most attackers fall into one of four categories, each with their own favored tactics, techniques, and procedures.

Join & Write a Comment

Suggested Solutions

Entering a date in Microsoft Access can be tricky. A typo can cause month and day to be shuffled, entering the day only causes an error, as does entering, say, day 31 in June. This article shows how an inputmask supported by code can help the user a…
Since upgrading to Office 2013 or higher installing the Smart Indenter addin will fail. This article will explain how to install it so it will work regardless of the Office version installed.
This video shows the viewer how to set up and create Footnotes in their document. Click on the References tab: Select "Insert Footnote": Type in desired text:
The viewer will learn how to simulate a series of coin tosses with the rand() function and learn how to make these “tosses” depend on a predetermined probability. Flipping Coins in Excel: Enter =RAND() into cell A2: Recalculate the random variable…

760 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

19 Experts available now in Live!

Get 1:1 Help Now