?
Solved

Exchange 2003: Two SMTP Connectors (one w/Smart Host, one w/o) Not Working As Expected

Posted on 2013-05-13
1
Medium Priority
?
491 Views
Last Modified: 2013-05-23
We are running Exchange 2003 in a simple environment (one Exchange server, no front-end server).  We use the McAfee Email Protection Service (formerly MX Logic) to scan our outbound email, which is accomplished by configuring our SMTP connector to send through a Smart Host that routes all email through McAfee.  We have a need to send all emails from one individual directly out to the Internet via SMTP rather than through McAfee.  To accomplish this, I have created a second SMTP connector that is configured to "Use DNS to route each address space on this connector."  I gave it a higher cost than our primary connector, setup the * address space, and configured the Delivery Restrictions as required to only allow emails from the user in question to send through the connector (and deny them from sending through the primary connector).  I did make the necessary change to the registry to process restrictions on the connectors.

The emails sent from that user are most definitely going through the new connector, as I can see in the "Queues" view in ESM.  However, viewing the headers of the email on the recipient end reveal that the emails are still going through McAfee.  It seems as if they use the correct connector, but still use the Smart Host setting from the primary connector.  I have confirmed that I do NOT have a Smart Host configured on the SMTP Virtual Server.

Both connectors are sharing the same Virtual Server.  Both also use the same Local Bridgehead server, of course.  Do I have to create a second VS specifically for the connector that I want to deliver directly to the Internet?  Any other suggestions?

Please let me know if there is any more information I can provide to assist in troubleshooting this.  Thanks!
0
Comment
Question by:FCTGIS
1 Comment
 
LVL 63

Accepted Solution

by:
Simon Butler (Sembee) earned 1500 total points
ID: 39171487
I haven't seen this functionality work reliably. Have you tried using a group instead of the individual to do the restriction? That seems to improve matters.

If email is still going through the smart host it could be that the smart host was set on the SMTP virtual server and while you have removed it, the server is still using it. This could be a corrupt IIS metabase for example.

A new SMTP virtual server (create through ESM) will clear that if that is the case.

Simon.
0

Featured Post

Making Bulk Changes to Active Directory

Watch this video to see how easy it is to make mass changes to Active Directory from an external text file without using complicated scripts.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Importing Outlook PST contacts to Exchange Server can become a complicated task. Situations arise where an Exchange user is not able to import contacts from PST to Exchange Mailboxes in an efficient manner. Try SysTools Exchange Import to move conta…
Fix RPC Server is unavailable Error in Exchange 2013, 2010, 2007, and 2003 Server. Different reason can such as network connectivity issue, name resolution issue, firewall, registry corruption that lead to RPC Server Unavailable error.
The video tutorial explains the basics of the Exchange server Database Availability groups. The components of this video include: 1. Automatic Failover 2. Failover Clustering 3. Active Manager
This video shows how to quickly and easily deploy an email signature for all users in Office 365 and prevent it from being added to replies and forwards. (the resulting signature is applied on the server level in Exchange Online) The email signat…

589 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question