Still celebrating National IT Professionals Day with 3 months of free Premium Membership. Use Code ITDAY17

x
?
Solved

Cisco 1841 Dual ISP *Help*

Posted on 2013-05-13
4
Medium Priority
?
574 Views
Last Modified: 2013-10-11
Hi,

I wonder if one of you experts can stop me from going mad.


I have the following setup :-

ISP BT (DHCP) <------->  (FA0/0 DIALER0)-----\
                                                                           CISCO 1841<------->VLAN 2 <--------> USER PC
ISP VM (DHCP) <------->  (FA0/1)-----------------/

I am trying to setup that all traffic from the user pc on port 80 & port 443 goes via the BT ISP and all other traffic goes via the VM ISP.

I know having two ISP's with DHCP doesn't help but is it possible ?


I must admit this is way above my head and every time I look at Google I seem to end up with a different answer,

Please help !!!!

Here is what I have currently, I have tried with routes no routes etc. and just going around in circles.

____________________________________________________________________________________________________

version 12.4


service timestamps debug datetime msec
service timestamps log datetime msec
service password-encryption
!
hostname MY-ROUTER
!
boot-start-marker
boot-end-marker
!
logging message-counter syslog
logging buffered 51200 warnings
no logging console
enable secret ********************
!
no aaa new-model
dot11 syslog
ip source-route
!
!
!
!
ip cef
no ip domain lookup
ip domain name **************
ip ips config location flash:/ips/ retries 1
ip ips notify SDEE
ip ips name sdm_ips_rule
!
ip ips signature-category
  category all
   retired true
  category ios_ips advanced
   retired false
!
no ipv6 cef
!
multilink bundle-name authenticated
!
ip ssh version 2
!
!
!
interface FastEthernet0/0
 description "Connection to BT"
 no ip address
 no ip redirects
 no ip unreachables
 no ip proxy-arp
 ip virtual-reassembly
 ip tcp adjust-mss 1452
 duplex auto
 speed auto
 pppoe enable group global
 pppoe-client dial-pool-number 1
!
interface FastEthernet0/1
 description "Connection to VM"
 ip address dhcp
 ip nat outside
 ip virtual-reassembly
 duplex auto
 speed auto
!
interface FastEthernet0/1/0
 switchport access vlan 2
!
interface FastEthernet0/1/1
!
interface FastEthernet0/1/2
!
interface FastEthernet0/1/3
!
interface Vlan1
 no ip address
!
interface Vlan2
 ip address 12.0.0.1 255.255.255.0
 ip nat inside
 ip virtual-reassembly
 ip policy route-map ROUTE-ISP
!
interface Dialer0
 ip address negotiated
 ip mtu 1454
 ip nat outside
 ip virtual-reassembly
 encapsulation ppp
 ip tcp adjust-mss 1414
 no ip mroute-cache
 dialer pool 1
 dialer-group 1
 no cdp enable
 ppp authentication pap chap callin
 ppp chap hostname *******************
 ppp chap password 7 **********
 ppp pap sent-username ************ password 7 *********
!
ip forward-protocol nd
ip route 0.0.0.0 0.0.0.0 Dialer0
ip route 0.0.0.0 0.0.0.0 FastEthernet0/1
!
!
ip nat inside source route-map BT interface Dialer0 overload
ip nat inside source route-map VM interface FastEthernet0/1 overload
!
ip access-list extended BT
 permit tcp any any eq www
 permit tcp any any eq 443
 !
!
ip access-list extended VM
 deny   tcp any any eq www
 deny   tcp any any eq 443
 permit ip any any
!
access-list 1 permit 12.0.0.0 0.0.0.255
!
!
!
!
route-map ROUTE-ISP permit 10
 match ip address BT
 set interface Dialer0
!
route-map ROUTE-ISP permit 30
 match ip address VM
 set interface FastEthernet0/1
0
Comment
Question by:Mongo Peck
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 2
  • 2
4 Comments
 
LVL 2

Accepted Solution

by:
pablito70 earned 2000 total points
ID: 39163380
Hello,
from which DHCP you want or you need connect to ?
You may have to look for helper-address configured.

Try to keep

ip route 0.0.0.0 0.0.0.0 Dialer0

and remove only

ip route 0.0.0.0 0.0.0.0 FastEthernet0/1

HTH
0
 

Author Comment

by:Mongo Peck
ID: 39163391
I need to connect to both depending on the traffic www etc

thank you in advance
0
 

Author Comment

by:Mongo Peck
ID: 39163438
still not working.  Its seems to be the routes when things go messy ?




Interface                  IP-Address      OK? Method Status                Protocol
FastEthernet0/0            unassigned      YES NVRAM  up                    up
FastEthernet0/1            **.**.**.**     YES dhcp up                    up
FastEthernet0/1/0          unassigned      YES unset  up                    up
FastEthernet0/1/1          unassigned      YES unset  up                    down
FastEthernet0/1/2          unassigned      YES unset  up                    down
FastEthernet0/1/3          unassigned      YES unset  up                    down
Vlan1                      unassigned      YES NVRAM  up                    down
Vlan2                      12.0.0.1        YES NVRAM  up                    up
NVI0                       unassigned      YES unset  administratively down down
Virtual-Access1            unassigned      YES unset  up                    up
Virtual-Access2            unassigned      YES unset  up                    up
Dialer0                    **.**.**.**  YES IPCP   up                    up


route-map ROUTE-ISP, permit, sequence 10
  Match clauses:
    ip address (access-lists): BT
  Set clauses:
    interface Dialer0
  Policy routing matches: 3754 packets, 306209 bytes
route-map ROUTE-ISP, permit, sequence 30
  Match clauses:
    ip address (access-lists): VM
  Set clauses:
    interface FastEthernet0/1
  Policy routing matches: 1155 packets, 147413 bytes
0
 
LVL 2

Expert Comment

by:pablito70
ID: 39174028
0

Featured Post

Supports up to 4K resolution!

The VS192 2-Port 4K DisplayPort Splitter is perfect for anyone who needs to send one source of DisplayPort high definition video to two or four DisplayPort displays. The VS192 can split and also expand DisplayPort audio/video signal on two or four DisplayPort monitors.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

How to set-up an On Demand, IPSec, Site to SIte, VPN from a Draytek Vigor Router to a Cyberoam UTM Appliance. A concise guide to the settings required on both devices
Shadow IT is coming out of the shadows as more businesses are choosing cloud-based applications. It is now a multi-cloud world for most organizations. Simultaneously, most businesses have yet to consolidate with one cloud provider or define an offic…
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…
Suggested Courses

722 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question