Solved

Lync 2013 Mobility Not Getting Meeting Information

Posted on 2013-05-14
3
949 Views
Last Modified: 2013-06-03
Hello,

We have Lync 2013 (onsite) installed with a TMG rule to allow Mobility (logging in on device clients). We are able to log in OK and start all Lync features, however the Meeting information will not display on anything APART from iOS devices.

it says - Cannot contact exchange. From what I understand its trying to contact the EWS. we have a rule to allow access to EWS & Auto discover. the authentication delegation is set to Basic and allows access on HTTP & HTTPS to autodiscover.domain.com.

Looking at the logs on my phone it is bringing up the TMG authentication page when trying to get to autidiscover.tedbaker.com.

 I've not copied the whole log in as its quite large, this is the EWS part, I have included where it loading that log in page.


2013-05-07 16:11:08.049 Lync[224:2176] INFO TRANSPORT TransportUtilityFunctions.cpp/907:<ReceivedResponse>
POST https://autodiscover.domain.com/cookieauth.dll?getlogon?curl=z2fautodiscoverz2fautodiscover.xml&reason=0&formdir=3
Request Id: 039BB748
HttpHeader:Cache-control no-cache,max-age=0,must-revalidate
HttpHeader:Connection close
HttpHeader:Content-Length 8216
HttpHeader:Content-Type text/html
HttpHeader:Pragma no-cache
HttpHeader:StatusCode 200

<!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.0 Transitional//EN">

!!!!!!!!!!!!!!!!!!!!!<THIS IS WHERE IT LOADS THE TMG LOG IN PAGE>!!!!!!!!!!!!!!!!!!!!!!!!!!!

2013-05-07 16:11:08.049 Lync[224:2176] ERROR UTILITIES ..\..\..\platform\xmlParser\privateWp\CXmlParser.cpp/545:m_pIXmlReader->Read() failed :hr=0xC00CEE4F
2013-05-07 16:11:08.049 Lync[224:2176] INFO UTILITIES CXmlParser.cpp/181:parse returned 536870913
2013-05-07 16:11:08.049 Lync[224:2176] ERROR TRANSPORT ..\..\..\ucmp\transport\ewsAutoDiscover\private\CEwsAutoDiscoverRequest.cpp/227:Unable to get response from Ews AutoDiscover server


Could anyone point my in the right direction on whats wrong please?
0
Comment
Question by:UBB
  • 2
3 Comments
 
LVL 3

Expert Comment

by:Chretien TALOM
ID: 39193533
Hi,

Could you check again if the autodiscover is proper set up? Check as well if your TMG is blocking or denying the connection or any firewall.

Thanks
Chretien
0
 

Accepted Solution

by:
UBB earned 0 total points
ID: 39206904
We ended up creating a new listener, this one used no delegation, client may authenticate directly. Autodiscover now works
0
 

Author Closing Comment

by:UBB
ID: 39215676
Listener and TMG rule should not have basic authentication as Lync is unable to support it on the mobile devices
0

Featured Post

Free Tool: SSL Checker

Scans your site and returns information about your SSL implementation and certificate. Helpful for debugging and validating your SSL configuration.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Following basic email etiquette rules will help you write a professional email and achieve a good, lasting impression with your contacts.
A list of top three free exchange EDB viewers that helps the user to extract a mailbox from an unmounted .edb file and get a clear preview of all emails & other items with just a single click on mailboxes.
This video discusses moving either the default database or any database to a new volume.
Access reports are powerful and flexible. Learn how to create a query and then a grouped report using the wizard. Modify the report design after the wizard is done to make it look better. There will be another video to explain how to put the final p…

829 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question