Solved

Database disappears from Exchange System Manager after restore

Posted on 2013-05-14
19
201 Views
Last Modified: 2013-05-31
Hi, after restoring an Exchange Server 2003 databse it fails to show up in system manager and also does not mount. However, there are three other databases on in the First Storage Group but these mount ok. The other three were not part of the ones that needed to be restored. Please assist
0
Comment
Question by:kitsao
  • 12
  • 7
19 Comments
 

Author Comment

by:kitsao
ID: 39164321
I should add that the message that appears in the Application log is
Event ID 9175

The MAPI call 'OpenMsgStore' failed with the following error:
The Microsoft Exchange Server computer is not available.  Either there are network problems or the Microsoft Exchange Server computer is down for maintenance.
The MAPI provider failed.
Microsoft Exchange Server Information Store
ID no: 8004011d-0526-00000000

For more information, click http://www.microsoft.com/contentredire
0
 

Author Comment

by:kitsao
ID: 39164405
FYI..I have just down an eseutil /mh on the database and the shuttdown state is clean
0
 
LVL 52

Expert Comment

by:Manpreet SIngh Khatra
ID: 39164747
Ideally you should have it in the RSG and the database added and restore over there ..... is this for a Production or your restoring to get some data ?

- Rancy
0
 
LVL 52

Expert Comment

by:Manpreet SIngh Khatra
ID: 39164758
After the restore have you checked the box "This Database can be overwritten by a restore" ?

This is very IMP on the Database properties if your gonna mount from a restored database :)

- Rancy
0
 

Author Comment

by:kitsao
ID: 39164847
The problem is this database does not show up on the Exchange System Manager so we cant change this, can it be done via registry ?
0
 

Author Comment

by:kitsao
ID: 39164873
This is in a production environment
0
 
LVL 52

Expert Comment

by:Manpreet SIngh Khatra
ID: 39164888
Sir if Database isnt visible in ESM not sure if its there or its a permissions issue on that Database ..... so i can try to fix it from ADSIEDIT :)

Are you comfortable with it ?

- Rancy
0
 

Author Comment

by:kitsao
ID: 39164923
The database is there for sure in the file system, just stopped appearing after the restore. I think I have no choice, happy to try the ADSI Edit route
0
 
LVL 52

Expert Comment

by:Manpreet SIngh Khatra
ID: 39164944
Sir are you aware what it is and something about it ?

- Rancy
0
IT, Stop Being Called Into Every Meeting

Highfive is so simple that setting up every meeting room takes just minutes and every employee will be able to start or join a call from any room with ease. Never be called into a meeting just to get it started again. This is how video conferencing should work!

 

Author Comment

by:kitsao
ID: 39164949
Please advice how to fix it via ADSI Edit
0
 

Author Comment

by:kitsao
ID: 39164993
yes
0
 
LVL 52

Expert Comment

by:Manpreet SIngh Khatra
ID: 39165012
Find the database in ADSIEDIT and then go to its Properties and Security tab and ensure that "Allow Inheritable" is checked on it

- Rancy
0
 

Author Comment

by:kitsao
ID: 39165101
Would this be under CN=Microsoft Exchange System Objects ?
0
 

Author Comment

by:kitsao
ID: 39165175
I have located it but cannot view its properties and therefore cannot modify it, can I create a new object
0
 
LVL 52

Expert Comment

by:Manpreet SIngh Khatra
ID: 39165230
Its not MESO its under Configuration partition

- Rancy
0
 

Author Comment

by:kitsao
ID: 39167244
Thanks. I believe the problem is indeed with the fact that the class attribute is missing from the database properties in ADSI Edit for this database that is not mounting. We can neither modify nor delete the entry though. How can we recreate a new one ?
0
 
LVL 52

Expert Comment

by:Manpreet SIngh Khatra
ID: 39167265
You can but this can be fixed so i will help you rather .... you can set this using Sties and Service console ....

Enable Show Service Node and do the same we did in ADSIEDIT and get to properties of the Database and Security tab and check the box for Allow Inheritable :)

- Rancy
0
 

Accepted Solution

by:
kitsao earned 0 total points
ID: 39192450
Thanks Rancy. I eneded up doing an offline restore to another server and was able to mount the database, only that now even though im able to move mailboxes from one server to another, the moved users are not able to connect to the newly moved mailboxes. I guess I have to ask a new question so context is not lost. Many thanks though
0
 

Author Closing Comment

by:kitsao
ID: 39210152
I installed a new server and restored a backup and was able to access the database so do not really know what would be the solution to the original problem
0

Featured Post

Free Trending Threat Insights Every Day

Enhance your security with threat intelligence from the web. Get trending threat insights on hackers, exploits, and suspicious IP addresses delivered to your inbox with our free Cyber Daily.

Join & Write a Comment

Suggested Solutions

Back in July, I blogged about how Microsoft's new server pricing model, combined with the end of the Small Business Server package, would result in significant cost increases for many small businesses (see SBS End of Life: Microsoft Punishes Small B…
Introduction: Sometimes when I receive a call from my users to solve their problems it is very difficult for me to found their computer IP address. Even finding their computer Host to provide remote support can be a problem.  So I resorted to Goo…
This video discusses moving either the default database or any database to a new volume.
Access reports are powerful and flexible. Learn how to create a query and then a grouped report using the wizard. Modify the report design after the wizard is done to make it look better. There will be another video to explain how to put the final p…

746 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

8 Experts available now in Live!

Get 1:1 Help Now